Introduction

 Top Next

3iMedia Call Queue Controller for SwyxWare/NetPhone enhances SwyxWare/NetPhone version 6.12 and above with powerful call queue features described below and can be parameterized to fit almost every call queue scenario. 3iMedia Call Queue for SwyxWare/NetPhone is developed as a SwyxWare/NetPhone action block, so it can be used very easily in CRM and ECR rules.


Features (call queue)

Features call queueing

 Top Previous Next
· SwyxWare/NetPhone action block, easy to implement, insert only one block to create a complete call queue
· Many call delivery scenarios:
· Dynamic call queue destination depending on amount of callers in the queue
· Dynamic call queue destination depending on call time in the queue
· Dynamic call queue destination with preferred agent groups
· Dynamic call queue destination with sequential call delivery
· Dynamic call queue destination with rotary call delivery
· Dynamic call queue destination with random call delivery
· Dynamic call queue destination with longest waiting call delivery
· Dynamic call queue destination with custom (scriptable) call delivery
· Group delivery to free agents only
· Call delivery to specific device types like SoftClient, SIP-device, H323-device, Mobile only...
· Instant call delivery to skip queuing latency, the number of delivered calls is evaluated from the number of free agents instead of delivering only the first call in queue
· Last agent delivery to deliver the call the the agents or employee the caller has been connected on his last call
· Call priority, add call to top or bottom of call queue
· Different or random music on hold for each call
· Music on hold for external caller while call is delivered internally
· Music on hold fading during announcements automatically
· Logon state checking as shown in SwyxWare/NetPhone Administration (strict checking)
· Logon state checking depending on device state such SwyxIt! or SwyxPhone (line state checking)
· Remote logon state checking from other servers running Queue Controller services
· Connect to destination or voicemail if queue is closed
· Connect to destination or voicemail if agents are logged off
· Connect to destination or voicemail on escalation timeout
· Connect to voicemail on call timeout
· Connect to destination or voicemail on selection menu
· Multiple time adjustable and repeatable announcements within the queue telling the caller to be patient
· Selection menu in queue with possibility to connect to destination, voicemail or request callback
· Simple and advanced callback request
· Announcement of caller position in the queue
· Mail notification on not delivered calls
· Mail notification on logged off condition
· Mail notification on lost calls
· Return values in ECR to determine the result of the call queue action
· Many more parameters (over 100) ...


Features (visualization)

Features web front-end

· Call queue visualization in web browser
· List of all call queues
· List of calls within the selected call queue
· List of active calls within the selected call queue
· List of callback request within the selected call queue
· List of lost calls within the selected call queue
· List of all calls in all queues
· List of active calls in all queues
· List of callback request in all queues
· List of all lost calls in all queues
· Add call info to every call (queue or global)
· Reorder calls in call queue
· Pickup calls in call queue (also possible by name key)
· Abort calls in call queue
· Display call properties for each call
· Colored status for each call
· Log on and off from groups (also possible by name key)
· Increase or reset post processing time for each user (also possible by name key)
· Global list of all calls within SwyxWare/NetPhone
· Filter for global calls list on SwyxWare/NetPhone-Users and SwyxWare/NetPhone-Groups
· Customizable layout based on tags in html code
· Number resolution in active calls list against 3iMedia Metaservices for SwyxWare/NetPhone
· Integration in SwyxIt!/NetPhone Client Webextensions
· Web based real callback feature (click callback on website and Queue Controller establishes a call with an internal agent)


Versions

Version overview

There are three different versions available

Features (Queue Controller) | Standard Version | Professional Version | Call Center Version
Number of queues | 1 | 5 | 6 to unlimited
Call forwarding | One single destination One user or group can be entered as forwarding destination | Multiple destination sets as described in chapter call forwarding destination | Multiple destination sets as described in chapter call forwarding destination
Call Logged off processing | MemberLogOn | MemberLogOn | MemberLogOn
Call queue closed processing | MemberLogOn | MemberLogOn | MemberLogOn
Call Escalation processing | MemberLogOff | MemberLogOn | MemberLogOn
Call Announcements | MemberLogOn | MemberLogOn | MemberLogOn
Call Selection menu | MemberLogOff | MemberLogOn | MemberLogOn
Call detail records logging | MemberLogOn | MemberLogOn | MemberLogOn
Groups logon / logoff | MemberLogOff | MemberLogOn | MemberLogOn
System logon / logoff logging | MemberLogOff | MemberLogOn | MemberLogOn
Simple callback | MemberLogOff | MemberLogOn | MemberLogOn
Advanced callback | MemberLogOff | MemberLogOn | MemberLogOn
Supplementary call parameters | MemberLogOff | MemberLogOn | MemberLogOn
Post processing time | MemberLogOff | MemberLogOn | MemberLogOn
Pickup calls | MemberLogOff | MemberLogOn | MemberLogOn
Persistent storage system | MemberLogOff | MemberLogOn | MemberLogOn
Features (Front-end) |  |  |
Color schemas | MemberLogOff | MemberLogOn | MemberLogOn
Move calls up, down, top | MemberLogOff | MemberLogOn | MemberLogOn
Cancel calls | MemberLogOff | MemberLogOn | MemberLogOn
Pickup calls | MemberLogOff | MemberLogOn | MemberLogOn
Add call info | MemberLogOn | MemberLogOn | MemberLogOn
Queued calls list | MemberLogOn | MemberLogOn | MemberLogOn
Active calls list | MemberLogOn | MemberLogOn | MemberLogOn
Callback list | MemberLogOff | MemberLogOn | MemberLogOn
Lost calls list | MemberLogOff | MemberLogOn | MemberLogOn
Global calls list | MemberLogOff | MemberLogOn | MemberLogOn
Groups logon / logoff | MemberLogOff | MemberLogOn | MemberLogOn
Post processing time | MemberLogOff | MemberLogOn | MemberLogOn
Option packs |  |  |
Callback | MemberLogOff | MemberLogOn | MemberLogOn


Installation

Follow these steps to install the 3iMedia Call Queue Controller for SwyxWare/NetPhone on the swyx server.

· Logon locally with administrative privileges
· Ensure that Microsoft .Net Framework 3.5 incl. all service packs is installed (note: Microsoft .Net Framework 4.0 does not include 3.5)
· Ensure that SwyxWare/NetPhone version is 6.12 or higher
· Start the MSI package from the installation source
· Click next ("Weiter >") on the installation welcome screen

· Change the installation destination folder if needed
· Click next ("Weiter >")

· Enter the password of your SwyxWare/NetPhone service account. The Queue Controller has to use the same account as SwyxWare/NetPhone services. If the SwyxWare/NetPhone server is running under the predefined SwyxServiceAccount account these logon credentials have to be changed using the configuration wizard because the password for the predefined service account is created randomly during configuration wizard.

· The password is stored encrypted inside the windows registry. To change it after installation, use the config tool.

· Click install ("Installieren") to finish the setup.

· After finishing the installation, please check the following components:

· Windows service "3iMedia Call Queue Controller for SwyxWare" is present and running
· Scripts, announcements and skin files have been automatically uploaded to SwyxWare/NetPhone global scope (see screenshot below)
· Folder "3iMedia Call Queue Controller for SwyxWare" (if not changed during setup) contains the following file structure (see screenshot below)
· Config folder containing config files for users and queues
· Doc folder containing help files and documentation
· Html folder containing the html files for the integrated web server
· Reports folder
· Logon system subfolder containing the logon protocol for selected groups
· Logon group subfolder containing the logon protocol for group logon/logoff
· CDR subfolder containing the call detail records
· Scripts folder containing the script files for SwyxWare/Netphone

· All files are uploaded to SwyxWare/NetPhone database on startup. There is no need to upload any files manually. The description of these files is starts with "MD5:" which is a calculated hash value to track changes on local files. In case these files are not uploaded automatically please check the logon credentials in the registry. Further check windows eventlog for messages regarding failed log on attempts.

The installation of the Call Queue Controller has finished. You can test the installation by opening your browser locally on the SwyxWare/Netphone server and navigate to http://localhost:81


Uninstall

Uninstall is performed by the software applet in windows control panel. All files but the html and reports directory are removed. The call routing scripts have to be removed manually from the SwyxWare/NetPhone database.


Config tool

The config tool offers an easy way to change the most common settings in Queue Controller. To start the config tool simply execute the SwyxQueueController.exe in the program folder by using Windows Explorer. The program itself detects if it is started in interactive mode and shows configuration interface instead of starting the windows service.


Webserver settings

Set the http port for Queue Controller web frontend. Default value is 81. To call the web frontend navigate to http://localhost:[port]

After changing the port the Queue Controller service needs to be restarted.


Language settings

To change the language of the web frontend set the language value to a valid language. Languages included in setup are German and English. It is possible to create own languages. Please contact support for instructions.


Database connection settings

These settings control the database or text file logging. On default, Queue Controller logs its data into text files in file system. To activate logging into a database a correct connection string has to be set and CDR type has to be set to "SQL" instead of "Text".

Further information can on connection strings can be found on www.connectionstrings.com

There are some settings that cannot be changed using the config tool. These settings are described in chapter registry settings.

After changing these setting no restart is necessary.


Service settings

To change the password used to logon to SwyxWare/NetPhone change password on the service settings page. The service has to be restarted after changing this value. Check the Queue Controller start page for error messages regarding logon to SwyxWare/NetPhone.


Client line manager settings

If Queue Controller is used for web based callback services the first checkbox needs to be enabled. Queue Controller will logon to SwyxWare using the created "QueueController" user.

If Queue Controller should request status updates using the Client Line Manager interface, the second checkbox needs to be enabled.


Version information

Version information gives info about the installed version including installed quickfixes.


Call Routing Manager

Using Call Queue Controller in CRM rules

For use in standard CRM (Call Routing Manager) create a simple rule with all filters needed. As action select "CallQueue" action from the list of available actions. Although using the CRM wizard, an ECR license is required.

Set or change the parameters. A full list of parameters is described in the following chapters.


Extended Call Routing Editor (ECR)

Using Call Queue Controller in ECR rules

For use in ECR (Extended Call Routing) editor create a graphical rule or open an existing rule. The call queue action block can be found after inserting an ECR action block from the toolbar.

Set or change the parameters by double clicking the block and choose "CallQueue" from the list of available actions. A full list of parameters is described in the following chapters.


Call queue ID

Default value: CStr(PBXUser.UserID)

 Top Previous Next

This value sets the call queue id to distinguish between the different call queues in the system. The variable call queue id makes it very easy to set up a call queue for every user by using his UserID as call queue id. Another option would be to use CalledNumber() as unique identifier. This id should be numeric.

Using the same queue id for different queues makes it possible to merge calls from different queues to the same group of agents.

Annotation:

Be aware of the maximum number queue ids that are allowed by license file.

Standard version supports only 1 queue

Professional version support up to 5 queues

Call center version supports up to 6 queues and can be enhanced by additional queue licenses

MemberLogOn | Standard version
MemberLogOn | Professional version
MemberLogOn | Call Center version


Call queue name

Default value: CStr(PBXUser.Name)

 Top Previous Next

This value sets the call queue name to distinguish between the different call queues in the system. This name is displayed in the web front-end. Please take care not to use different names for one queue id. This would change the queue name on each call that sets a new queue name. So the queue name is only a friendly name for the queue id property.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue color schema

Default value: ColorSet1,60|ColorSet2,120|ColorSet3,0

This value defines the used stylesheets in web front-end for displaying the status of each call. This parameter is evaluated in sets of stylesheets separated by semi-colons. In this example all calls waiting until 60 seconds in the queue are colorized by the ColorSet1 stylesheet. Calls waiting until 120 seconds are colorized by the ColorSet2 stylesheet. All other calls are colorized by the ColorSet3 stylesheet. It is possible to add further sets with other stylesheet.

Stylesheets are defined in the CallQueueColor.css file in the html subfolder.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call queue size

Default value: 100

This value sets the maximum number of calls the call queue can handle. If the maximum number is reached the next caller will be connected to the call queue voicemail (if set). If you don't want the caller to be connected to the call queue voicemail just increase the call queue size value to a value higher than the maximum number of lines available in SwyxGate or SwyxLink.

Another possibility is to check the call queue return values and place further action blocks behind the call queue. So own actions can be executed if the call queue size is exceeded. For example a second call queue with other announcements can be placed behind the first queue block.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call tag

Default value: CStr(PBXUser.Name)

 Top Previous Next

This value allows to add any annotation or description to a call. This tag is displayed in web front-end. With ECR editor it is possible to add further information (customer id, VIP, service contracts...) to a call very easily. It is also possible to add a web link as tag. This allows opening contact information in web bases CRM systems by clicking the tag element of a particular call.

MemberLogOn | Standard version
MemberLogOn | Professional version


Introduction

Call forwarding destinations

Call forwarding destinations are grouped in destination sets and have to start with a delivery mode. Each set is separated by a "|". To control the call delivery each destination set can suffixed by supplementary parameters and special parameters for that delivery mode.

Common example: TimeAdv2|69;70[Alert=FreeOnly],10,10|70[StateChecking=Always;Device=Mobile],10,0

This forwarding destination has 2 destination sets with delivery mode "TimeAdv2"

TimeAdv2: | Delivery mode
69;70[Alert=FreeOnly],10,10 | 1st destination set
69;70 | Destination number (parallel call to 69 and 70)
[Alert=FreeOnly] | Supplementary parameters
,10,10 | Destination mode parameters
70[StateChecking=Always,Device=Mobile],10,0 | 2nd destination set
70 | Destination number
[StateCheckingAlways,Device=Mobile] | Supplementary parameters
,10,0 | Destination mode parameters

Further information can be found in the following chapters.

Example 1:

Simple|69 or 69

Delivers the call to number 69 without any special options

Example 2:

LongestWaiting|69|70

Delivers the call to the members of group 69 and 70. Both groups are resolved to its members in the order set in the corresponding group.

Example 3:

Sequential|69|70|80[Alert=FreeOnly;ResolveGroupMembers=No]

Delivers the call in sequential order to the members of group 69, 70 and group 80. Group 80 is not resolved to its members and the call is delivered to free members only in that group.


Single destination

If only one single number is set, the call queue will deliver the call to this number. This is the default behavior.

For more options to control call delivery see supplementary parameters

MemberLogOn | Standard version
MemberLogOn | Professional version


Multiple destinations with queue size dependency

Size|[Destination1],[Timeout1],[QueueSize1]|[Destination2],[Timeout2],[QueueSize2]|…

SizeAdv1|[Destination1],[Timeout1],[QueueSize1]|[Destination2],[Timeout2],[QueueSize2]|…

SizeAdv2|[Destination1],[Timeout1],[QueueSize1]|[Destination2],[Timeout2],[QueueSize2]|…

This delivery mode delivers calls to a bigger group with more agents depending on the queue size itself. This makes it possible to react on a growing amount of callers and connect them quicker to their responsible agents.

Example:

Size|50,10,2|51,10,5|52,10,10|53,10,0

The call will be delivered in that way:

Queue size between 0 and 2 -> destination 50 for 10 seconds

Queue size between 3 and 5 -> destination 51 for 10 seconds

Queue size between 6 and 10 -> destination 52 for 10 seconds

Queue size between 11 and 0 (max) -> destination 53 for 10 seconds

Different size modes:

Size:

The destination is selected strictly from the actual call queue size. If the selected destination is busy the caller stays in the queue until the destination becomes free or another destination set is selected due to changed queue size. If a selected destination is offline, the caller stays only in queue if CallQueueStayIfLoggedOff is set to "1"

SizeAdv1:

The destination is selected from the actual queue size. If this destination is offline the call queue selects the next destination. If destination is busy, the caller stays in queue until destination becomes free or another destination set is selected due to changed queue size.

SizeAdv2:

The destination is selected from the actual queue size. If this destination is offline or busy the call queue selects the next destination.

More options:

For more options to control call delivery see supplementary parameters

Annotations:

· If timeout is omitted, the CallQueueConnectTime value is used
· If QueueSize is "0", the CallQueueSize value is used
· Use "0" or CallQueueSize as QueueSize value for the last delivery set
· Group numbers are not resolved by default, do not use "ResolveGroupMembers" from supplementary parameters

If a destination is unreachable, the caller stays in queue if the CallQueueStayIfUserLoggedOff parameter is set to "1" otherwise the caller will exit the queue

MemberLogOff | Standard version
MemberLogOn | Professional version


Multiple destinations with queue time dependency

Time|[Destination1],[Timeout1],[QueueTime1]|[Destination2],[Timeout2],[QueueTime2]|…

TimeAdv1|[Destination1],[Timeout1],[QueueTime]|[Destination2],[Timeout2],[QueueTime2]|…

TimeAdv2|[Destination1],[Timeout1],[QueueTime]|[Destination2],[Timeout2],[QueueTime2]|…

So it is possible to deliver the call to a group of agents depending on the queue time. With increasing queue time the call is connected to other groups

Example:

Time|50,10,15|51,10,45|52,10,0

The call will be delivered in that way:

Queue time between 0 and 15 seconds -> destination 50 for 10 seconds

Queue time between 16 and 45 seconds -> destination 51 for 10 seconds

Queue time between 46 and 0 (max) seconds -> destination 52 for 10 seconds

Different time modes:

Time:

The destination is selected strictly from the actual call queue time. If the selected destination is busy the caller stays in the queue until the destination becomes free or another destination set is selected due to changed queue time. If a selected destination is offline, the caller stays only in queue if CallQueueStayIfLoggedOff is set to "1"

TimeAdv1:

The destination is selected from the actual queue time. If this destination is offline the call queue selects the next destination. If destination is busy, the caller stays in queue until destination becomes free or another destination set is selected due to changed queue time.

TimeAdv2:

The destination is selected from the actual queue time. If this destination is offline or busy the call queue selects the next destination.

More options:

For more options to control call delivery see supplementary parameters

Annotations:

· If timeout is omitted, the CallQueueConnectTime value is used
· If QueueSize is "0", the CallQueueSize value is used
· Use "0" or CallQueueSize as QueueSize value for the last delivery set
· Group numbers are not resolved by default, do not use "ResolveGroupMembers" from supplementary parameters

If a destination is unreachable, the caller stays in queue if the CallQueueStayIfUserLoggedOff parameter is set to "1" otherwise the caller will exit the queue

MemberLogOff | Standard version
MemberLogOn | Professional version


Multiple destinations with preferred destination

Preferred|[Destination1],[Timeout1],0|[Destination2],[Timeout2],0|…

In this scenario the call will be preferred delivered to the first destination set.

Example:

A customer has 3 different locations with 3 local help desks. Each help desk is primary responsible for the local location. Using 3 call queues with a single destination would solve this problem. But if a help desk needs to get calls from other locations too if in these locations is nobody able to take the call you need a second delivery destination for each call queue with a global destination.

Helpdesk A – destination 50

Helpdesk B – destination 60

Helpdesk C – destination 70

All users from all help desks – destination 99

Call queue A – Forwarding destination "Preferred|50,10,0|99,10,0"

Call queue B – Forwarding destination "Preferred|60,10,0|99,10,0"

Call queue C – Forwarding destination "Preferred|70,10,0|99,10,0"

If a user from location A call helpdesk A, he is put in call queue A and delivered first to destination 50. If destination 50 is busy or logged of the call is delivered to destination 99.

More options:

For more options to control call delivery see supplementary parameters

MemberLogOff | Standard version
MemberLogOn | Professional version


Multiple destinations with sequential destination

Sequential|[Destination1]|[Destination2]|[Destination3]...

In this scenario the call will be sequentially delivered to the destination sets. The call delivery always starts with the first destination set. The difference to the preferred delivery scenario is that groups are resolved to users before delivering the call. So destination are displayed in CDR as users and not as groups.

Example:

Sequential|50|51|52

Destination 50 is a group with members 10,11 and 12

Destination 51 is a group with members 20 and 21

Destination 52 is a user

The call will be delivered in that way:

Resolve group 50 to users, add users to destination list, resulting list is 10,11,12

Resolve group 51 to users, add users to destination list, resulting list is 10,11,12,20,21

Resolve user 52 to user, add user to destination list, resulting list is 10,11,12,20,21,52

Pick the first user from the list and deliver the call if user is free

Different sequential modes:

Sequential:

· The destination group is resolved as described above.
· The call will be delivered to each destination in this group.

SequentialAdv1:

· The destination group is not resolved.
· The call will be delivered to the destination.
· If the destination is a group number, SwyxWare/NetPhone will perform the group delivery itself.

SequentialAdv2:

· The destination group is resolved.
· The call will be delivered to each destination in this group but stops at the last member. This delivery mode can be used for escalation scenarios.

SequentialAdv3:

· The destination group is not resolved.
· The call will be delivered to the destination.
· If the destination is a group number, SwyxWare/NetPhone will perform the group delivery itself.
· The delivery stops at the last member.

SequentialAdv4:

· The destination group is resolved.
· The delivery stops after the last member. The call queue proceeds with the queue timeout process.

SequentialAdv5:

· The destination group is not resolved.
· The delivery stops after the last member. The call queue proceeds with the queue timeout process.

Annotations:

· The call queue starts on every connection attempt with the first destination. If this destination is logged off or busy the destination is skipped and the next destination in the list is selected.
· The difference to SwyxWare/NetPhone sequential call delivery is that in SwyxWare/NetPhone itself the sequential delivery is done within the same delivery attempt
· If groups are used as destination, the resolved group members will be resolved in the order defined in the group name with "(sorted)" in its name in SwyxWare/NetPhone Administration

More options:

For more options to control call delivery see supplementary parameters

MemberLogOff | Standard version
MemberLogOn | Professional version


Multiple destinations with rotary destination

Rotary|[Destination1]|[Destination2]|[Destination3]...

In this scenario the call will be rotary delivered to the destination sets. The call delivery always starts with the last used destination set in the previous delivery attempt. Groups are resolved to users before delivering the call. So destination are displayed in CDR as users and not as groups.

Example:

Rotary|50|51|52

Destination 50 is a group with members 10,11 and 12

Destination 51 is a group with members 20 and 21

Destination 52 is a user

The call will be delivered in that way:

Resolve group 50 to users, add users to destination list, resulting list is 10,11,12

Resolve group 51 to users, add users to destination list, resulting list is 10,11,12,20,21

Resolve user 52 to user, add user to destination list, resulting list is 10,11,12,20,21,52

Pick the lase user from the list and deliver the call to the next user if free

Different sequential modes:

Rotary:

· The destination group is resolved as described above.
· The call will be delivered to each destination in this group.

RotaryAdv1:

· The destination group is not resolved.
· The call will be delivered to the destination.
· If the destination is a group number, SwyxWare/NetPhone will perform the group delivery itself.

Annotations:

· The call queue starts on every connection attempt with the previous destination. If this destination is logged off or busy the destination is skipped and the next destination in the list is selected.
· The difference to SwyxWare/NetPhone rotary call delivery is that in SwyxWare/NetPhone itself the rotary delivery is done within the same delivery attempt
· If groups are used as destination, the resolved users are not in the order defined in the group in SwyxWare/NetPhone Administration

More options:

For more options to control call delivery see supplementary parameters

MemberLogOff | Standard version
MemberLogOn | Professional version


Multiple destinations with random destination

Random|[Destination1]|[Destination2]|[Destination3]...

In this scenario the call will be randomly delivered to the destination sets. The call delivery always starts with a random destination set. Groups are resolved to users before delivering the call. So destination are displayed in CDR as users and not as groups.

Example:

Random|50|51|52

Destination 50 is a group with members 10,11 and 12

Destination 51 is a group with members 20 and 21

Destination 52 is a user

The call will be delivered in that way:

Resolve group 50 to users, add users to destination list, resulting list is 10,11,12

Resolve group 51 to users, add users to destination list, resulting list is 10,11,12,20,21

Resolve user 52 to user, add user to destination list, resulting list is 10,11,12,20,21,52

Pick one user from the list and deliver the call if user is free

Different sequential modes:

Random:

· The destination group is resolved as described above.
· The call will be delivered to each destination in this group.

RandomAdv1:

· The destination group is not resolved.
· The call will be delivered to the destination.
· If the destination is a group number, SwyxWare/NetPhone will perform the group delivery itself.

Annotations:

· The call queue starts on every connection attempt with the previous destination. If this destination is logged off or busy the destination is skipped and the next destination in the list is selected.
· The difference to SwyxWare/NetPhone rotary call delivery is that in SwyxWare/NetPhone itself the rotary delivery is done within the same delivery attempt
· If groups are used as destination, the resolved users are not in the order defined in the group in SwyxWare Administration

More options:

For more options to control call delivery see supplementary parameters

MemberLogOff | Standard version
MemberLogOn | Professional version


Multiple destinations with longest waiting destination

LongestWaiting|[Destination1]|[Destination2]|[Destination3]...

In this scenario the call will be delivered to the destination that has the longest idle time. Groups are resolved to users before delivering the call. So destination are displayed in CDR as users and not as groups.

Example:

LongestWaiting|50|51|52

Destination 50 is a group with members 10,11 and 12

Destination 51 is a group with members 20 and 21

Destination 52 is a user

The call will be delivered in that way:

Resolve group 50 to users, add users to destination list, resulting list is 10,11,12

Resolve group 51 to users, add users to destination list, resulting list is 10,11,12,20,21

Resolve user 52 to user, add user to destination list, resulting list is 10,11,12,20,21,52

Pick one user from the list and deliver the call if user is free

Annotations:

· The call queue starts on every connection attempt with the destination with the longest idle time. If this destination is logged off or busy the destination is skipped and the next destination in the list is selected.
· If groups are used as destination, the resolved users are not in the order defined in the group in SwyxWare/NetPhone Administration

More options:

For more options to control call delivery see supplementary parameters

MemberLogOff | Standard version
MemberLogOn | Professional version


Group handling

Each group number that is used for call delivery has to be created in SwyxWare/NetPhone administration first. Queue Controller created two additional groups for each group used in call delivery or web front-end. Together with the original created group there are three groups that are described below:

Example: Group "Support"

If a group "Support" is created in the administration with a number 69 and the first call will be delivered to this number, the Queue Controller creates a group "Support (logged off)" and a group "Support (sorted)"

Group "Support":

This group has to be created manually. Place all needed members in that group.

Group "Support (logged off)":

All members that are logged off via front-end or by phone are moved to this group. This group is used to display the logged off members in front-end. After logging on an user again the user is moved back to the "Support" group.

Group "Support (sorted)":

This group contains all users from both groups "Support" and "Support (logged off)". This group is created using a sequential delivery mode. So reordering of members in that group with SwyxWare/NetPhone administration is possible.

If Queue Controller resolves a group used by a delivery mode the group members will be returned in the order set in this group.

Group synchronization mechanism:

Groups are synchronized automatically

· Adding a new member to the "Support" group also adds this member to the "Support (sorted)" group
· Adding a new member to the "Support (logged off)" group also adds this member to the "Support (sorted)" group
· Removing a member from the "Support" group also removes this member from the "Support (sorted)" group
· Removing a member from the "Support (logged off)" group also removes this member from the "Support (sorted)" group
· Removing members from the "Support (sorted)" group is not supported

This synchronization is done on next call delivery to this group or web front-end update on a page that uses this group.

Please be aware that it can take some seconds to create the new groups and read the new membership entries from SwyxWare/NetPhone. So the first call to a group with a delivery mode that needs group resolution may fail.


Supplementary parameters

Each destination can be appended with supplementary parameters. These parameters have to be places in brackets.

Example:

69[Alert=FreeOnly;Device=Mobile.SoftClient;ResolveGroupNumbers=Yes]

[Alert=All or FreeOnly]

Sets the alerting type for that destination

All | All numbers will be included in call delivery
FreeOnly | Only free numbers will be included in call delivery

Example: 69[Alert=FreeOnly]

Destination number is a group number 69 that contains the members 10, 12, 60 and 62. If alerting type is set to "All", the call is delivered to the group number directly. If alerting type is set to "FreeOnly" the group is resolved to its members and only free members are used for call delivery. This prevents ringing on hard phone if the soft client is logged off.

[Device=H323Client or Mobile or PhoneLxxx or PhoneSxxx or SIPClient or SoftClient or Conference or Gateway or SIPGateway or Link or Fax]

Sets the device for call delivery

H323Client | Device logged in as H323 device
Mobile | SwyxIt! mobile device
PhoneLxxx | SwyxPhones Lxxx series
PhoneSxxx | SwyxPhones Sxxx series
SIPClient | Device logged in as SIP device
Conference | Swyx conference user
SoftClient | SwyxIt! client
Gateway | ISDN gateway
SIPGateway | SIP gateway
Link | SwyxLink
Fax | SwyxFax

Example: If a user has a logged on SwyxIt! mobile device that should not be included in call delivery set the device type to "SoftClient". The call will be delivery to SwyxIt! client only. To deliver the call to multiple devices add them separated by a "."

[PostProcessingTime=x]

Defines the post processing time a user is locked for call delivery after finishing his call

x

Time in seconds

Using -1 as value for seconds the post processing time is set to infinite. The user's post processing time is displayed as "paused" in web front-end.

Annotation: Setting a post processing time on a group number automatically sets the alerting type to "FreeOnly". This is necessary because the call has to be delivered to members whose post processing time has elapsed.

[StateChecking=Strict or Device or Always or Remote1..Remote9]

Defines the logon state checking method

Strict | Checks the logon state of this destination based on SwyxWare/NetPhone logon state (as shown in SwyxIt!/NetPhone Client)
Device | Checks the logon state of this destination based on device response
Always | Assumes that destination is free, used for external destinations
Remote1.. | Remote server 1, checks the logon state on a remote server set in remote servers parameter
Remote9 | Remote server 9, checks the logon state on a remote server set in remote servers parameter

Annotation: For backward compatibility the logon state checking method can also be set by a suffix added to the destination number.

"d" = Device

"s" = Strict

"a" = Always

"r1" = Remote server 1

"r2" = Remote server 2

...

"r9" = Remote server 9

[AutoLogOff=DoNotLogOff or LogOffOn1TimeOuts or LogOffOn2TimeOuts or LogOffOn3TimeOuts or LogOffOn4TimeOuts or LogOffOn5TimeOuts]

DoNotLogOff | No action
LogOffOn1Timeouts | User is logged off if delivery times out 1 time
LogOffOn2Timeouts | User is logged off if delivery times out 2 times
LogOffOn3Timeouts | User is logged off if delivery times out 3 times
LogOffOn4Timeouts | User is logged off if delivery times out 4 times
LogOffOn5Timeouts | User is logged off if delivery times out 5 times

A user is logged off if a call from any queue times out x times during delivering the call to this user. Logging off a user means setting the user to "pause". He is not logged off from any groups. Setting a user to "pause" equals setting post processing time to -1.

[ResolveGroupNumber=Yes or No]

Yes | If the destination number is a group number the number is resolved to its members
No | It the delivery mode resolves group numbers and this parameter is set to "No", group resolution is suppressed

MemberLogOff | Standard version
MemberLogOn | Professional version


Parallel calls

Starting with version 3.11 it is possible to use SwyxWare/Netphone parallel call feature in call delivery. Parallel calls mean that two or more internal numbers can be joined in call delivery. To join numbers in a parallel call these numbers have to be separated by a ";".

Example:

Setting call forwarding destination to "69;70" will deliver a call simultaneously to "69" and "70" if both destinations are free. If one destination is logged off or busy, the destination is skipped in call delivery.


Call connect time

Default value: 15

This value sets the connection attempt timeout a call is delivered to the call destination if the call destination is free. Using zero as value is not recommended because it stops the execution of all following call queue actions because the call is delivered infinitely.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call not connected mail notification

Default value: 0

If this value is set to "1", the call queue sends a mail notification if a call is not picked up from the destination.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call not connected mail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the notification mail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call not connected mail subject

Default value: Call Queue: Delivery timed out or has been rejected

 Top Previous Next

This value sets the Email subject of the notification mail. The following placeholders are possible:

%name% | Caller name
%number% | Caller number
%time% | Call start time
%starttime%" | Call start time
%callingnumber% | Caller number
%callednumber%" | Called number
%dialednumber%" | Dialed number
%callid%" | CallID
%calltype%" | Call type
%duration% | Call duration (for time waiting in queue use %deliveredtime% instead)
%connectedname% | Connected name
%connectednumber% | Connected number
%reason% | Reason (rejected or timeout)
%deliverednumber% | Destination number
%deliveredtime% | Delivery time (time waiting in queue)

MemberLogOff | Standard version
MemberLogOn | Professional version


Call not connected mail body

Default value:

Call Information|CallID: %callid%|CallerName: %name%|CallerNumber: %number%|Start: %time%|Duration: %deliveredtime%|Delivered to: %deliverednumber%|Reason: %reason%

 Top Previous Next

This value sets the Email body of the notification mail. The following placeholders are possible:

%name% | Caller name
%number% | Caller number
%time% | Call start time
%starttime%" | Call start time
%callingnumber% | Caller number
%callednumber%" | Called number
%dialednumber%" | Dialed number
%callid%" | CallID
%calltype%" | Call type
%duration% | Call duration (for time waiting in queue use %deliveredtime% instead)
%connectedname% | Connected name
%connectednumber% | Connected number
%reason% | Reason (rejected or timeout)
%deliverednumber% | Destination number
%deliveredtime% | Delivery time (time waiting in queue)

Annotation:

· Use "|" as new line separator

MemberLogOff | Standard version
MemberLogOn | Professional version


Call instant delivery

Default value: 0

This value affects the delivery of calls in the queue. If instant call delivery is set to "0" the calls are queued and delivered in exact the same order as they are added to the queue. If instant call delivery is set to "1" the call queue tries to deliver calls faster and in a random order.

Example: Instant call delivery set to "0"

Call on position 1, destination group 50

Call on position 2, destination group 50

If call on position 1 is delivered to an agent the next call is delivered to this group. If this group has a sequential, rotary or random delivery mode set, the other agents in this group have to wait until the first agent whose phone is ringing picks up and answers the call.

Example: Instant call delivery set to "1"

Call on position 1, destination group 50

Call on position 2, destination group 50

Both calls will be delivered simultaneously to the group. Two phones are ringing at the same time and the call can be answered more quickly. The amount of calls delivered simultaneously is limited to the amount of logged on and free members in the destination set.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call custom delivery

Default value: 0

Custom delivery can be used to change queue parameter after the caller has been added to the queue.

Therefore custom delivery exits the queue on each connection attempt inside the queue. The queue block exits on exit "1". On that exit multiple action blocks can be connected to change almost all parameters inside the queue.

Please see the following example:

· The initialize block sets creates some variables
· Queue parameters are set to default except hold music = "", welcome announcement = "0", hold time = "-1"
· The call queue block has custom delivery set to "1"
· The queue exits on exit "1" named custom and uses a vb-script block to do a loop from 0 to 3
· Before first delivery attempt the queue exits and sets the forwarding destination to "10"
· On second delivery attempt the forwarding destination is set to "12", hold music and welcome announcement are set to a the wave files that needs to be played
· On third delivery attempt the forwarding destination is set to "69"
· On fourth delivery attempt the custom delivery mode is switched off because it is not needed any longer (just to save performance)

So the queue tries to connect to 10, then changes the destination to 12 and activate the welcome announcement with hold music after that. This delivers the call to 10 and 12 before placing the call on hold and playing the welcome announcement. To omit the short brake between the two delivery attempts the hold time is set to "-1".

To set or get call queue parameters the "CallQueueSetParameter" or "CallQueueGetParameter" blocks has to be used (see screenshot below)

All "Call finished" exits (not visible, if not marked explicitly in block) of every block connected to exit "1" of the CallQueue block has to be reconnected to the input of the CallQueue block.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call last agent delivery

Default value: 0

Last agent delivery is used to deliver a call previously connected to a specific agent to the same agent on the next call from the same calling party number. The call queue holds an internal table saving calling party numbers with the last agent or employee accepting this call.

If this agent is busy or logged off the call will be delivered to all other available destinations configured for this queue.

There are to modes for last agent delivery:

Setting this value to "1" the call will be delivered to an agent defined in the destination set configured for the queue. If this agent transfers the call to another agent or employee this has no effect on the destination for the next call coming from this calling party number.

Setting this value to "2" and the call taken by an agent will be transferred to an employee, the next call from this calling party number will be delivered to the employee the agent has transferred the call to one the first time.

Annotation:

If a user logs of or on to or from a group, he will be removed from the internal last agent table. This prevents calls from being delivered to agents that are not longer member in an agent group.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call last agent delivery expiration timeout

Default value: 3600

Sets the timeout in seconds the calling party number - agent allocation is stored in the internal table before the entry is deleted and the next call from a previous calling party number will be delivered as configured in the queue properties.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call hold time if not connected

Default value: 5

This value sets the minimum time a user hears hold music before the next connection attempt is possible. This feature prevents a user from hearing just one second hold music before the next connection attempt is made. This condition matches if destination is free but nobody answers the call. This value can be decreased if call queue plays hold music while connecting. This value can be set to 1 because there is no need for a long hold time period in this scenario.

Setting this value to -1 skips the waiting period between the delivery attempts. This can be used if the call is delivered to several destination with no hold music set. So it is possible to play the alerting tone without interruption while delivering the call to the destinations.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call priority

Default value: 2

This value set the priority of the caller in the call queue

1 - Add caller to top of queue

2 - Add caller to bottom of queue

3 - Add caller to top of queue after all other calls with top position

Example:

Call A and B is already in queue. A and B has been added with priority 2.

1. A caller C with priority 1 is added. The queue order is C, A, B (C is always added to the top)

2. A caller D with priority 1 is added. The queue order is D, C, A, B (D is always added to the top)

3. A caller E with priority 3 is added. The queue order is D, C, E, A, B (E is added after all calls with priority 1)

4. A caller F with priority 2 is added. The queue order is D, C, E, A, B, F (F is added to the end)

Priority classes:

It is possible to add a priority class to each priority level. A priority class is a closed set of calls with own priority levels. A priority class is added at the end of the priority level separated with a "|".

Priority classes enables the queue to prefer calls such as emergency calls before VIP calls and all other calls in one single queue. All emergency calls get class 1, VIP calls class 2 and all other calls class 3. Only using priority 1, 2 or 3 without classes would sort all priority 1 calls at the top of the queue, so VIP calls would be preferred before emergency calls.

Example:

Using value 2|1 adds a call A to the end of class 1.

Using value 2|2 adds a call B to the end of class 2.

There are 2 calls in the queue. Each call is in a separate priority class. The order is A, B.

Using value 2|1 again adds a call C to the end of class 1. The order is now A, C, B.

Using value 1|1 which means "top of queue" and "class 1" adds a call D to the top of class 1. The order is now D, A, C, B where calls D, A, C belongs to class 1 and call B belongs to class 2.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call timeout

Default value: 3600

This value sets the maximum time a caller can stay in the call queue before a timeout occurs. This time is similar to the escalation timeout but the caller is connected the call queue voicemail (if set) and not the escalation process.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call hold music

Default value: *hold*

This value sets the call hold music for the caller. Setting this value to "*hold*" the queue uses the system music on hold configured in SwyxWare/NetPhone Administration. Different music on hold can be used for each call. The music on hold can be changed by entering the name of the wav-file for music on hold.

By setting this value to *random* the queue chooses one of the system music on hold files randomly. So each caller will hear a different music on hold. This prevents callers calling very often to hear the same music every time.

Another possibility is to separate multiple files by "|". The queue will play one of the configured files randomly. So it is possible to configure multiple music on hold files.

Setting this value to "0" suppresses the music on hold. The caller hears the alerting tone or silence while waiting in the queue. This parameter should be used with care!

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue plays hold music while connecting

Default value: 1

This parameter lets SwyxWare/NetPhone play music on hold while the call is ringing internal. The external caller does not hear the internal ringtone. The call is transferred if the internal user hooks off the phone.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue plays hold music on welcome

Default value: 1

Is this parameter is set to "1" the call queue plays music on hold in the background of the welcome announcement. The music on hold is faded in and out by SwyxWare/NetPhone automatically.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue plays hold music on selection

Default value: 1

Is this parameter is set to "1" the call queue plays music on hold in the background of the selection announcement. The music on hold is faded in and out by SwyxWare/NetPhone automatically.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call queue uses strict logon state checking

Default value: 1

The call queue distinguishes between two logon state checking methods.

If strict logon state checking is activated the logon state is checked on base of the SwyxWare logon state shown in SwyxWare/NetPhone Administration.

Example:

In SwyxWare/NetPhone Administration only SwyxIt! is marked as logon device on the devices tab in SwyxWare/NetPhone Administration. If SwyxIt! and SwyxPhone are logged on, the user is marked as logged on. If the user logs off SwyxIt! he will be marked as logged off although his SwyxPhone remains logged on. This logon state is that state that is displayed on the name keys in SwyxIt!

Group 69:

Member A, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)

Member B, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)

Member C, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)

Group 69 is logged off, if all SwyxIt!s are closed.

If strict logon state checking is deactivated the logon state is checked on base of device state.

Example:

A user is displayed as logged off in SwyxWare/NetPhone Administration but his SwyxPhone is logged on. The user could pick up the call, so the call queue will assume the user as logged on. In this scenario the states of the lines in SwyxIt! and SwyxPhone are included in logon state checking process.

Group 69:

Member A, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)

Member B, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)

Member C, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)

Group 69 is logged off, it all SwyxIt!s and SwyxPhones are logged off or no SwyxPhone has a configured free line for destination number 69.

This behaviour can be overwritten for each destination by adding a suffix like "d", "s", "a" or "r1..9" to the destination. See call queue forwarding destinations

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue remote servers for logon state checking

Default value: [localhost:81],[+49...]|[remotehost:81],[+49...]

 Top Previous Next

This value defines the remote server sets that can be used for logon state checking on remote servers. On the remote server a 3iMedia Call Queue Controller is needed as well.

Example:

swyxserver1.customer.com:81,+4972178167|swyxserver2.customer.com:81,+492314777

As described in chapter call forwarding destination each destination can be suffixed with a destination logon state checking flag ("s", "d", "a" or "r1".."r9"). The "r1"..."r9" flags correspond to the remote server sets in this chapter.

The destination set 10r1 checks the internal destination 10 on the server swyxserver1.customer.com on port 81 and connects to +4972178167-10 if this destination is free.

The destination set 20r2 checks the internal destination 20 on the server swyxserver2.customer.com on port 81 and connects to +492314777-20 if this destination is free.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call queue evaluates locked line as logged off

Default value: 0

Is this parameter is set to "1" the call queue evaluates a locked line key for the destination as logged off.

Example:

The call queue for the operator has the destination set "Preferred;60,10,0;61,20,0". That means the call queue tries to deliver the call first to the destination 60 and if that user is not logged on or free the call queue delivers the call to destination 61.

If destination 60 is logged on and destination 61 is logged on but has his line key for 61 locked, the call queue will assume that there is still somebody to take the call. If the destination 61 is only standby operator and has his line key locked normally it doesn't make sense to let a caller wait in the queue.

Setting this parameter to "1" lets the call queue evaluate this condition as logged off too. So if all callers in the destination sets are logged off or locked their line keys the logged off condition is executed.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue activates call on exit

Default value: 1

If this value is set to "0" the call stays on hold if the call is dropped from the queue. Sometimes it is necessary to add more than one queue in a chain. To avoid fading out music on hold on transferring the call from one queue to another set this value to zero.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call welcome announcement

Default value: Call Queue - Welcome.wav

This sound file is played it the caller is added to the queue. The welcome announcement is not played if the call queue destination is free and the call is connected on the first connection attempt. It the call queue destination is free but the call is not connected the welcome announcement is played once for every caller. If a new caller is on position higher than two, the welcome announcement is played immediately.

MemberLogOn | Standard version
MemberLogOn | Professional version
MemberLogOn | Call Center version

Multiple announcements can be separated them with a "|" between the different announcement files.

Example:

Announcement1.wav|Announcement2.wav|Announcement3.wav|Announcement4.wav

MemberLogOff | Standard version
MemberLogOn | Professional version


Caller position

On welcome announcement it is possible to add the caller position to every announcement.

0: Do not append position (default)

1: Append position

2: Append position as wave file, normally a position announcement is played by using system announcements. This means that positions above 9 are played as multiple files. Position "10" is played as "One.wav" followed by "Zero.wav". Using "2" as suffix to the announcement file a sound file "10.wav" will be played. This file must be recorded and uploaded to SwyxWare/NetPhone before.

Example:

Announcement1.wav,1|Announcement2.wav,0

The call queue will play "Announcement1.wav" and add the caller position after the announcement. Right after the caller position "Announcement2.wav" is played but no caller position is added.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call queue plays welcome before connecting

Default value: 0

This value controls the timing of the welcome announcement. If this value is set to 1 the welcome announcement is played before the first connection attempt. If the value is set to 0 the call queue will first try to reach a destination and will play the welcome announcement afterwards.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue allows staying in queue if no user logged on

Default value: 1

This value controls the behavior if the callers waiting in the queue stay inside the queue if all agents are logged off. If a caller is in the queue and all users in the call queue destination are logged off the caller is removed from the queue and the logged off condition is executed.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue allows staying in queue if all users busy

Default value: 1

This value controls the behaviour if callers entering the queue will exit the queue immediately if all destinations are busy.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue closed destination

Default value: 0

This value sets the destination a caller is connected to if the queue is in closed state. If this value is not "0" the caller is connected to the configured number.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue closed destination timeout

Default value: 15

This value sets the duration a caller is connected to the queue closed state destination number before a connect timeout occurs.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue closed proceed with destination script

Default value: 0

This value affects the call transfer. Setting this value to "1" executes the call routing script of the SwyxWare/NetPhone user the call is transferred to.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue closed voicemail

Default value: 0

This value enables the voicemail a caller is connected to if the queue is in closed state.

Annotation:

If both "call queue closed destination" and "call queue closed voicemail" are set, the call will be connected to voicemail if the connection attempt reaches a timeout or unreachable condition.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue closed voicemail file

Default value: 0

This value sets the voicemail file used for the queue closed condition described above. If this value is Set To 0 the default voicemail of the script user is used otherwise the configured voicemail file is played.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue closed voicemail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the voicemail described above. The default value uses the address of the script user configured in SwyxWare/Netphone Administration.

If the value is set to "0" the voicemail announcement is played and call is terminated.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue closed mail notification

Default value: 0

If this value is set to "1", the call queue sends a mail notification if the queue is closed.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call queue closed mail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the notification mail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call queue closed mail subject

Default value: Call Queue: All destinations logged off

This value sets the Email subject of the notification mail. The following placeholders are possible:

%name% | Caller name
%number% | Caller number
%time% | Call start time
%starttime%" | Call start time
%callingnumber% | Caller number
%callednumber%" | Called number
%dialednumber%" | Dialed number
%callid%" | CallID
%calltype%" | Call type
%duration% | Call duration (for time waiting in queue use %deliveredtime% instead)
%connectedname% | Connected name
%connectednumber% | Connected number

MemberLogOff | Standard version
MemberLogOn | Professional version


Call queue closed mail body

Default value: Call Information|CallID: %callid%|CallerName: %name%|CallerNumber: %number%|Start: %time%|Duration: %duration%

 Top Previous Next

This value sets the Email body of the notification mail. The following placeholders are possible:

%name% | Caller name
%number% | Caller number
%time% | Call start time
%starttime%" | Call start time
%callingnumber% | Caller number
%callednumber%" | Called number
%dialednumber%" | Dialed number
%callid%" | CallID
%calltype%" | Call type
%duration% | Call duration (for time waiting in queue use %deliveredtime% instead)
%connectedname% | Connected name
%connectednumber% | Connected number

Annotation:

· Use "|" as new line separator

MemberLogOff | Standard version
MemberLogOn | Professional version


Call user logged off override

Default value: 0

If this value is set to "1" the call queue assumes that all users are logged off. This parameter should be uses if own logged off conditions have to be checked before the call is placed in the queue.

Example:

Office hours are from Monday to Friday from 8 am to 4 pm. Add the standard ECR actions for the time checking and set a variable to "1" if the caller is calling outside the office hours. Use this variable as value for this call queue parameter.

(standard, professional and call center version)

MemberLogOn | Standard version
MemberLogOn | Professional version


Call user logged off destination

Default value: 0

This value sets the destination a caller is connected to if no agent is logged on in the forwarding destination group or the call queue logged off override parameter is set to "1". If this value is not "0" the caller is connected to the configured number.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call user logged off destination timeout

Default value: 15

This value sets the duration a caller is connected to the logged off destination number before a connect timeout occurs.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call user logged off proceed with destination script

Default value: 0

This value affects the call transfer. Setting this value to "1" executes the call routing script of the SwyxWare/NetPhone user the call is transferred to.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call user logged off voicemail

Default value: 0

This value enabled the voicemail a caller is connected to if no agent is logged on in the forwarding destination group or the call queue logged off override parameter is set to "1".

Annotation:

If both "call queue logged off destination" and "call queue user logged off voicemail" are set, the call will be connected to voicemail if the connection attempt reaches a timeout or unreachable condition.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call user logged off voicemail file

Default value: 0

This value sets the voicemail file used for the logged off condition described above. If this value is Set To 0 the default voicemail of the script user is used otherwise the configured voicemail file is played.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call user logged off voicemail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the voicemail described above. The default value uses the address of the script user configured in SwyxWare/Netphone Administration.

If the value is set to "0" the voicemail announcement is played and call is terminated.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call user logged off mail notification

Default value: 0

If this value is set to "1", the call queue sends a mail notification if all destinations are logged off.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call user logged off mail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the notification mail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call user logged off mail subject

Default value: Call Queue: All destinations logged off

This value sets the Email subject of the notification mail. The following placeholders are possible:

%name% | Caller name
%number% | Caller number
%time% | Call start time
%starttime%" | Call start time
%callingnumber% | Caller number
%callednumber%" | Called number
%dialednumber%" | Dialed number
%callid%" | CallID
%calltype%" | Call type
%duration% | Call duration (for time waiting in queue use %deliveredtime% instead)
%connectedname% | Connected name
%connectednumber% | Connected number

MemberLogOn | Standard version
MemberLogOn | Professional version


Call user logged off mail body

Default value: Call Information|CallID: %callid%|CallerName: %name%|CallerNumber: %number%|Start: %time%|Duration: %duration%

 Top Previous Next

This value sets the Email body of the notification mail. The following placeholders are possible:

%name% | Caller name
%number% | Caller number
%time% | Call start time
%starttime%" | Call start time
%callingnumber% | Caller number
%callednumber%" | Called number
%dialednumber%" | Dialed number
%callid%" | CallID
%calltype%" | Call type
%duration% | Call duration (for time waiting in queue use %deliveredtime% instead)
%connectedname% | Connected name
%connectednumber% | Connected number

Annotation:

· Use "|" as new line separator

MemberLogOn | Standard version
MemberLogOn | Professional version


Call escalation timeout

Default value: 0

This value sets the maximum time a caller can stay in the call queue. After the escalation timeout the caller is forwarded to the escalation process described below. This prevents the caller from staying in the call queue for too long.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call escalation destination

Default value: 0

This value sets the destination a caller is connected to if the escalation timeout is reached. If this value is not "0" the caller is connected to the configured number.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call escalation destination timeout

Default value: 15

This value sets the duration a caller is connected to the escalation destination number before a connect timeout occurs.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call escalation proceed with destination script

Default value: 0

This value affects the call transfer. Setting this value to "1" executes the call routing script of the SwyxWare/NetPhone user the call is transferred to.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call escalation voicemail

Default value: 0

This value enabled the voicemail a caller is connected to if the escalation timeout occurs.

Annotation:

If both "call queue escalation destination" and "call queue escalation voicemail" is set, the call will be connected to voicemail if the connection attempt reaches a timeout or unreachable condition.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call escalation voicemail file

Default value: 0

This value sets the voicemail file used for the escalation condition described above. If this value is set to "0" the default voicemail of the script user is used otherwise the configured voicemail file is played.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call escalation voicemail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the voicemail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

If the value is set to "0" the voicemail announcement is played and call is terminated.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call escalation stylesheet

Default value: ColorSetEscalation

This parameter sets the stylesheet used in web front-end for escalation condition. The calls are displayed in the active connections list.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call announcement timeout

Default value: 0

This value sets the timeout for the call queue announcement. The call queue announcement is an announcement that is played after the welcome announcement to inform the caller to be patient.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call announcement file

Default value: Call Queue - Announcement.wav

This value sets the call queue announcement files. These files are played if the call queue announcement timeout occurs.

MemberLogOn | Standard version
MemberLogOn | Professional version
MemberLogOn | Call Center version

Multiple announcements can be separated them with a "|" between the different announcement files. After the first timeout the first announcement is played, after the second timeout the second announcement and so on...

Example:

Announcement1.wav|Announcement2.wav|Announcement3.wav|Announcement4.wav

MemberLogOff | Standard version
MemberLogOn | Professional version


Caller position

On these announcements it is possible to add the caller position to every announcement.

0: Do not append position (default)

1: Append position

2: Append position as wave file, normally a position announcement is played by using system announcements. This means that positions above 9 are played as multiple files. Position "10" is played as "One.wav" followed by "Zero.wav". Using "2" as suffix to the announcement file a sound file "10.wav" will be played. This file must be recorded and uploaded to SwyxWare/NetPhone before.

Example:

Announcement1.wav,1|Announcement2.wav,0

The call queue will play "Announcement1.wav" and add the caller position after the announcement. Right after the caller position "Announcement2.wav" is played but no caller positions is added.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call announcement repeat

Default value: 1

This value defines whether the call queue announcement is repeated or just played once.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call selection timeout

Default value: 0

This value sets the timeout for the call queue selection. The call queue selection is a voice menu after the call queue announcement that gives the caller the possibility to select from different choices by sending DTMF tones with his telephone.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection repeat

Default value: 1

This value defines whether the call queue selection is repeated or just played once.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection before first connect

Default value: 0

This value defines whether the call queue selection menu is played before th first connection attempt. Otherwise the selection menu is played after the selection timeout. This option is useful for IVR-menus that should offer the possible options directly after the welcome announcement(s).

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection after first connect

Default value: 0

This value defines whether the call queue selection menu is played after the first connection attempt. Otherwise the selection menu is played after the selection timeout. This option is useful for IVR-menus that should offer the possible options directly after the first connection attempt.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection file

Default value: Call Queue - Selection.wav

This value sets the call queue selection file. This file is played if the call queue selection timeout occurs.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection DTMF timeout

Default value: 3

This value sets the time a caller can enter his choice in the IVR menu. Increasing this value gives the caller more time to make his decision.

Annotation:

The script is hold until the DTMF timeout occurs or the caller enters a DTMF digit. So do not increase this value to much. A maximum value of 10 should not be exceeded.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection voicemail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the voicemail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection callback mail notification

Default value: 0

If this value is set to "1", the call queue sends a mail notification if a callback has been requested.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection callback mail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the notification mail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection callback mail subject

Default value: Call Queue: Caller requested callback

This value sets the Email body of the notification mail. The following placeholders are possible:

%name% | Caller name
%number% | Caller number
%time% | Call start time
%starttime%" | Call start time
%callingnumber% | Caller number
%callednumber%" | Called number
%dialednumber%" | Dialed number
%callid%" | CallID
%calltype%" | Call type
%callbacknumber% | Number of caller

Annotation:

· Use "|" as new line separator

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection callback mail body

Default value: Call Information|CallID: %callid%|CallerName: %name%|CallerNumber: %callbacknumber%|Start: %time%|Duration: %duration%

 Top Previous Next

This value sets the Email body of the notification mail. The following placeholders are possible:

%name% | Caller name
%number% | Caller number
%time% | Call start time
%starttime%" | Call start time
%callingnumber% | Caller number
%callednumber%" | Called number
%dialednumber%" | Dialed number
%callid%" | CallID
%calltype%" | Call type
%callbacknumber% | Number of caller

Annotation:

· Use "|" as new line separator

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection key 0..9, *, #, timeout

These parameters offer the possibility to set the actions for the different IVR inputs within the selection menu.

Possible actions are:

· Nothing
· Voicemail
· Connect
· SimpleCallback
· SimpleCallbackAdv1
· AdvancedCallback
· AdvancedCallbackAdv1
· Exit

Nothing:

This action does nothing. It seems senseless at the first look. In conjunction with the selection key timeout parameter it can be used to force a caller to press a digit on his phone to stay in the queue. So the announcement says "Please press 1 to stay in the line" If the caller pressed nothing the selection key time puts him to the voicemail.

Voicemail:

Transfers the call to the selection voicemail

Connect:

Transfers the call to the corresponding destination and proceeds with the call routing of that destination

SimpleCallback, SimpleCallbackAdv1:

The simple callback removes the call from the queue and puts him to the callback request list in the web front end. If the caller doesn't transmit a caller id the caller id is asked by a DTMF input sequence and used as callback number. Using SimpleCallbackAdv1 requests the callers number in every case.

AdvancedCallback, AdvancedCallbackAdv1:

The advanced callback works like the simple callback but the caller stays virtually in the queue. It moves to the top position just as he would in the queue. If the caller would have been on position 1, the call is removed from the queue and put in the callback request list.

If the caller doesn't transmit a caller id the caller id is asked by a DTMF input sequence and used as callback number. Using AdvancedCallbackAdv1 requests the callers number in every case.

Exit:

Exits the call queue with a return value 65 + number of DTMF digit pressed (655 if 5 has been pressed).

The corresponding destination parameter sets the destination the call is connected to if the call queue selection key entry is set to "Connect"

MemberLogOff | Standard version
MemberLogOn | Professional version


Call selection stylesheet

Default value: ColorSetSelection

This parameter sets the stylesheet used in web front-end for selection condition.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call queue voicemail

Default value: 0

This value enables the call queue voicemail. The call queue voicemail will be executed if one of the following conditions matches:

· Call queue sized exceeded
· Call queue call timeout occurred

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue voicemail file

Default value: 0

This value sets the voicemail file used for call queue voicemail described above. If this value is set to 0 the default voicemail of the script user is used otherwise the configured voicemail file is played.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue voicemail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the voicemail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

If the value is set to "0" the voicemail announcement is played and call is terminated.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue voicemail stylesheet

Default value: ColorSetVoicemail

This parameter sets the stylesheet used in web front-end for the call queue voicemail. The calls are displayed in the active connections list.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call disconnect mail notification

Default value: 0

If this value is set to 1, the call queue sends a mail notification if the caller hooks on without being connected to any destination.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call disconnect mail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the notification mail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call disconnect mail subject

Default value: Call Queue: User has hook on during call queue

 Top Previous Next

This value sets the Email subject of the notification mail. The following placeholders are possible:

%name% | Caller name
%number% | Caller number
%time% | Call start time
%starttime%" | Call start time
%callingnumber% | Caller number
%callednumber%" | Called number
%dialednumber%" | Dialed number
%callid%" | CallID
%calltype%" | Call type
%duration% | Call duration (for time waiting in queue use %deliveredtime% instead)
%connectedname% | Connected name
%connectednumber% | Connected number

MemberLogOff | Standard version
MemberLogOn | Professional version


Call disconnect mail body

Default value: Call Information | CallID: %callid%|CallerName: %name%|CallerNumber: %number%|Start: %time%|Duration: %duration%

 Top Previous Next

This value sets the Email body of the notification mail. The following placeholders are possible:

%name% | Caller name
%number% | Caller number
%time% | Call start time
%starttime%" | Call start time
%callingnumber% | Caller number
%callednumber%" | Called number
%dialednumber%" | Dialed number
%callid%" | CallID
%calltype%" | Call type
%duration% | Call duration (for time waiting in queue use %deliveredtime% instead)
%connectedname% | Connected name
%connectednumber% | Connected number

Annotation:

· Use "|" as new line separator

MemberLogOff | Standard version
MemberLogOn | Professional version


Call disconnect threshold

Default value: 5

This value defines a threshold for the mail notification. Default value is 5 seconds. So if a caller hooks on within the first 5 seconds no notification mail is sent.

MemberLogOff | Standard version
MemberLogOn | Professional version


Call disconnect clearing timeout

Default value: 60

This value defines the time in seconds a disconnected caller is visible in web front-end. A disconnected call is displayed in the active calls list.

0 = infinite

-1 = immediate

MemberLogOn | Standard version
MemberLogOn | Professional version


Call voicemail clearing timeout

Default value: 60

This value defines the time in seconds a call connected to voicemail is visible in web front-end. A voicemail call is displayed in the active calls list. Setting this value to "0" the calls will never be removed from the voicemail calls list.

0 = infinite

-1 = immediate

In some scenarios voicemail calls needed to be treated as lost calls.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call aborted clearing timeout

Default value: 10

This value defines the time in seconds an aborted call is visible in web front-end. An aborted call is displayed in the active calls list.

0 = infinite

-1 = immediate

MemberLogOn | Standard version
MemberLogOn | Professional version


Call lost clearing timeout

Default value: 600

This value defines the time in seconds a lost caller is visible in web front-end. A lost call is displayed in the lost calls list. Setting this value to "0" the calls will never be removed from the lost calls list.

0 = infinite

-1 = immediate

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue delete phone call entry on connect

This value controls the phone call entry mechanism in Queue Controller. Setting this value to "1" deletes all phone call entries on users the call has been delivered but not connected. The entry on the connected user will not be deleted.

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue change phone call entry on connect

Call queue delete phone call entry on connect

This value controls the phone call entry mechanism in Queue Controller. Setting this value to "1" changes all phone call entries on users the call has been delivered but not connected. The entry for the call destination column in call history will be changed to the connected party name.


Custom 10..20

Custom fields 10 to 20

These fields can be used to add own information to the call entry. These information will be added to the call detail entry logged in the database. See CDR logging for further information.

MemberLogOn | Standard version
MemberLogOn | Professional version


Return values

The call queue block has several return values, depending on the conditions and actions executed within the call queue. These return values can be uses to add further actions in ECR-scripts. For standard CRM-script an evaluation of these return values is not possible.

Sample:

Logged off processing

11 Call connected to logged off destination

12 Call connected to logged off special voicemail

13 Call connected to call queue default voicemail

Closed queue processing

70 Queue is closed

71 Call connected to closed queue destination

72 Call connected to closed queue special voicemail

73 Call connected to call queue default voicemail

Escalation processing

21 Call connected to escalation destination

22 Call connected to escalation special voicemail

23 Call connected to call queue default voicemail

Error processing

31 Call connected to error destination

32 Call connected to error special voicemail

33 Call connected to call queue default voicemail

Call Queue processing

41 Call connected to destination

42 Common error while processing the call in the queue. See trace for further details

43 Call lost

44 Queue size exceeded

45 Destination unreachable / logged off

46 Call timeout has been reached

47 Escalation timeout has been reached

48 Call aborted

49 Selection pressed

51 Call connected to queue special voicemail

53 Call connected to default voicemail

61 Call connected to selection destination

62 Call connected to selection special voicemail

63 Call connected to default voicemail

64 Caller requested a callback

65 Call exited the queue - DTMF digit pressed will be added to the return value (650...659)

91 Error creating queue

92 Error adding call to queue

97 Invalid license (invalid call property set)

98 Invalid license (maximum queue count exceeded, 1 for standard version)

99 Invalid license (license invalid, evaluation period expired)

MemberLogOn | Standard version
MemberLogOn | Professional version


Call pickup from Phone or SwyxIt!/NetPhone Client or website

There are 2 possibilities to pickup a call from a queue. This can be done by one of the following steps:

Using Skin or browser:

The installed skins delivered with this solution already include the correct url to pickup a call from a queue. On self built skins the url used in the Web Extension has to be similar to that:

Example: Call pickup destination is 60

Url:

http://localhost:81/QueueCalls.html?QueueID=X&PickupDestination=60

http://localhost:81/QueueCalls.html?QueueID=X&PickupDestination=Frank Schmidt

http://localhost:81/QueueCalls.html?QueueID=X&PickupDestination=%OwnName%

Instead of the QueueCalls.html any other html file can be used. The OwnName variable is parsed by SwyxIt!/NetPhone Client with the name of the logged on user.

Using a call routing script:

Users not using SwyxIt!/NetPhone Client or a PC with a browser are also able to pickup a call from a queue simply by using a name key on a Phone. The CallQueuePickupCall action block can be used to pickup the first call from a specific queue. By default the call will be delivered to the user calling the script that includes this ECR action block.

MemberLogOff | Standard version
MemberLogOn | Professional version


Queue visualization

Call queue overview

This view displays the overview of all available queues. Selecting one queue jumps to the call queue view page.

http://server:81/Index.html

Fields:

ID = Call queue ID

Name = Call queue name including "(closed)" as state if queue is closed

Queue size = Actual call queue size and maximum call queue size separated by "/"

Action = Open or close queue

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue view

This view shows all calls in the selected queue. The connected calls are displays below the caller waiting in the queue. At the bottom of the page all lost calls are displayed.

http://server:81/QueueCalls.html?QueueID=X&QueueName=Y

http://server:81/QueueCallsSmall.html?QueueID=X&QueueName=Y (used for SwyxIt! Webextension)

MemberLogOn | Standard version
MemberLogOn | Professional version


Call queue all calls

This view shows an overview of all calls in all queues. The connected calls are displays below the caller waiting in the queue. At the bottom of the page all lost calls are displayed.

http://server:81/QueueAllCalls.html

http://server:81/QueueAllCallsSmall.html (used for SwyxIt! Webextension)

MemberLogOn | Standard version
MemberLogOn | Professional version


Call details

This view shows the call details.

MemberLogOn | Standard version
MemberLogOn | Professional version


Global members view

This view shows all members of a group. The group parameters have to be added in html page

http://server:81/QueueMembers.html

http://server:81/QueueMembersSmall.html (used for SwyxIt! Webextension)

Columns:

This members view shows the users group state as red, green or yellow bar in the front of the row. This state is the most important state for call delivery.

Red indicates that the user is logged off from this group (group name is shown in the header of the first column).

Green indicates that the user is logged on in this group and ready to accept calls if he is actually free

Yellow indicates that the user is logged on but not able to accept calls at the moment. Reasons can be post processing times or redirections to voicemail

The first column header shows the name of the group member with a hyperlink to call this user directly.

The status column shows the SwyxWare/NetPhone status of this user. Possible states are "logged off", "free", "alerting", "speaking internal", "speaking external", "redirected"

The actions columns contains the buttons to logon and logoff a user from the group. The logon and logoff action controls the membership of the user and is reflected in the red or green bar in the from of the row.

The second hook in the actions column allows a user to remotely logon to a group. If a user is remotely logged on, Queue Controller will delivery the call to this user using its mobile extension number, configured for this user. The SwyxWare/Netphone state is ignored. So it is possible to deliver a call to a logged off user that uses a normal phone in its home office.

The time columns offers the possibility to set or reset the user's post processing time. The third column shows the post processing time as absolute time or countdown. If a user is set to "pause" the time shows "paused" instead of the post processing time. For setting a user to "pause", see chapter post processing control.

MemberLogOff | Standard version
MemberLogOn | Professional version


Global calls view

This view shows all calls in SwyxWare, grouped by internal, outgoing and incoming calls.

http://server:81/GlobalAllCalls.html

http://server:81/GlobalAllCallsSmall.html (used for SwyxIt! Webextension)

Annotation:

SwyxWare/Netphone only resolves numbers on outgoing call against the internal phone books. For number resolution against other systems (CRM, ERP) 3iMedia Metaservices has to be installed. This product has to be licensed separately.

MemberLogOff | Standard version
MemberLogOn | Professional version


Additional call info

Each call in each call view (queue or global) offers a small post-it icon. This icon can be used to save additional information to each call. This function needs logging to database activated. If database-logging is inactive the icons is greyed out.

The information added to the call is saved in a history. Multiple users can add information.

These information are available to all other users in form of a history.

The call information are saved in the database table "QueueCallInfo".


HTML Templates

The front end can be customized on customers demand. All HTML files can contain tags that are parsed before displaying the web page.

These tags are described in the following chapters. The tags have to use the following syntax:

<%TagName%>

<%TagName:Parameter:Value%>

<%Set Value=Property%>

The html files containing the tags have to be in the webdir folder specified in the registry. Default location for that folder is the html subfolder in the installation directory.

The customized files should be placed in the custom subfolder. So the original html files are not overwritten. The webserver uses files in the custom folder first!

The provided samples in the html folder consist of a html and a html data file. The html file includes a ajax java script that loads the content of its data file every 2 seconds. The name of the data file is set automatically. So it is very easy to copy these files to the custom folder and modify them. There is no need to change the data file name in the calling html file.

Further it is possible to use server side includes and iterated tags. So it is very simple to edit pages and create one page for multiple users or groups. Please find further information in the following chapters.

Using custom pages and html tags it is possible to arrange all elements on customers demand.


QueueList

Contains a list with all queues (File: QueueList.html)

<%QueueList%> Returns a list of all queues including the html table headers

<%QueueList/Body%> Returns a list of all queues without the table headers

Optional tags in HTML file:

Set QueueCallsURL: URL for queue calls link

Hiding queues from view:

Set QueueHide1=QueueID

Set QueueHide2=QueueID

Set QueueHide3=QueueID

...

Set QueueHideX=QueueID

Do not use Hide and Show on the same page

Show only queues in view:

Set QueueShow1=QueueID

Set QueueShow2=QueueID

Set QueueShow3=QueueID

...

Set QueueShowX=QueueID

Do not use Hide and Show on the same page

Hiding columns from view:

Set QueueListHiddenColumns1=1

Set QueueListHiddenColumns2=2

Set QueueListHiddenColumns3=3

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Hiding maximum queue members from view:

Set QueueListHideSize=1

Hides the maximum number of callers allowed to enter the queue from the view

MemberLogOn | Standard version
MemberLogOn | Professional version


QueueCallsList

Contains a list with all callers waiting in the selected queue (File: QueueCalls.html)

<%QueueCallsList%> Returns a list of all calls waiting in the selected queue including the html table headers

<%QueueCallsList/Body%> Returns a list of all calls waiting in the selected queue without the table headers

Mandatory parameters in URL:

QueueID: ID of the selected queue

Optional tags in HTML file:

Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:

Set QueueCallsListHiddenColumns1=1

Set QueueCallsListHiddenColumns2=2

Set QueueCallsListHiddenColumns3=3

Set QueueCallsListHiddenColumns4=4

Set QueueCallsListHiddenColumns5=5

Set QueueCallsListHiddenColumns6=6

Set QueueCallsListHiddenColumns7=7

Set QueueCallsListHiddenColumns8=8

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color

Set QueueListColorLayout=ColorLeftOnly

MemberLogOn | Standard version
MemberLogOn | Professional version


QueueActiveCallsList

Contains a list with all active calls in the selected queue (File: QueueCalls.html)

<%QueueActiveCallsList%> Returns a list of all active calls in the selected queue including the html table headers

<%QueueActiveCallsList/Body%> Returns a list of all active calls in the selected queue without the table headers

Mandatory parameters in URL:

QueueID: ID of the selected queue

Optional tags in HTML file:

Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:

Set QueueActiveCallsListHiddenColumns1=1

Set QueueActiveCallsListHiddenColumns2=2

Set QueueActiveCallsListHiddenColumns3=3

Set QueueActiveCallsListHiddenColumns4=4

Set QueueActiveCallsListHiddenColumns5=5

Set QueueActiveCallsListHiddenColumns6=6

Set QueueActiveCallsListHiddenColumns7=7

Set QueueActiveCallsListHiddenColumns8=8

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color

Set QueueListColorLayout=ColorLeftOnly

MemberLogOn | Standard version
MemberLogOn | Professional version


QueueLostCallsList

Contains a list with all lost calls in the selected queue (File: QueueCalls.html)

<%QueueLostCallsList%> Returns a list of all lost calls in the selected queue including the html table headers

<%QueueLostCallsList/Body%> Returns a list of all lost calls in the selected queue without the table headers

Mandatory parameters in URL:

QueueID: ID of the selected queue

Optional tags in HTML file:

Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:

Set QueueLostCallsListHiddenColumns1=1

Set QueueLostCallsListHiddenColumns2=2

Set QueueLostCallsListHiddenColumns3=3

Set QueueLostCallsListHiddenColumns4=4

Set QueueLostCallsListHiddenColumns5=5

Set QueueLostCallsListHiddenColumns6=6

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color

Set QueueListColorLayout=ColorLeftOnly

MemberLogOff | Standard version
MemberLogOn | Professional version


QueueAllCallsList

Contains a list with all callers waiting in all queues (File: QueueAllCalls.html)

<%QueueAllCallsList%> Returns a list of all calls waiting in all queues including the html table headers

<%QueueAllCallsList/Body%> Returns a list of all calls waiting in all queues without the table headers

Optional tags in HTML file:

Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:

Set QueueAllCallsListHiddenColumns1=1

Set QueueAllCallsListHiddenColumns2=2

Set QueueAllCallsListHiddenColumns3=3

Set QueueAllCallsListHiddenColumns4=4

Set QueueAllCallsListHiddenColumns5=5

Set QueueAllCallsListHiddenColumns6=6

Set QueueAllCallsListHiddenColumns7=7

Set QueueAllCallsListHiddenColumns8=8

Set QueueAllCallsListHiddenColumns9=9

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color

Set QueueListColorLayout=ColorLeftOnly

MemberLogOn | Standard version
MemberLogOn | Professional version


QueueAllActiveCallsList

Contains a list of all active calls in all queues (File: QueueAllCalls.html)

<%QueueAllActiveCallsList%> Returns a list of all active calls in all queues including the html table headers

<%QueueAllActiveCallsList/Body%> Returns a list of all active calls in all queues without the table headers

Optional tags in HTML file:

Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:

Set QueueAllActiveCallsListHiddenColumns1=1

Set QueueAllActiveCallsListHiddenColumns2=2

Set QueueAllActiveCallsListHiddenColumns3=3

Set QueueAllActiveCallsListHiddenColumns4=4

Set QueueAllActiveCallsListHiddenColumns5=5

Set QueueAllActiveCallsListHiddenColumns6=6

Set QueueAllActiveCallsListHiddenColumns7=7

Set QueueAllActiveCallsListHiddenColumns8=8

Set QueueAllActiveCallsListHiddenColumns9=9

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color

Set QueueListColorLayout=ColorLeftOnly

MemberLogOn | Standard version
MemberLogOn | Professional version


QueueAllLostCallsList

Contains a list of all lost calls in all queues (File: QueueAllCalls.html)

<%QueueAllLostCallsList%> Returns a list of all lost calls in all queues including the html table headers

<%QueueAllLostCallsList/Body%> Returns a list of all lost calls in all queues without the table headers

Optional tags in HTML file:

Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:

Set QueueAllLostCallsListHiddenColumns1=1

Set QueueAllLostCallsListHiddenColumns2=2

Set QueueAllLostCallsListHiddenColumns3=3

Set QueueAllLostCallsListHiddenColumns4=4

Set QueueAllLostCallsListHiddenColumns5=5

Set QueueAllLostCallsListHiddenColumns6=6

Set QueueAllLostCallsListHiddenColumns7=7

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color

Set QueueListColorLayout=ColorLeftOnly

MemberLogOff | Standard version
MemberLogOn | Professional version


QueueGroupMembersLoggedOnOffList

Contains a list of all logged on members of a group (File: QueueMembers.html)

<%QueueMembersLoggedOnList:EveryOne%> Returns a list of all logged on members for the selected group including the table headers

<%QueueMembersLoggedOffList:EveryOne%> Returns a list of all logged off members for the selected group including the table headers

<%QueueMembersLoggedOnOffList:EveryOne%> Returns a joined list of all logged on AND off members for the selected group including the table headers

<%QueueMembersLoggedOnList:EveryOne%> Returns a list of all logged on members for the selected group without the table headers

<%QueueMembersLoggedOffList/Body:EveryOne%> Returns a list of all logged off members for the selected group without the table headers

<%QueueMembersLoggedOnOffList/Body:EveryOne%> Returns a joined list of all logged on AND off members for the selected group without the table headers

Optional tags in HTML file:

Set MemberListURL: URL for queue members logon action link

Set QueueMembersMin: Minimum members that have to be logged on

Set QueueMembersMax: Maximum members that can be logged on

Set QueueMembersLogging: Activate logging, log files are saved in the reports folder in the installation folder

Set MemberPostProcessingFormat: Sets the time format for post processing time

Set MemberPostProcessingTime: Sets the post processing time in seconds (-1 = infinite / paused)

Set MemberAddCallToLink: Activates or deactivates the callto link on a user

Set MemberAddCallToLinkToRedirectionInfo: Activates or deactivates the callto link on a redirected user to directly call its redirection destination

Set MemberShowRedirectionInfo: Activates or deactivates the redirection info in redirection information of a user. This info shows the redirection destination of a user

Set MemberShowOwnUserOnly: Shows only the own user in members list. All other user will not be shown

Set MemberShowOwnActionOnly: Shows only the action buttons (log on, off, ect.) on the own user in members list. See example and annotations below

Set MemberShowOwnStatusOnly: Shows only the own status of mobile extension settings

Hiding columns from view:

Set QueueMembersListHiddenColumns1=1

Set QueueMembersListHiddenColumns2=2

Set QueueMembersListHiddenColumns3=3

Set QueueMembersListHiddenColumns4=4

Set QueueMembersListHiddenColumns5=5

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Hiding actions from view:

Set QueueMembersListHideTimeAdd: Hides the add post processing time column

Set QueueMembersListHideTimeReset: Hides the reset post processing time column

Set QueueMembersListHideTime: Hides the time from the post processing column

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

User state column:

Set MemberNumberPrefix=+49xxxxxxxxxx Prefix for callto: link for internal numbers to dial number directly from HTML-page

Set MemberStateNoText=0,1 Adds the users state but suppresses the text leaving only the background color

Example 1 (used in QueueMembers.html):

Set MemberStateNoText=0

Set QueueMembersListHiddenColumns2=2

Result:

Column 2 that normally contains the internal number with the prefix +4972178167 is hidden

Column 3 contains "alerting"

Column 4 contains the links for logging off from the group

Column 5 contains the links for increasing and resetting post processing time

Example 2 (used in StatusMembers.html):

Set MemberNumberPrefix=+49xxxxxxxxxx

Set MemberStateNoText=1

Set QueueMembersListHiddenColumns4=4

Result:

Column 2 contains the internal number with the prefix +4972178167

Column 3 contains no text but has a colored background

Column 4 that normally contains the link for logging off from the group is hidden

Column 5 contains the links for increasing and resetting post processing time

Example 3 (showing only own actions)

Set MemberShowOwnActionOnly=1

Result:

Now it is no longer possible for a user to change the status of other users in its group. To use this feature SwyxWare/NetPhone user name needs to be passed to Queue Controller.

To pass the SwyxWare/NetPhone user name into web extension to Queue Controller the parameter "OwnName" needs to be added to the url of the group members view.

Link:

http://%ActiveServerName%:81/QueueMembers.html?OwnName=%OwnName%

MemberLogOff | Standard version
MemberLogOn | Professional version


QueueGroupMembersLoggedOnOffCount

Returns the number of members in the corresponding logged on/off group (File: QueueMembers.html)

<%QueueMembersLoggedOnCount:EveryOne%>

<%QueueMembersLoggedOffCount:EveryOne%>

MemberLogOff | Standard version
MemberLogOn | Professional version


GlobalAllCallsList

Contains a list of all active outgoing calls (File: GlobalAllCalls.html)

<%GlobalAllOutgoingCallsList%> Returns a list of all outgoing calls including the table headers

<%GlobalAllOutgoingCallsList/Body%> Returns a list of all outgoing calls without the table headers

<%GlobalAllIncomingCallsList%> Returns a list of all incoming calls including the table headers

<%GlobalAllIncomingCallsList/Body%> Returns a list of all incoming calls without the table headers

<%GlobalAllInternalCallsList%> Returns a list of all internal calls including the table headers

<%GlobalAllInternalCallsList/Body%> Returns a list of all internal calls without the table headers

<%GlobalAllCallsList%> Returns a joined list of all calls including the table headers

<%GlobalAllCallsList/Body%> Returns a joined list of all calls without the table headers

Hiding columns from view:

Set GlobalAllCallsListHiddenColumns1=1

Set GlobalAllCallsListHiddenColumns2=2

Set GlobalAllCallsListHiddenColumns3=3

Set GlobalAllCallsListHiddenColumns4=4

Set GlobalAllCallsListHiddenColumns5=5

Set GlobalAllCallsListHiddenColumns6=6

Set GlobalAllCallsListHiddenColumns7=7

Set GlobalAllCallsListHiddenColumns8=8

Set GlobalAllCallsListHiddenColumns9=9

Set GlobalAllCallsListHiddenColumns10=10

Show colored marker in front of line instead of setting background color

Set QueueListColorLayout=ColorLeftOnly

MemberLogOff | Standard version
MemberLogOn | Professional version


GlobalAllCallsList filtering

It is possible to filter the global calls list on users or groups. For filtering users and groups use the following syntax:

<%GlobalAllOutgoingCallsList:User:User1%>

<%GlobalAllOutgoingCallsList/Body:User:User1%>

Filters the user by name "User1", only "User1" will be displayed

<%GlobalAllOutgoingCallsList:NoUser:User1%>

<%GlobalAllOutgoingCallsList/Body:NoUser:User1%>

Filters the user by Name "User1", all users are displayed excepting "User1"

<%GlobalAllOutgoingCallsList:Group:Group1%>

<%GlobalAllOutgoingCallsList/Body:Group:Group1%>

Filters the group by name "Group1", only users from "Group1" will be displayed

<%GlobalAllOutgoingCallsList:NoGroup:Group1%>

<%GlobalAllOutgoingCallsList/Body:NoGroup:Group1%>

Filters the group by name "Group1", all users are displayed excepting users from "Group1"

MemberLogOff | Standard version
MemberLogOn | Professional version


Reload

Returns the refresh interval used in the html code. The refresh interval can be adjusted in the registry. See registry documentation for further details.

MemberLogOn | Standard version
MemberLogOn | Professional version


Parameters

Returns the complete parameter string collected from the browser url. This tag is used to pass parameters to other pages. Parameters that are added from the Queue Controller itself (like Action, UserName, GroupName, ...) are removed from that string.

Available tags:

<%Parameters%>

<%Parameters?%>

<%Parameters&%>

Parameters contains the complete and cleaned query string.

Parameters? contains the complete and cleaned query string with a leading "?". This can be added right behind any url. This string is empty if no parameters are found.

Parameters& contains the complete and cleaned query string with a leading "&". This can be added after other parameters. This string is empty if no parameters are found.

MemberLogOn | Standard version
MemberLogOn | Professional version


Date

Inserts the actual date

MemberLogOn | Standard version
MemberLogOn | Professional version


Time

Inserts the actual time

MemberLogOn | Standard version
MemberLogOn | Professional version


Custom tags

Custom tags can be used in the following way

Example 1:

/test.html?Testentry=2

<%Testentry%> is parsed as "2"

Example 2:

<%Key=Value%>

MemberLogOn | Standard version
MemberLogOn | Professional version


Server side includes

Server side includes allows including other files with often used code in another file. These includes are resolved before displaying the page in the browser. To include another file in any html file use the following tag:

<%Include:Filename%>

If the included file contains an include tag too, these includes are resolved as well. Recursive includes are recognized and produce a warning message in html code. If the include file cannot be found a warning message is displayed in html file.

MemberLogOn | Standard version
MemberLogOn | Professional version


Recursive tags

Recursive tags can be used to pass parameters to a tag within a page:

<%Set Tag1=<%Tag2%>%>

To set the inner tag (Tag2) add this parameter to the query of the calling url like http://localhost:81/File.html?Tag2=Value. Tag2 is replaced by the String "Value" and is then parsed the normal way. This recursive parsing is iterated only 1 level of depth and only parameters used in the calling url are resolved.

Example:

http://localhost:81/Groups.html?GroupDisplayName=Support

http://localhost:81/Groups.html?GroupDisplayName=Sales

In the Groups.html file the tag can be something like this: <%QueueMembersLoggedOnOffList:<%GroupDisplayName%>%>. So calling this page with "Support" as parameter will display the page with all members of group "Support". Calling the same page with "Sales" shows "Sales" group instead. So there is no need to create two separate pages.

MemberLogOn | Standard version
MemberLogOn | Professional version


Log on/off from Phone or SwyxIt!/NetPhone Client

It is possible to log on and off from a group by using the Phone or SwyxIt!/NetPhone Client. There is a sample call routing "GroupLogonLogoff.rse" included in the Scripts\Samples folder in the installation folder. This call routing can be imported in ECR editor. It is also possible to create own call routing scripts with the included ECR action blocks CallQueueAddMember and CallQueueRemoveMember.

CallQueueAddMember:

This block can be used to add a user to a group.

User name: Name of the user from SwyxWare/NetPhone that should be added to the group

Group name: Name of the group from SwyxWare/NetPhone the user should be added to

Max members: Maximum amount of possible members in that group

Logging: Enables or disables logging on a logon or logoff action. Log files are written in Reports\Logon groups subfolder in the installation folder

Acoustic notification: Enables or disables the acoustic notification for the logon process. This should be set to "0" if multiple blocks are chained

Annotations:

· A successful operation is confirmed with a positive confirmation sound (if not deactivated)
· A unsuccessful operation is confirmed with a negative confirmation sound (if not deactivated)
· If add operation exceeds the maximum amount of members the maximum number of members is announced an a negative confirmation sound is played (if not deactivated)
· If the user is already a member of this group a positive confirmation sound is played (if not deactivated)
· If the user is added to a group where he is not a member before he is added to this group anyway

CallQueueRemoveMember:

This block can be used to add a user to a group.

User name: Name of the user from SwyxWare/NetPhone that should be removed from the group

Group name: Name of the group from SwyxWare/NetPhone the user should be removed from

Min members: Minimum amount of possible members in that group

Logging: Enables or disables logging on a logon or logoff action. Log files are written in Reports\Logon groups subfolder in the installation folder

Acoustic notification: Enables or disables the acoustic notification for the logoff process. This should be set to "0" if multiple blocks are chained

Annotations:

· A successful operation is confirmed with a positive confirmation sound (if not deactivated)
· A unsuccessful operation is confirmed with a negative confirmation sound (if not deactivated)
· If remove operation exceeds the minimum amount of members the minimum number of members is announced an a negative confirmation sound is played (if not deactivated)
· If the user is not a member of this group a negative confirmation sound is played (if not deactivated)

MemberLogOff | Standard version
MemberLogOn | Professional version


ECR example

The included ECR example can be used in that way:

Import the GroupLogonLogoff.rse in GSE editor into a new created ECR rule. Save this rule and activate it. This rule should be used on a dummy user in SwyxWare/Netphone.

Group name: Name of group the calling user should be added to

Minimum members in group: Minimum amount of possible members in that group

Maximum members in group: Maximum amount of possible members in that group

Logging: Enables or disables logging on a logon or logoff action. Log files are written in reports subfolder in the installation folder

To log on a member to a group, just call the number of the call routing user and add a "1" to the dialed number. To log off the member again add a "0" to the dialed number

Example:

Dummy user has number 100. For logging on user with name "User1" to the group "Group1", set "Group1" as group name parameter in the ECR rule and call 1001 from the phone or SwyxIt! of "User1". To log off this user again, call 1000. This sample script always logs on and off the calling user. It is not possible to log on or off another user. To do so use the ECR action blocks used in this example script. With these action blocks it is also possible to add and remove users from groups by calling from an external phone.


Log on/off from website

It is also possible to add and remove users from a group in web front. The parameters used to set the group parameters are described in the HTML Templates chapter. In the web page the state is visible. The status column contains the logon state of the group (logged on / logged off) and the call state of this user.

To call the members view call the QueueMembers page or any copy of this page with customized parameters.

http://server:81/QueueMembers.html

http://server:81/QueueMembersSmall.html (used for SwyxIt! Webextension)

Links:

<a href="#" onclick="new Ajax.Request('?Action=AddUserToGroup&UserName=[UserName]&GroupName=[GroupName]&MinMembers=[Min]&Logging=1', {{ asynchronous:true }});return false;">Log on</a>

<a href="#" onclick="new Ajax.Request('?Action=RemoveUserFromGroup&UserName=[UserName]&GroupName=[GroupName]&MaxMembers=[Max]&Logging=1', {{ asynchronous:true }});return false;"><Log off</a>

These links can be used to set or clear post processing time for a specific user. In SwyxIt!/NetPhone Client Webextension %OwnName% can be used for UserName.

MemberLogOff | Standard version
MemberLogOn | Professional version


Log on/off from multiple groups

To log on or off from more than one group at a time, Queue Controller offers a possibility to manage global log on/off procedures.

To manage the groups a user will be logged on/off in one step, a INI-file has to be created in the "Config\Users" folder. In this INI-file the groups for global log on/off are defined. The INI-file has the following structure:

[GroupSet1]

Sales=LoggedOff

Support=LoggedOff

State=LoggedOff

AutoLogOff=1

AutoLogOn=1

AutoLogOnOffLogging=1

Description:

[GroupSet1] | Set of groups for global log on/off, there can be multiple group sets in this file
Sales=LoggedOff | The user is actually logged off in group "Sales"
Support=LoggedOff | The user is actually logged off in group "Support"
AutoLogOff=1 | Queue Controller will log off the user from all groups automatically if the user logs off from SwyxWare/NetPhone
AutoLogOn=1 | Queue Controller will log on the user to all groups automatically if the user logs on to SwyxWare/NetPhone
AutoLogOnOffLogging=1 | The log on/off process is being logged
Other entries | All other entries in this section contains the recent group state that is used to save the last group state of the user

There is no need to create these INI-files manually. Queue Controller can create these files automatically. There are 2 groups created in SwyxWare/NetPhone. To create these INI-files the users only needs to be dragged into one of these groups in SwyxWare/NetPhone Administration.

Group: "Queue (global autologon control)"

An INI-file for all users in this group will be created. All groups created by Queue Controller are added to the INI-file on creation. To change the groups the user will be logged on/off this file has to be edited manually. AutoLogOff and AutoLogOn will set to "1" in all these files.

Group: "Queue (global control)"

An INI-file for all users in this group will be created. All groups created by Queue Controller are added to the INI-file on creation. To change the groups the user will be logged on/off this file has to be edited manually. AutoLogOff and AutoLogOn will set to "0" in all these files.

Annotations:

· The INI-files are not created immediately. Process for checking users in these two groups runs every 30 seconds
· A Global.ini file is created and contains the global parameters for each GroupSet.

Links:

<a href="#" onclick="new Ajax.Request('?Action=AddUserToAllGroups&UserName=[UserName]&Set=[GroupSet]&Logging=1', {{ asynchronous:true }});return false;">Global log on</a>

<a href="#" onclick="new Ajax.Request('?Action=RemoveUserFromAllGroups&UserName=[UserName]&Set=[GroupSet]&Logging=1', {{ asynchronous:true }});return false;">Global log off</a>

These links can be used to set or clear post processing time for a specific user. In SwyxIt!/NetPhone Client Webextension %OwnName% can be used for UserName.


Logging to database

Per default the logon and logoff actions are logged to the "Reports\Logon groups" folder. The logging into a database is performed by an ODBC driver. This behaviour can be configured in config tool or directly in the registry.

Logging to text file (default):

· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set LoggingType to "Text"

Logging to a database:

· Create the database (preferred name is "CDR")
· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set LoggingConnectionString to "Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Trusted_Connection=Yes;"
· Set LoggingType to "SQL"
· Tested on Microsoft SQL Server 2000/2005

The tables should be created automatically in the database connected by the connection string. See windows event log for error messages concerning database operations. Changes in the connection string should take effect immediately. A sample SQL connection string (LoggingConnectionStringSQLSample) is created in registry by default.

Annotation:

Using the connection string for SQL Server the SwyxWare/NetPhone account is used connecting to the database. This account needs sufficient rights to that database. Otherwise the following connection string can be used instead:

Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Uid=[Username];Pwd=[Password] (values in braces need to be replaced by there real values)

A list of connection strings for other databases can be found on http://www.connectionstrings.com/. The connection string for an ODBC connection should be used.


Set and clear postprocessing time from Phone or SwyxIt!/NetPhone Client

It is possible to set an clear the post processing time of a user by using the Phone or SwyxIt!/NetPhone Client. There is a sample call routing "PostProcessingTime.rse" included in the Scripts\Samples folder in the installation folder. This call routing can be imported in ECR editor. It is also possible to create own call routing scripts with the included ECR action blocks CallQueueSetPostProcessing and CallQueueClearPostProcessing.

CallQueueSetPostProcessing:

This block can be used to set the post processing time for a user.

User name: Name of the user from SwyxWare/NetPhone

Post processing time: Time in seconds

Logging: Enables or disables logging. Log files are written in Reports\Logon groups subfolder in the installation folder

Acoustic notification: Enables or disables the acoustic notification for the process

Annotations:

· A successful operation is confirmed with a positive confirmation sound (if not deactivated)
· A unsuccessful operation is confirmed with a negative confirmation sound (if not deactivated)
· Setting the post processing time to -1 sets the user to pause. This status is displayed as "paused" in web front end
· If the user is already set to post processing time, the post processing time is overwritten with the new value

CallQueueClearPostProcessingTime:

This block can be used to add a user to a group.

User name: Name of the user from SwyxWare/NetPhone

Logging: Enables or disables logging. Log files are written in Reports\Logon groups subfolder in the installation folder

Acoustic notification: Enables or disables the acoustic notification for the process

Annotations:

· A successful operation is confirmed with a positive confirmation sound (if not deactivated)
· A unsuccessful operation is confirmed with a negative confirmation sound (if not deactivated)
· If the user is not set to post processing time this action has no effect

MemberLogOff | Standard version
MemberLogOn | Professional version


ECR example

The included ECR example can be used in that way:

Import the PostProcessingTime.rse in GSE editor into a new created ECR rule. Save this rule and activate it. This rule should be used on a dummy user in SwyxWare/Netphone.

Post processing time: Time in seconds

Logging: Enables or disables logging. Log files are written in Reports\Logon groups subfolder in the installation folder

To set post processing time, just call the number of the call routing user and add a "1" to the dialed number. To clear post processing time add a "0" to the dialed number.


Set and clear postprocessing time from website

It is also possible to set and clear the post processing time of a user in web front. The parameters used to set the users parameters are described in the HTML Templates chapter. In the web page the state is visible. The time column contains the post processing state of a user.

To call the members view call the QueueMembers page or any copy of this page with customized parameters.

http://server:81/QueueMembers.html

http://server:81/QueueMembersSmall.html (used for SwyxIt!/NetPhone Client Webextension)

Links:

<a href="#" onclick="new Ajax.Request('?Action=SetPostProcessingTime&UserName=[UserName]&Logging=1', {{ asynchronous:true }});return false;">Set processing</a>

<a href="#" onclick="new Ajax.Request('?Action=ClearPostProcessingTime&UserName=[UserName]&Logging=1', {{ asynchronous:true }});return false;">Clear processing</a>

These links can be used to set or clear post processing time for a specific user. In SwyxIt!/NetPhone Client Webextension %OwnName% can be used for UserName.

MemberLogOff | Standard version
MemberLogOn | Professional version


Logging to database

The logging for post processing actions is written to the same table as the logon and logoff actions. The column "Groups" is set to NULL and the column "PostProcessing" is set to "1". For further information in configuring the logging see this chapter.


Description

Persistent storage

All information in queue controller are volatile by default. It is possible to store persistent information regarding calls, users, queues or any other information into the database. These information can be set and retrieved by using call routing scripts or web pages.

This mechanism can be used to change values like announcements in web front end and retrieve these values from call routing very easily. There is no need to develop complex web pages or call routing scripts that do any kind of database requests.

All persistent information are stored in a database. Storing these information in text files like logging logon or logoff from groups or call detail records is not supported. The access the database the settings using config tool or directly in registry need to be changed.

Creating connection to a database:

· Create the database (preferred name is "CDR")
· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set LoggingConnectionString to "Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Trusted_Connection=Yes;"
· Tested on Microsoft SQL Server 2000/2005

The tables should be created automatically in the database connected by the connection string. See windows event log for error messages concerning database operations. Changes in the connection string should take effect immediately. The default connection string in registry should work on MS SQL Server 2000.

Fields:

The table created in the database has the following fields.

Field name | Description
ID | Unique identifier (created automatically)
DataGroup | Value to group multiple key value pairs to a group
DataKey | Key of a key value pair
DataValue | Value of a key value pair
AssociatedGroup | Group ID or group name to associate the keys and values to a SwyxWare/NetPhone group
AssociatedUser | User ID or user name to associate the keys and values to a SwyxWare/NetPhone user
AssociatedQueueID | Queue ID or queue name to associate the keys and values to a specific queue
AssociatedCallID | Call ID to associate the keys and values to a specific call
LifeTime | Lifetime in seconds the value can be retrieved from database. Using 0 for infinite.
DateCreated | Timestamp of date of creation

Annotation:

Using the connection string for SQL Server the SwyxWare/NetPhone account is used connecting to the database. This account needs sufficient rights to that database. Otherwise the following connection string can be used instead:

Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Uid=[Username];Pwd=[Password] (values in braces need to be replaced by there real values)

A list of connection strings for other databases can be found on http://www.connectionstrings.com/. The connection string for an ODBC connection should be used.


Saving and reading persistent information from ECR

CallQueueSetPersistentProperty:

This block can be used to save values into the internal persistent data table. To save multiple value into the database, more than one block needs to be chained.

Group: A data group value groups multiple key/value pair together like a category. This value can have any value. There are not predefined group categories.

Key: Key entry for each key/value pair

Value: Value for a specific key/value pair

Associated: These value can be empty or filled with any kind of data that should be associated with the value

Example:

1. Block: Group = "Announcements", Key = "1", Value = "Annoucement_Office.wav"

2. Block: Group = "Announcements", Key = "2", Value = "Annoucement_Holiday.wav"

3. Block: Group = "Announcements", Key = "3", Value = "Annoucement_Night.wav"

These 3 blocks create 3 entries in the database.

CallQueueGetPersistentProperty:

This block can be used to retrieve values from the internal persistent data table. To retrieve a specific value, all entries but "Value" needs to be filled with the filter criteria.

Example:

To retrieve one of the announcements from the upper example, data group and key needs to be filled with Group = "Announcement" and Key = "1", "2" or "3". The Value needs to be saved into a variable like "=ReturnValue".

If the saved value has been associated with a group, user, queue or call, these values needs to be set on retrieving the value from the database. Otherwise the value won't be found. If group, user, queue or call have been empty on saving the value, they have to be empty on retrieving the value too.


Saving and reading persistent information from website

It is also possible to save persistent information into the internal data table using html url.

Links for saving values:

<a href="#" onclick="new Ajax.Request('?Action=SetPersistentProperty&DataGroup=[...]&DataKey=[...]&DataValue=[...]&AssociatedGroup=[...]&AssociatedUser=[...]&AssociatedQueueID=[...]&AssociatedCallID=[...]&LifeTime=[...]Logging=1', {{ asynchronous:true }});return false;">

Tag to retrieve values:

<%PersistentProperty:DataGroup:DataKey:AssociatedGroup:AssociatedUser:AssociatedQueueID:AssociatedCallID%>

Annotations

· Not filled values needs to be empty.

Example:

<%PersistentProperty:Announcements:1::::%> retrieves the value "Annoucement_Office.wav" from the previous example.

<%PersistentProperty:Announcements:1::::%>

<%PersistentProperty:Announcements:2::::%>

<%PersistentProperty:Announcements:3::::%>

Retrieves a list with values that can be filled into a html drop down menu for example.


Description

Call detail records

SwyxWare/NetPhone writes CDR-files with call detail records into a text file or a database table. These CDR-files contain all information on incoming and outgoing calls. It exists only one CDR-record for each call. So some fields in the CDR-entry are overwritten during the call. So there is no way to get all the information needed to create reports.

To address this issue the queue controller writes its own CDR-files. In these CDR-files a new CDR-entry is created if the state of the call changes. See a complete list of available states.

If one of these states differ from the previous state a new CDR-entry is written. The result is a complete call history for each call. These CDR-entries are written for incoming calls, processed by the queue controller. The queue controller also monitors outgoing calls and direct calls to internal destinations. The logging equals to the logging for incoming call but is not so detailed. The type of a call is written in fields "CDRTypeCDR" or "CDRTypeQueue".

The CDR-files are located in the reports subfolder in the installation directory. On default all CDR entries are written in TXT-files with a maximum size of 5MB. The CDR-files are numbered CDR0.txt, CDR1.txt, ... CDRx.txt.

MemberLogOn | Standard version
MemberLogOn | Professional version


Fields

The following fields are used in the CDR-files. To be compatible with the Swyx-CDR-files not all of the fields are used but all fields are present.

Field | Description | Incoming | Outgoing
CDRCallId | CallID of the call | MemberLogOn | MemberLogOn
CDROriginationNumber | Originating number in canonical format | MemberLogOn | MemberLogOn
CDROriginationName | Originating name if resolved by SwyxWare/NetPhone | MemberLogOn | MemberLogOn
CDRCalledNumber | Called number in canonical or internal format | MemberLogOn | MemberLogOn
CDRCalledName | Called name, normally the name of the SwyxUser or ScriptUser | MemberLogOn | MemberLogOn
CDRDestinationNumber | Number of destination or group the call is delivered to | MemberLogOn | MemberLogOn
CDRDestinationName | Name of destination or group the call is delivered to | MemberLogOn | MemberLogOn
CDRStartDate | Start date of call | MemberLogOn | MemberLogOn
CDRScriptConnectDate | Connect date of call | MemberLogOn |
CDRDeliveredDate | Delivery date of call (date for each delivery attempt) | MemberLogOn |
CDRConnectDate | Connect date of call | MemberLogOn | MemberLogOn
CDREndDate | End date of call | MemberLogOn | MemberLogOn
CDRCurrency |  |  |
CDRCosts |  |  | MemberLogOn
CDRState | State of call | MemberLogOn | MemberLogOn
CDRPreviousState | Previous state of call (can be used to report state transitions) |  |
CDRPublicAccessPrefix | Public access prefix |  | MemberLogOn
CDRLCRProvider |  |  |
CDRProjectNumber | Project number |  | MemberLogOn
CDRAOC |  |  |
CDROriginationDevice | SwyxWare/NetPhone origination device (trunk name) |  | MemberLogOn
CDRDestinationDevice | SwyxWare/NetPhone destination device (trunk name) |  | MemberLogOn
CDRTransferredByNumber |  |  |
CDRTransferredByName |  |  |
CDRTransferredCallId1 |  |  |
CDRTransferredCallId2 |  |  |
CDRTransferredToCallId |  |  |
CDRTransferDate | Transfer date of call |  |
CDRDisconnectReason |  |  |
CDRConnectedNumber | Connected number in canonical or internal format | MemberLogOn |
CDRConnectedName | Connected name if resolved by SwyxWare/NetPhone | MemberLogOn |
CDRCustom0 | Call forwarding destination | MemberLogOn |
CDRCustom1 | Call tag | MemberLogOn |
CDRCustom2 | Call duration in seconds (set on disconnect) | MemberLogOn |
CDRCustom3 | Name of the called user | MemberLogOn |
CDRCustom4 | Queue ID | MemberLogOn |
CDRCustom5 | Queue name | MemberLogOn |
CDRCustom6 | for future purposes | MemberLogOn |
CDRCustom7 | for future purposes | MemberLogOn |
CDRCustom8 | for future purposes | MemberLogOn |
CDRCustom9 | for future purposes | MemberLogOn |
CDRCustom10 | Custom entry set in call routing block | MemberLogOn |
CDRCustom11 | Custom entry set in call routing block | MemberLogOn |
CDRCustom12 | Custom entry set in call routing block | MemberLogOn |
CDRCustom13 | Custom entry set in call routing block | MemberLogOn |
CDRCustom14 | Custom entry set in call routing block | MemberLogOn |
CDRCustom15 | Custom entry set in call routing block | MemberLogOn |
CDRCustom16 | Custom entry set in call routing block | MemberLogOn |
CDRCustom17 | Custom entry set in call routing block | MemberLogOn |
CDRCustom18 | Custom entry set in call routing block | MemberLogOn |
CDRCustom19 | Custom entry set in call routing block | MemberLogOn |
CDRCustom20 | Custom entry set in call routing block | MemberLogOn |
CDRTimeStamp | Timestamp of logging entry | MemberLogOn | MemberLogOn
CDRCallsInQueue | Callers in queue at time of logging entry | MemberLogOn |
CDRTypeQueue | Call is an incoming call handled by a queue | MemberLogOn |
CDRTypeCDR | Call is an incoming or outgoing call handled by SwyxWare/NetPhone | MemberLogOn | MemberLogOn
CDRTypeCallback | Not used yet |  |
CDRId | Unique identifier | MemberLogOn | MemberLogOn

MemberLogOn | Standard version
MemberLogOn | Professional version


States

This list contains all states logged to the CDR table

Incoming calls processed by queue:

Aborted | Call has been aborted by agent (web front end)
AdvancedCallbackRequested | Advanced callback has been requested
Alerting | Call is alerting
Announcement | Announcement is played
Busy | All agents in selected destination are busy
CallTimeout | Call timeout has been reached
Connected | Caller has been connected to destination
Destination script | Call has been connected to destination script (CDRConnectedName shows further information about destination)
Disconnected | Call has been disconnected, this value is always the last state
DTMFxpressed | DTMF digit x is pressed in selection menu
EscalationTimeout | Escalation timeout has been reached
Initialized | Call entry is created, all values are NULL
Lost | Call has been lost, caller waiting in queue disconnected the call
Offline | All agents in selected destination are logged off
OnHold | Removed in 3.11
OnHoldAfterConnected | Call put on hold after call has been connected to destination
ConnectedAfterOnHold | Call activated from hold after call has been connected to destination
Pickup | Call has been picked up by agent (CDRDestinationName shows further information about agent)
QueueClosed | Queue is closed
Queued | Call is added to queue
Rejected | Agent has rejected the call
SelectionAnnouncement | Selection announcement is played
SimpleCallbackRequested | Simple callback has been requestes
SizeExceeded | Number of callers in queue exceeds defined maximum number of possible callers
Timeout | Agent has not pickup up a call
Transfered | Call has been transfered
Transfering | Caller starts a call transfer
Voicemail | Call has been connected to voicemail (CDRConnectedName shows further information about voicemail type)
VoicemailFinished | Caller connected to voicemail has disconnected the call (CDRConnectedName shows further information about voicemail type)
WelcomeAnnouncement | Welcome announcement is played

Outoging calls monitored by queue controller:

Connecting | Call is initialized and waiting for connect
Connected | Call has been connected to destination
OnHold | Call has been put on hold
Disconnected | Call has been disconnected, this value is always the last state
Transferred | Call has been transferred


Logging to database

Per default the CDR entries are logged to the Reports\CDR folder. The logging into a database is performed by an ODBC driver. This behaviour can be configured in config tool or directly in the registry.

Logging to text file (default):

· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set LoggingType to "Text"

Logging to a database:

· Create the database (preferred name is "CDR")
· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set LoggingConnectionString to "Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Trusted_Connection=Yes;"
· Set LoggingType to "SQL"
· Tested on Microsoft SQL Server 2000/2005

The tables should be created automatically in the database connected by the connection string. See windows event log for error messages concerning database operations. Changes in the connection string should take effect immediately. A sample SQL connection string (LoggingConnectionStringSQLSample) is created in registry by default.

Annotation:

Using the connection string for SQL Server the SwyxWare/NetPhone account is used connecting to the database. This account needs sufficient rights to that database. Otherwise the following connection string can be used instead:

Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Uid=[Username];Pwd=[Password] (values in braces need to be replaced by there real values)

A list of connection strings for other databases can be found on http://www.connectionstrings.com/. The connection string for an ODBC connection should be used.


Description

Logon times monitoring

The queue controller is aware of the logon state of any user in SwyxWare/NetPhone. For these users a log file can be written containing all logon and logoff activities. The state monitored by queue controller is the state of the devices configured in server or user properties.

MemberLogOff | Standard version
MemberLogOn | Professional version


Usage

The usage of this feature is very simple. For each group that should be monitored a MBR-File has to be created in the reports\logon system subfolder of the installation directory. The queue controller adds a second file to this MBR-file if needed. In that LOG-file the logon and logoff activities are logged.

Example:

An empty Everyone.mbr file has been placed in the logon system folder under the reports folder. A short time later, the MBR-file is filled with the group members of the group "Everyone". Further an Everyone.log file has been generated. If someone logs off from the "everyone" group in SwyxWare/NetPhone a log entry will be written to the log file.

The log file looks like this:

02.12.2008 20:52:46;User1;logged off;logged on

02.12.2008 20:53:38;User1;logged on;logged on

02.12.2008 21:13:41;User1;new;logged on

02.12.2008 21:15:56;User2;new;logged on

02.12.2008 21:22:10;User2;logged on;logged off

The log file contains the date and time, the username, the actual state of this user and the new state of the user.

Annotation:

For reporting purposes the "everyone" group should be monitored. Do not monitor groups where users log off and on by phone or web front end. This leads to the fact that logging off from a group also logs off the user completely because he is no longer in the monitored group. So always use groups that are static for surveillance.

MemberLogOff | Standard version
MemberLogOn | Professional version


Logging to database

Per default the logon and logoff actions are logged to the Reports\Logon groups folder. The logging into a database is performed by an ODBC driver. This behaviour can be configured in config tool or directly in the registry.

Logging to text file (default):

· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set LoggingType to "Text"

Logging to a database:

· Create the database (preferred name is "CDR")
· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set LoggingConnectionString to "Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Trusted_Connection=Yes;"
· Set LoggingType to "SQL"
· Tested on Microsoft SQL Server 2000/2005

The tables should be created automatically in the database connected by the connection string. See windows event log for error messages concerning database operations. Changes in the connection string should take effect immediately. A sample SQL connection string (LoggingConnectionStringSQLSample) is created in registry by default.

Annotation:

Using the connection string for SQL Server the SwyxWare/NetPhone account is used connecting to the database. This account needs sufficient rights to that database. Otherwise the following connection string can be used instead:

Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Uid=[Username];Pwd=[Password] (values in braces need to be replaced by there real values)

A list of connection strings for other databases can be found on http://www.connectionstrings.com/. The connection string for an ODBC connection should be used.

MemberLogOff | Standard version
MemberLogOn | Professional version


Replication

Queue Controller is able to replicate all user files from Master to Standby Server. The mechanism works as describes below:

Stand-Alone:

· On startup, all updated files in "Scripts", "Scripts\Soundfiles" and "Skin" folder are uploaded to the database global scope automatically
· File changes in the "Scripts", "Scripts\Soundfiles" and "Skin" folder are updated in the database global scope
· Files in "Html\Custom", "Config\Users", "Config\Queues" and "Config\Global" folder are not uploaded to the database

Master-Server:

· On startup, all updated files in "Scripts", "Scripts\Soundfiles" and "Skin" folder are uploaded to the database global scope automatically
· On startup, all updated files in "Config\Users", "Config\Queues", "Html\Custom" folder are uploaded to the database global scope
· File changes in the "Scripts", "Scripts\Soundfiles" and "Skin" folder are updated in the database global scope
· File changes in the "Config\Users", "Config\Queues" and "Config\Global" folder are updated in the database queue controller user scope
· File changes in the "Html\Custom" folder are updated in the database queue controller user scope

Standby-Server:

· On startup, all updated files in global scope are downloaded to local file system automatically
· File changes in database are downloaded to local file system automatically
· There is no file upload of any kind on standby server


Description

Reporting

The queue controller is able to trigger reports from "3iMedia Reporting Services" on a time based interval. To use this feature "3iMedia Reporting Services" have to be installed. This product needs to be licensed separately.

MemberLogOff | Standard version
MemberLogOn | Professional version


Usage

The following tags can be included in a html file to trigger a report from "3iMedia Reporting Services" and show them inside a html page.

<%Set ReportDescription=...%> Description of the report as created in Reporting Services

<%Set ReportInterval=60%> Interval of report generation in seconds

<%Set ReportSize=60%> Maximum file size for report file, default is 524288 bytes. If the report file exceeds this size it is ignored

<%Set ReportSplitCharacter=;%> Split character in report file, default is ";"

<%Report:{1569ff00-016d-4267-ac5a-975e6dd38b9e}%> Report Id as created in Reporting Services

MemberLogOff | Standard version
MemberLogOn | Professional version


Registry Settings

Registry entry are located under HKLM\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare

Name | Default | Type | Description
CallQueueReloadTimeout | 2 | REG_DWORD | Refresh timeout used for reloading the content of a html page
CDRFileMaxSize | 5242880 | REG_DWORD | Maximum file size for CDR text file (not used if logging to SQL database is used)
CDRType | Text | REG_SZ | Type of logging, text for TXT-files, SQL for database logging
Culture | en-GB | REG_SZ | Language for web front end
InstallPath | %ProgramFiles%\3iMedia Call Queue Controller for SwyxWare | REG_SZ | Installation folder
LoggingConnectionString | Driver={SQL Server};Server=(local);Database=CDR;Trusted_Connection=Yes; | REG_SZ | ODBC connect string for connecting to logging database
LoggingConnectionTimeout | 5 | REG_DWORD | Connection timeout for connection to database
LoggingType | Text | REG_SZ | Logging type, possible values are "Text", "SQL", "Off"
LogonGroupsFileMaxSize | 5242880 | REG_DWORD | Maximum file size for CDR text file (not used if logging to SQL database is used)
LogonStateFileMaxSize | 5242880 | REG_DWORD | Maximum file size for CDR text file (not used if logging to SQL database is used)
Port | 81 | REG_DWORD | Webserver port used for front end. If port 81 is already used by another application the port has to be changed
ServicePasswordEncrypted | Encrypted password entered on setup | REG_SZ | Password for accessing SwyxWare/NetPhone services


Licensing

The installation package contains a 30 day trial version. To activate this version please contact license@3imedia.de. To activate the license we need the volume id of the hard disc the product is installed and the DNS server name including the domain name.

To determine the volume id perform the following steps:

· Start - Run
· Type "cmd"
· In the command line type "dir"

The output should look similar to that:

The volume id is the number in the upper part of the screenshot. In that case it's A835-3D36

After sending us the requested information together with company name and address we deliver a license file with further information. This license file has to be saved in the application installation folder.

To check the current license information use http://localhost:81/License.html on the machine. The result shows information similar to these:


Version history

 Top Previous

Version 3.11

· Queue: Real web based callback (needs extra license)
· Queue: Automatically set agent/user to pause if agent/user does not take the call (auto logoff)
· Queue: Possibility to use ";" for parallel calls in destination numbers
· Queue: Two new callback modes (SimpleCallbackAdv1 and AdvancedCallbackAdv1) to request phone number from caller in every case instead of only asking if number is suppressed
· Queue: Deflection support, deflecting a call delivered by Queue Controller can be deflected to another user or queue
· General: Configuration GUI for setup most common settings, started by running SwyxQueueController.exe from explorer
· General: Complete new status update mechanism using Client Line Manager to request status updates from SwyxWare/NetPhone (less resources, no polling on Swyx/NetPhone server, deactivated by default)
· General: Remote login to allow call delivery using Mobile Extension Manager (MEM) to home office or remote agents
· General: Post processing for outgoing calls
· General: Compressed logfiles are stored in traces sub folders to reduce amount of trace files in traces folder
· General: Configurable trace folder in registry
· General: Service password encryption in registry
· Webserver: Global calls list now available in standard version of Queue Controller
· Webserver: Add-Call-Info button in all call lists to add information to each call (info is written to new QueueCallInfo table)
· Webserver: Show actions only for own user in member list
· Webserver: Show only status for other users in member list
· Webserver: Hide all other users from member list (shows only one user that is logged on with SwyxIt!/NetPhone Client)
· Webserver: Change order of users in member list by using new tag <%QueueMembersLoggedOnOffSortedList%>
· Webserver: Improved detection mechanism for call direction (outgoing, incoming, internal) in global active calls list
· Webserver: Improved detection mechanism for calls to virtual conference rooms and ad-hoc conferences in global active calls list
· Webserver: Cancel call button in global calls list to terminate call (useful to kick user from a conference)
· Webserver: Display state "On hold" of connected calls in web frond end
· Reporting: Logging of pause time to QueueLogonGroups table
· Reporting: Logging of remote login time (for mobile extension delivery) to QueueLogonGroups table
· Reporting: Logging of time on hold to QueueLogonGroups table
· Reporting: 4 new states in CDR table "OnHold" (put call on hold AFTER connect), "ConnectedAfterOnHold", "CallTimeout", "EscalationTimeout"
· Reporting: 4 new fields in CDR table "CDRTypeQueue", "CDRTypeCDR", "CDRTypeCallback", "CDRPreviousState"
· Reporting: Removed state "OnHold" (call is on hold while waiting for connect) from CDR table if caller is just waiting in queue due new "CDRPreviousState" field (allows reporting state transitions "Alerting->Lost", "WelcomeAnnouncement->Lost", ...)
· Reporting: Writing CDR data by ODBC text driver removed due to performance issues after many calls. Text files for call detail records are written directly
· Reporting: Writing Logon groups data by ODBC text driver removed due to performance issues after many calls. Text files for logging are now written directly
· Reporting: Writing Logon system data by ODBC text driver removed due to performance issues after many calls. Text files for logging are now written directly

Version 3.10

· General: Windows 2008 Support
· General: Persistent storage, possibility to store data by scripting, web or COM into database to preserve data on service restart
· General: Performance counter integration
· General: Log file compression to save disc space
· General: Automatic update mechanism for script and html files in executable (future updates require only a new SwyxQueueController.exe executable)
· General: Automatic file upload of script, skin and announcement files into global scope on startup
· General: Automatic repliaction of script, skin, announcement, config and html files in master/standby scenario
· Queue: Post processing time in call routing can be set to -1 = ever to set employee to pause
· Queue: New delivery methods, last agent delivery and last employee delivery
· Queue: Random music on hold
· Queue: Deleting phone call entries for connected calls on all other agents
· Queue: Changing phone call entries for connected calls on all other agents to add information who took the call
· Reporting: Logging of outgoging calls in CDR table (including number resolved by 3iMedia Metaservices)
· Reporting: New CDR states: "WelcomeAnnouncement", "Announcement" and "SelectionAnnouncement" added for reporting purposes
· Reporting: CDRConnectDate updated for all previous records on connect
· Reporting: New field CallId in LogonGroups table to associate post processing time to call
· Reporting: New field CDRCallersInQueue in CDR table to count the number of callers waiting in a specific queue
· Webserver: Post processing time in web frontend can be set to -1 = ever to set agent to pause
· Webserver: Show "redirected to voicemail" in agent status entry in members list

Version 3.03:

· Queue: Post processing time for queue delivery
· Queue: New alerting type for group delivery (delivers call to logged on members only)
· Queue: Queue controller starts on first call automatically
· Queue: Complete new custom delivery mode (can now be used in ecr with standard Swyx ECR blocks)
· Queue: New ecr block for setting and getting parameters from the queue (for custom delivery or to get information on exit)
· Queue: Self registration on startup, self repairing mechanism
· Webserver: Display post processing time in members list
· Webserver: Easier data file creation, data file is set automatically in calling file
· Webserver: Server side includes (include files in html code for easier html file administration)
· Webserver: Health-Check for Webserver, self repairing mechanism
· General: Possibility to separate Queue Controller from SwyxWare/NetPhone has been removed
· General: Complete new call routing architecture all call control components are included in Call Queue Controller executable
· General: Some minor fixes
· Licensing: Introduced CallCenter version, limited Professional version to a maximum of 5 queues

Version 3.02:

· Webserver: Number resolution for outgoing calls against 3iMedia Metaservices
· Webserver: New tag <%Set QueueListColorLayout=ColorLeftOnly%> in html pages to display the background color only in front of the line
· Webserver: PickupDestination in URL can include the SwyxWare/NetPhone user name. So in SwyxIt! WebExtension %OwnName% can be used
· Webserver: New style sheets
· Webserver: Webserver included in QueueController, only one exe file
· General: Performance optimizations in Webserver and QueueController

Version 3.01:

· Webserver: New Http listener
· General: Some minor fixes

Version 3.00:

· Webserver: Live reporting, integration with 3iMedia Reporting Services
· Webserver: New design
· Webserver: Hide actions in calls list
· Webserver: Faster html parsing
· Webserver: Delete button for lost call

· Queue: Simple, Advanced Callback
· Queue: New delivery scenarios, "Custom", "SequentialAdvX", "RotaryAdvX"...
· Queue: Logging to database for groups logon and system logon states
· Queue: Changes on CDR, no time fields any more, empty fields are left null
· Queue: Assembly redirection to support multiple SwyxWare/NetPhone platforms

· General: Better logging for support
· General: Possibility to separate Queue Controller from SwyxWare/NetPhone