Description

3iMedia Call Queue Controller for SwyxWare/NetPhone enhances SwyxWare/NetPhone version 6.12 and above with powerful call queue features described below and can be parameterized to fit almost every call queue scenario. 3iMedia Call Queue for SwyxWare/NetPhone is developed as a SwyxWare/NetPhone action block, so it can be used very easily in CRM and ECR rules.


Features (call queue)

· SwyxWare/NetPhone action block, easy to implement, insert only one block to create a complete call queue
· Many call delivery scenarios:
· Dynamic call queue destination depending on amount of callers in the queue
· Dynamic call queue destination depending on call time in the queue
· Dynamic call queue destination with preferred agent groups
· Dynamic call queue destination with sequential call delivery
· Dynamic call queue destination with rotary call delivery
· Dynamic call queue destination with random call delivery
· Dynamic call queue destination with longest waiting call delivery
· Dynamic call queue destination with custom (scriptable) call delivery
· Instant call delivery to skip queuing latency, the number of delivered calls is evaluated from the number of free agents
· Call priority, add call to top or bottom of call queue
· Different music on hold for each call
· Music on hold for external caller while call is delivered internal
· Music on hold fading during announcements
· Logon state checking as shown in SwyxWare/NetPhone Administration (strict checking)
· Logon state checking depending on device state such SwyxIt! or SwyxPhone (line state checking)
· Remote logon state checking from other servers running queue controller services
· Connect to destination or voicemail if agents are logged off
· Connect to destination or voicemail on escalation timeout
· Connect to voicemail on call timeout
· Connect to destination or voicemail on selection menu
· Simple and advanced callback request
· Multiple time adjustable and repeatable announcements within the queue telling the caller to be patient
· Announcement of caller position in the queue
· Mail notification on not delivered calls
· Mail notification on logged off condition
· Mail notification on lost calls
· Return values in ECR to determine the result of the call queue action
· Many more parameters (over 100) ...


Features (visualization)

· Call queue visualization in web browser
· List of all call queues
· List of calls within the selected call queue
· List of active calls within the selected call queue
· List of callback request within the selected call queue
· List of lost calls within the selected call queue
· List of all calls in all queues
· List of active calls in all queues
· List of callback request in all queues
· List of all lost calls in all queues
· Reorder calls in call queue
· Pickup calls in call queue
· Abort calls in call queue
· Display call properties for each call
· Colored status for each call
· Log on and off from groups (also possible by name key)
· Global list of all calls within SwyxWare/NetPhone
· Filter for global calls list on SwyxWare/NetPhone-Users and SwyxWare/NetPhone-Groups
· Customizable layout basing on tags in html code
· Number resolution in active calls list against 3iMedia Metaservices for SwyxWare
· Integration in SwyxIt! Webextensions


Versions

There are two different versions available:

Features (Queue Controller) | Standard Version | Professional Version
Number of queues | 1 | unlimited
Call forwarding | One single destination One user or group can be entered as forwarding destination | Multiple destination sets as described in chapter call forwarding destination
Call Logged off processing | Yes | Yes
Call Escalation processing | No | Yes
Call Announcements | Yes | Yes
Call Selection menu | No | Yes
Groups logon / logoff | Yes | Yes
System logon / logoff logging | No | Yes
Simple callback | No | Yes
Advanced callback | No | Yes
Features (Web frontend) |  |
Color schemas | No | Yes
Move calls up, down, top | No | Yes
Cancel calls | No | Yes
Pickup calls | No | Yes
Queued calls list | Yes | Yes
Active calls list | Yes | Yes
Lost calls list | No | Yes
Global calls list | No | Yes
Groups logon / logoff | No | Yes


Installation Step 1

Follow these steps to install the 3iMedia Call Queue Controller for SwyxWare/NetPhone on the swyx server.

· Logon locally with administrative privileges
· Start the msi package from the installation source
· Click next on the installation welcome screen

· Change the installation destination folder if needed
· Click next

· Enter the password of your swyx service account. The call queue controller has to run under the same account as your swyx server. If the swyx server is running under the predefined SwyxServiceAccount account you have to change this logon account with the configuration wizard first because the password for the predefined service account is created randomly during configuration wizard.

· Click install to finish the setup. If an error occurred during setup please abort an rerun setup. Check if the service account credentials are correct.

· After finishing the installation, please check if the flowing components are present

· Service "3iMedia Call Queue Controller for SwyxWare" present and running
· Service "3iMedia Call Queue Webserver for SwyxWare" present and running
· Folder "3iMedia Call Queue Controller for SwyxWare" (if not changed during setup) has to contain the following file structure
· Doc folder contains help files and documentation
· Html folder contains the html files for the integrated web server
· Reports folder
· Logon system subfolder contains the logon protocol for selected groups
· Logon group subfolder contains the logon protocol for group logon/logoff
· CDR subfolder contains the cdr files
· Scripts folder contains the script files for SwyxWare/Netphone versions 6.10 or higher

The installation of the call queue controller has finished. You can test the installation by opening your browser locally on the SwyxServer and navigate to http://localhost:81


Installation Step 2

Import the script and audio files into the database. Follow these steps to import the files in the swyx database. The call routings script files (*.ase, *.vbs) and the announcements (*.wav) need to be imported.

· Open SwyxWare/NetPhone Administration
· Open SwyxServer properties and navigate to the files tab
· Click "Edit..."
· Click "Add..."
· Click ... in the upper right order to open the files dialog
· Navigate to the scripts folder under the installation destination folder and select all vbs and ase files
· Select "global" as scope from the list
· Select "call routing scripts" as category from the list
· Click "Ok"
· Repeat the steps above to import all wav files in the "announcements" category
· Repeat the steps above to import all cab files from the skins folder to the "skins" category

The installation of the call queue controller has been finished. You can test the installation by opening your browser locally on the SwyxServer and navigate to http://localhost:81


Uninstall

Uninstall is performed by the software applet in windows control panel. All files but html an reports directory are removed. The call routing scripts have to be removed manually from the swyx database.


Call Routing Manager

For use in standard CRM create a simple rule with all filters needed. As action select the call queue action from the list of available actions. Although using the CRM wizard, a ECR license is required.

Set the parameters. A full list of parameters is described in the following chapter.


Extended Call Routing Editor

For use in Extended Call Routing Editor create a graphical rule or open an existing rule. The call queue action block can be found after inserting an ecr action block from the toolbar.

Set the parameters by double clicking the block and choose "call queue" from the list of available actions. A full list of parameters is described in the following chapter.


Call queue ID

Default value: CStr(PBXUser.UserID)

This value sets the call queue ID to distinguish between the different call queues in the system. The variable call queue ID makes it very easy to set up call queue for every user by using his UserID as call queue ID. Another option would be CalledNumber() as unique identifier.

Using the same queue ID for different queues makes it possible to merge calls from different queues to the same group of agents.

(standard and professional version)


Call queue name

Default value: CStr(PBXUser.Name)

This value sets the call queue name to distinguish between the different call queues in the system.

(standard and professional version)


Call queue color schema

Default value: ColorSet1,60|ColorSet2,120|ColorSet3,0

This value defines the used stylesheets in web frontend for displaying the status of each call. This parameter is evaluated in sets of stylesheets separated by semi-colons. In this example all calls waiting until 60 seconds in the queue are colorized by the ColorSet1 stylesheet. Calls waiting until 120 seconds are colorized by the ColorSet2 stylesheet. All other calls are colorized by the ColorSet3 stylesheet. It is possible to add further time steps with other stylesheet.

Stylesheets are defined in CallQueue.css and CallQueueSmall.css file in the html subfolder.

(professional version only)


Call queue size

Default value: 100

This value sets the maximum calls the call queue can handle. If the maximum is reached the next caller will be connected to the call queue voicemail (if set) described below. If you don't want the caller to be connected to the call queue voicemail just increase the call queue size value to a value higher than the maximum lines available in SwyxGate or SwyxLink.

Another possibility is to check the call queue return values and place further action blocks behind the call queue. So own actions can be executed if the call queue size is exceeded. For example a second call queue with other announcements can be placed behind the first queue block.

(standard and professional version)


Call tag

Default value: CStr(PBXUser.Name)

This value allows to add any annotation or description to a call. This tag is displayed in web frontend. With ECR editor it is possible to add further information to a call very easily.

(standard and professional version)


Single destination

If only one single number is set, the call queue will connect the caller to this number. This is the default behavior.

Logon state checking
Each destination can be appended with a logon state checking suffix. These values are possible:
"d" = Device, checks the logon state of this destination on device response
"s" = Strict, checks the logon state of this destination of SwyxWare/NetPhone logon state
"a" = Always, assumes that destination is free, use this for external destinations
"r1" = Remote server 1, checks the logon state on a remote server set in remote servers parameter
"r2" = Remote server 2, checks the logon state on a remote server set in remote servers parameter
...
"r9" = Remote server 9, checks the logon state on a remote server set in remote servers parameter

(standard and professional version)


Multiple destinations with queue size dependency

Size|[Destination1],[Timeout1],[QueueSize1]|[Destination2],[Timeout2],[QueueSize2];…
SizeAdv1|[Destination1],[Timeout1],[QueueSize1]|[Destination2],[Timeout2],[QueueSize2];…
SizeAdv2|[Destination1],[Timeout1],[QueueSize1]|[Destination2],[Timeout2],[QueueSize2];…

This delivery method delivers calls to a bigger group with more agents depending on the queue size itself. This makes it possible to react on a growing amount of callers and connect them quicker to their responsible agents.

Example:
Size|50,10,2|51,10,5|52,10,10;53,10,0

The call queue will connect the caller in that way:
Queue size between 0 and 2 -> destination 50 for 10 seconds
Queue size between 3 and 5 -> destination 51 for 10 seconds
Queue size between 6 and 10 -> destination 52 for 10 seconds
Queue size between 11 and 0 (max) -> destination 53 for 10 seconds

Different size modes:
Size:
The destination is selected strictly from the actual call queue size. If the selected destination is busy the caller stays in the queue until the destination becomes free or another destination set is selected due to changed queue size. If a selected destination is offline, the caller stays only in queue if CallQueueStayIfLoggedOff is set to "1"
SizeAdv1:
The destination is selected from the actual queue size. If this destination is offline the call queue selects the next destination. If destination is busy, the caller stays in queue until destination becomes free or another destination set is selected due to changed queue size.
SizeAdv2:
The destination is selected from the actual queue size. If this destination is offline or busy the call queue selects the next destination.

Logon state checking
Each destination can be appended with a logon state checking suffix. Two values are possible:
"d" = Device, checks the logon state of this destination on device response
"s" = Strict, checks the logon state of this destination of SwyxWare/NetPhone logon state
"a" = Always, assumes that destination is free, use this for external destinations
"r1" = Remote server 1, checks the logon state on a remote server set in remote servers parameter
"r2" = Remote server 2, checks the logon state on a remote server set in remote servers parameter
...
"r9" = Remote server 9, checks the logon state on a remote server set in remote servers parameter

Annotations:
· If timeout is omitted, the CallQueueConnectTime value is used
· If QueueSize is "0", the CallQueueSize value is used
· Use "0" or CallQueueSize as QueueSize value for the last delivery set

If a destination is unreachable, the caller stays in queue if the CallQueueStayIfUserLoggedOff parameter is set to "1" otherwise the caller will exit the queue

(professional version only)


Multiple destinations with queue time dependency

Time|[Destination1],[Timeout1],[QueueTime1]|[Destination2],[Timeout2],[QueueTime2];…
TimeAdv1|[Destination1],[Timeout1],[QueueTime]|[Destination2],[Timeout2],[QueueTime2];…
TimeAdv2|[Destination1],[Timeout1],[QueueTime]|[Destination2],[Timeout2],[QueueTime2];…

So it is possible to deliver the call to a group of agents depending on the queue time. With increasing queue time the call is connected to other groups

Example:
Time|50,10,15|51,10,45|52,10,0
The call queue will connect the caller in that way:
Queue time between 0 and 15 seconds -> destination 50 for 10 seconds
Queue time between 16 and 45 seconds -> destination 51 for 10 seconds
Queue time between 46 and 0 (max) seconds -> destination 52 for 10 seconds

Different size modes:
Time:
The destination is selected strictly from the actual call queue time. If the selected destination is busy the caller stays in the queue until the destination becomes free or another destination set is selected due to changed queue time. If a selected destination is offline, the caller stays only in queue if CallQueueStayIfLoggedOff is set to "1"
TimeAdv1:
The destination is selected from the actual queue time. If this destination is offline the call queue selects the next destination. If destination is busy, the caller stays in queue until destination becomes free or another destination set is selected due to changed queue time.
TimeAdv2:
The destination is selected from the actual queue time. If this destination is offline or busy the call queue selects the next destination.

Logon state checking
Each destination can be appended with a logon state checking suffix. These values are possible:
"d" = Device, checks the logon state of this destination on device response
"s" = Strict, checks the logon state of this destination of SwyxWare/NetPhone logon state
"a" = Always, assumes that destination is free, use this for external destinations
"r1" = Remote server 1, checks the logon state on a remote server set in remote servers parameter
"r2" = Remote server 2, checks the logon state on a remote server set in remote servers parameter
...
"r9" = Remote server 9, checks the logon state on a remote server set in remote servers parameter

Annotations:
· If timeout is omitted, the CallQueueConnectTime value is used
· If QueueSize is "0", the CallQueueSize value is used
· Use "0" or CallQueueSize as QueueSize value for the last delivery set

If a destination is unreachable, the caller stays in queue if the CallQueueStayIfUserLoggedOff parameter is set to "1" otherwise the caller will exit the queue


Multiple destinations with preferred destination

Preferred|[Destination1],[Timeout1],0|[Destination2],[Timeout2],0;…

In this scenario the call will be preferred delivered to the first destination set.

Example:
A customer has 3 different locations with 3 local help desks. Each help desk is primary responsible for the local location. Using 3 call queues with a single destination would solve this problem. But if a help desk needs to get calls from other locations too if in these locations is nobody able to take the call you need a second delivery destination for each call queue with a global destination.

Helpdesk A – destination 50
Helpdesk B – destination 60
Helpdesk C – destination 70
All users from all help desks – destination 99

Call queue A – Forwarding destination "Preferred|50,10,0|99,10,0"
Call queue B – Forwarding destination "Preferred|60,10,0|99,10,0"
Call queue C – Forwarding destination "Preferred|70,10,0|99,10,0"

If a user from location A call helpdesk A, he is put in call queue A and delivered first to destination 50. If destination 50 is busy or logged of the call is delivered to destination 99.

Logon state checking
Each destination can be appended with a logon state checking suffix. These values are possible:
"d" = Device, checks the logon state of this destination on device response
"s" = Strict, checks the logon state of this destination of SwyxWare/NetPhone logon state
"a" = AlAlwaysasassumeshat destination is free, use this for external destinations
"r1" = Remote server 1, checks the logon state on a remote server set in remote servers parameter
"r2" = Remote server 2, checks the logon state on a remote server set in remote servers parameter
...
"r9" = Remote server 9, checks the logon state on a remote server set in remote servers parameter


Multiple destinations with sequential destination

Sequential|[Destination1]|[Destination2]|[Destination3]...

In this scenario the call will be sequentially delivered to the destination sets. The call delivery always starts with the first destination set. The difference to the preferred delivery scenario is that groups are resolved to users before delivering the call. So destination are displayed in CDR as users and not as groups.

Example:
Sequential|50|51|52
Destination 50 is a group with members 10,11 and 12
Destination 51 is a group with members 20 and 21
Destination 52 is a user

The call queue will connect the caller in that way:
Resolve group 50 to users, add users to destination list, resulting list is 10,11,12
Resolve group 51 to users, add users to destination list, resulting list is 10,11,12,20,21
Resolve user 52 to user, add user to destination list, resulting list is 10,11,12,20,21,52
Pick the first user from the list and deliver the call if user is free

Different sequential modes:
Sequential:
· The destination group is resolved as described above.
· The call will be delivered to each destination in this group.
SequentialAdv1:
· The destination group is not resolved.
· The call will be delivered to the destination.
· If the destination is a group number, SwyxWare/NetPhone will perform the group delivery itself.
SequentialAdv2:
· The destination group is resolved.
· The call will be delivered to each destination in this group but stops at the last member. This delivery method can be used for escalation scenarios.
SequentialAdv3:
· The destination group is not resolved.
· The call will be delivered to the destination.
· If the destination is a group number, SwyxWare/NetPhone will perform the group delivery itself.
· The delivery stops at the last member.
SequentialAdv4:
· The destination group is resolved.
· The delivery stops after the last member. The call queue proceeds with the queue timeout process.
SequentialAdv5:
· The destination group is not resolved.
· The delivery stops after the last member. The call queue proceeds with the queue timeout process.

Annotations:
· The call queue starts on every connection attempt with the first destination. If this destination is logged off or busy the destination is skipped and the next destination in the list is selected.
· The difference to SwyxWare/NetPhone sequential call delivery is that in SwyxWare/NetPhone itself the sequential delivery is done within the same delivery attempt
· If groups are used as destination, the resolved users are not in the order defined in the group in SwyxWare/NetPhone Administration

Logon state checking
Each destination can be appended with a logon state checking suffix. These values are possible:
"d" = Device, checks the logon state of this destination on device response
"s" = Strict, checks the logon state of this destination of SwyxWare/NetPhone logon state
"a" = Always, assumes that destination is free, use this for external destinations
"r1" = Remote server 1, checks the logon state on a remote server set in remote servers parameter
"r2" = Remote server 2, checks the logon state on a remote server set in remote servers parameter
...
"r9" = Remote server 9, checks the logon state on a remote server set in remote servers parameter


Multiple destinations with rotary destination

Rotary|[Destination1]|[Destination2]|[Destination3]...

In this scenario the call will be rotary delivered to the destination sets. The call delivery always starts with the last used destination set in the previous delivery attempt. Groups are resolved to users before delivering the call. So destination are displayed in CDR as users and not as groups.

Example:
Rotary|50|51|52
Destination 50 is a group with members 10,11 and 12
Destination 51 is a group with members 20 and 21
Destination 52 is a user

The call queue will connect the caller in that way:
Resolve group 50 to users, add users to destination list, resulting list is 10,11,12
Resolve group 51 to users, add users to destination list, resulting list is 10,11,12,20,21
Resolve user 52 to user, add user to destination list, resulting list is 10,11,12,20,21,52
Pick the lase user from the list and deliver the call to the next user if free

Different sequential modes:
Rotary:
· The destination group is resolved as described above.
· The call will be delivered to each destination in this group.
RotaryAdv1:
· The destination group is not resolved.
· The call will be delivered to the destination.
· If the destination is a group number, SwyxWare/NetPhone will perform the group delivery itself.

Annotations:
· The call queue starts on every connection attempt with the previous destination. If this destination is logged off or busy the destination is skipped and the next destination in the list is selected.
· The difference to SwyxWare/NetPhone rotary call delivery is that in SwyxWare/NetPhone itself the rotary delivery is done within the same delivery attempt
· If groups are used as destination, the resolved users are not in the order defined in the group in SwyxWare/NetPhone Administration

Logon state checking
Each destination can be appended with a logon state checking suffix. These values are possible:
"d" = Device, checks the logon state of this destination on device response
"s" = Strict, checks the logon state of this destination of SwyxWare/NetPhone logon state
"a" = Always, assumes that destination is free, use this for external destinations
"r1" = Remote server 1, checks the logon state on a remote server set in remote servers parameter
"r2" = Remote server 2, checks the logon state on a remote server set in remote servers parameter
...
"r9" = Remote server 9, checks the logon state on a remote server set in remote servers parameter


Multiple destinations with random destination

Random|[Destination1]|[Destination2]|[Destination3]...

In this scenario the call will be randomly delivered to the destination sets. The call delivery always starts with a random destination set. Groups are resolved to users before delivering the call. So destination are displayed in CDR as users and not as groups.

Example:
Random|50|51|52
Destination 50 is a group with members 10,11 and 12
Destination 51 is a group with members 20 and 21
Destination 52 is a user

The call queue will connect the caller in that way:
Resolve group 50 to users, add users to destination list, resulting list is 10,11,12
Resolve group 51 to users, add users to destination list, resulting list is 10,11,12,20,21
Resolve user 52 to user, add user to destination list, resulting list is 10,11,12,20,21,52
Pick one user from the list and deliver the call if user is free

Different sequential modes:
Random:
· The destination group is resolved as described above.
· The call will be delivered to each destination in this group.
RandomAdv1:
· The destination group is not resolved.
· The call will be delivered to the destination.
· If the destination is a group number, SwyxWare/NetPhone will perform the group delivery itself.

Annotations:
· The call queue starts on every connection attempt with the previous destination. If this destination is logged off or busy the destination is skipped and the next destination in the list is selected.
· The difference to SwyxWare/NetPhone rotary call delivery is that in SwyxWare/NetPhone itself the rotary delivery is done within the same delivery attempt
· If groups are used as destination, the resolved users are not in the order defined in the group in SwyxWare Administration

Logon state checking
Each destination can be appended with a logon state checking suffix. These values are possible:
"d" = Device, checks the logon state of this destination on device response
"s" = Strict, checks the logon state of this destination of SwyxWare/NetPhone logon state
"a" = Always, assumes that destination is free, use this for external destinations
"r1" = Remote server 1, checks the logon state on a remote server set in remote servers parameter
"r2" = Remote server 2, checks the logon state on a remote server set in remote servers parameter
...
"r9" = Remote server 9, checks the logon state on a remote server set in remote servers parameter


Multiple destinations with longest waiting destination

LongestWaiting|[Destination1]|[Destination2]|[Destination3]...

In this scenario the call will be delivered to the destination that has the longest idle time. Groups are resolved to users before delivering the call. So destination are displayed in CDR as users and not as groups.

Example:
LongestWaiting|50|51|52
Destination 50 is a group with members 10,11 and 12
Destination 51 is a group with members 20 and 21
Destination 52 is a user

The call queue will connect the caller in that way:
Resolve group 50 to users, add users to destination list, resulting list is 10,11,12
Resolve group 51 to users, add users to destination list, resulting list is 10,11,12,20,21
Resolve user 52 to user, add user to destination list, resulting list is 10,11,12,20,21,52
Pick one user from the list and deliver the call if user is free

Annotations:
· The call queue starts on every connection attempt with the destination with the longest idle time. If this destination is logged off or busy the destination is skipped and the next destination in the list is selected.
· If groups are used as destination, the resolved users are not in the order defined in the group in SwyxWare/NetPhone Administration

Logon state checking
Each destination can be appended with a logon state checking suffix. These values are possible:
"d" = Device, checks the logon state of this destination on device response
"s" = Strict, checks the logon state of this destination of SwyxWare/NetPhone logon state
"a" = Always, assumes that destination is free, use this for external destinations
"r1" = Remote server 1, checks the logon state on a remote server set in remote servers parameter
"r2" = Remote server 2, checks the logon state on a remote server set in remote servers parameter
...
"r9" = Remote server 9, checks the logon state on a remote server set in remote servers parameter


Multiple destinations with custom delivery

Custom|[Destination1]|[Destination2]|[Destination3]...

For use of this delivery method the following things has to be regarded:
· The initial call of this method has to be setting the ForwardingDestination to "Custom"
· As parameters has to be set to the destinations used for logon checking. For example "Custom|100|200" would check if someone on destination 100 or 200 is logged on. Is no one logged on the logged off condition rule is executed.
· Using the custom delivery method calls a function "CheckCustomCallDelivery". In this function several queue parameters can be changed.
· The CheckCustomCallDelivery function has to be defined as following:
· Function CheckCustomCallDelivery(objQueue, ByRef aDestinations, ByRef aDestinationsState, ByRef aDestinationsMode, ByRef aRemoteServersName, ByRef dParameters)
· The several parameters are defined as following:
· objQueue contains the queue object for direct access to queue function. This object should only be used for logging purposes by calling objQueue.LogString. This method logs messages to the queue controller trace files
· aDestinations contains the destinations available to the queue at this moment. It contains all destinations from the delivery methods including the resolved group members rotating, sequential, random and longest waiting
· aDestinationsState contains the logon state for the corresponding destination from aDestinations. Possible states are 0=logged off, 1=busy, 2=free
· aDestinationsMode contains the logon state checking method for the corresponding destination from aDestinations
· aRemoteServersName contains the list of remote servers
· dParameters contains a collection of queue parameters with the possibility to change these values. Possible parameters are listed below

Example: Changing the delivery destination depending on the state of 2 groups

'#include "actionIsUserOrGroupFree.vbs"
Dim gGroup1, gGroup2
Function CheckCustomCallDelivery(objQueue, ByRef aDestinations, ByRef aDestinationsState, ByRef aDestinationsMode, ByRef aRemoteServersName, ByRef dParameters)
Dim nCallID, rParameters
nCallID = dParameters.Item("CallID")

PBXScript.OutputTrace "Custom delivery function..."
PBXScript.OutputTrace "CallID: " & nCallID

Set rParameters = new GSEParamList
rParameters.Count = 2
rParameters.AddParam "Number", gGroup1
rParameters.AddParam "Result", "0"

PBXScript.OutputTrace "Calling actionIsUserOrgGroupFree function..."
actionIsUserOrGroupFree rParameters
If CStr(rParameters.m_FunctionResult) = "1" Then
dParameters.Item("NewForwardingDestination") = "LongestWaiting|" & gGroup1
Else
dParameters.Item("NewForwardingDestination") = "LongestWaiting|" & gGroup1 & "|" & gGroup2
End If
CheckCustomCallDelivery = False
End Function

This function uses an action block to determine the state of a group and sets the delivery method depending on the state of this group.
The queue delivers the call to group1 AND group2, if at least one member is free using the longest waiting delivery method if no member in group1 is free.

Possibly parameters getting for dParameters.Item([ParameterName]) are:
CallID, CallTime, CallPosition, ForwardingDestination, EvaluateLockedLineAsLoggedOff and InstantDelivery

Possibly parameters setting for dParameters.Item([ParameterName]) are:
NewForwardingDestination, NewDeliveryDestination, NewDeliveryDestinationTimeout, NewDeliveryDestinationMode, NewDeliveryName, NewEvaluateLockedLineAsLoggedOff, NewInstantDelivery, and NewFreeMembers


Call connect time

Default value: 15

This value sets the connection attempt timeout a call is delivered to the call destination if the call destination is free. Using zero as value is not recommended because it stops the execution of all following call queue actions because the call is delivered infinitely.

(standard and professional version)


Call not connected mail notification

Default value: 0

If this value is set to "1", the call queue sends a mail notification if a call is not picked up from the destination.

(professional version only)


Call not connected mail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the notification mail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

(professional version only)


Call not connected mail subject

Default value: Call Queue: Delivery timed out or has been rejected

This value sets the Email subject of the notification mail. The following placeholders are possible:

%name% = Caller name
%number% = Caller number
%time% = Call start time
%starttime%" = Call start time
%callingnumber% = Caller number
%callednumber%" = Called number
%dialednumber%" = Dialed number
%callid%" = CallId
%calltype%" = Call type
%duration% = Call duration (for time waiting in queue use %deliveredtime% instead)
%connectedname% = Connected name
%connectednumber% = Connected number

%reason% = Reason (rejected or timeout)
%deliverednumber% = Destination number
%deliveredtime% = Delivery time (time waiting in queue)

(professional version only)


Call not connected mail body

Default value: Call Information|CallID: %callid%|CallerName: %name%|CallerNumber: %number%|Start: %time%|Duration: %deliveredtime%|Delivered to: %deliverednumber%|Reason: %reason%

This value sets the Email body of the notification mail. The following placeholders are possible:

%name% = Caller name
%number% = Caller number
%time% = Call start time
%starttime%" = Call start time
%callingnumber% = Caller number
%callednumber%" = Called number
%dialednumber%" = Dialed number
%callid%" = CallId
%calltype%" = Call type
%duration% = Call duration (for time waiting in queue use %deliverdtime% instead)
%connectedname% = Connected name
%connectednumber% = Connected number

%reason% = Reason (rejected or timeout)
%deliverednumber% = Destination number
%deliveredtime% = Delivery time (time waiting in queue)

Annotation:
· Use "|" as new line separator

(professional version only)


Call instant delivery

Default value: 0

This value affects the delivery of calls in the queue. If instant call delivery is set to "0" the calls are queued and delivered in exact the same order as they appear in the queue. If instant call delivery is set to "1" the call queue tries to deliver calls faster and in a random order.

Example: Instant call delivery set to off
Call on position 1, destination group 50
Call on position 2, destination group 50

If call on position 1 is picked up by an agent the next call is delivered to this group. If this group has a sequential, rotary or random delivery method set, the other agents in this group have to wait until the one agent that phone is ringing picks up and answers the call.

Example: Instant call delivery set to on
Call on position 1, destination group 50
Call on position 2, destination group 50

Both calls will be delivered simultaneously to the group. Two phones are ringing at the same time and the call can be answered more quickly. The amount of calls delivered simultaneously is limited to the amount of logged on and free members in the destination set.

(standard and professional version)


Call hold time if not connected

Default value: 15

This value sets the minimum time a user hears hold music before the next connection attempt is possible. This feature prevents a user from hearing just one second hold music before the next connection attempt is made. This condition matches if destination is free but nobody answers the call. This value can be decreased if call queue plays hold music while connecting. Value can be set to 1 because there is no need for a long hold time period in this scenario.

(standard and professional version)


Call priority

Default value: 2

This value set the priority of the caller in the call queue.
1 – Add caller to top of queue
2 – Add caller to bottom of queue

(standard and professional version)


Call timeout

Default value: 3600

This value sets the maximum time a caller can stay in the call queue before a timeout occurs. This time is similar to the escalation timeout but the caller is connected the call queue voicemail (if set) and not the escalation process.

(standard and professional version)


Call hold music

Default value: *hold*

This value sets the call hold music for the caller. Setting this value to "0" the queue uses the system music on hold configured in SwyxWare/NetPhone Administration. Different music on hold can be used for each call. The music on hold can be changed by entering the name of the wav-file for music on hold.

(standard and professional version)


Call queue plays hold music while connecting

Default value: 1

This parameter lets SwyxWare/NetPhone play music on hold while the call is ringing internal. The external caller does not hear the internal ringtone. The call is transferred if the internal user hooks off the phone.

(standard and professional version)


Call queue plays hold music on welcome

Default value: 1

Is this parameter is set to "1" the call queue plays music on hold in the background of the welcome announcement. The music on hold is faded in and out by SwyxWare/NetPhone automatically.

(standard and professional version)


Call queue plays hold music on selection

Default value: 1

Is this parameter is set to "1" the call queue plays music on hold in the background of the selection announcement. The music on hold is faded in and out by SwyxWare/NetPhone automatically.

(professional version only)


Call queue uses strict logon state checking

Default value: 1

The call queue distinguishes between two logon state checking methods.

If strict logon state checking is activated the logon state is checked on base of the SwyxWare logon state shown in SwyxWare/NetPhon Administration.

Example:
In SwyxWare/NetPhon Administration only SwyxIt! is marked as logon device on the devices tab in SwyxWare/NetPhone Administration. If SwyxIt! and SwyxPhone are logged on, the user is marked as logged on. If the user logs off SwyxIt! he will be marked as logged off although his SwyxPhone remains logged on. This logon state is that state that is displayed on the name keys in SwyxIt!

Group 69:
Member A, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)
Member B, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)
Member C, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)

Group 69 is logged off, if all SwyxIt!s are closed.

If strict logon state checking is deactivated the logon state is checked on base of device state.

Example:
A user is displayed as logged off in SwyxWare/NetPhone Administration but his SwyxPhone is logged on. The user could pick up the call, so the call queue will assume the user as logged on. In this scenario the states of the lines in SwyxIt! and SwyxPhone are included in logon state checking process.

Group 69:
Member A, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)
Member B, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)
Member C, SwyxIt! in CTI Mode with SwyxPhone (Logon Device only SwyxIt!)

Group 69 is logged off, it all SwyxIt!s and SwyxPhones are logged off or no SwyxPhone has a configured free line for destination number 69.

This behaviour can be overwritten for each destination by adding a suffix like "d", "s", "a" or "r1..9" to the destination. See call queue forwarding destinations

(standard and professional version)


Call queue remote servers for logon state checking

Default value: [localhost:81],[+49...]|[remotehost:81],[+49...]

This value defines the remote server sets that can be used for logon state checking on remote servers. On the remote server a 3iMedia Call Queue Controller is needed as well.

Example:
swyxserver1.customer.com:81,+4972178167|swyxserver2.customer.com:81,+492314777

As described in chapter call forwarding destination each destination can be suffixed with a destination logon state checking flag ("s", "d", "a" or "r1".."r9"). The "r1"..."r9" flags correspond to the remote server sets in this chapter.

The destination set 10r1 checks the internal destination 10 on the server swyxserver1.customer.com on port 81 and connects to +4972178167-10 if this destination is free.
The destination set 20r2 checks the internal destination 20 on the server swyxserver2.customer.com on port 81 and connects to +492314777-20 if this destination is free.

(professional version only)


Call queue evaluates locked line as logged off

Default value: 0

Is this parameter is set to "1" the call queue evaluates a locked line key for the destination as logged off.

Example:
The call queue for the operator has the destination set "Preferred;60,10,0;61,20,0". That means the call queue tries to deliver the call first to the destination 60 and if that user is not logged on or free the call queue delivers the call to destination 61.
If destination 60 is logged on and destination 61 is logged on but has his line key for 61 locked, the call queue will assume that there is still somebody to take the call. If the destination 61 is only standby operator and has his line key locked normally it doesn't make sense to let a caller wait in the queue.
Setting this parameter to "1" lets the call queue evaluate this condition as logged off too. So if all callers in the destination sets are logged off or locked their line keys the logged off condition is executed.

(standard and professional version)


Call queue allows entering queue if no user logged on

This parameter has been removed


Call queue allows staying in queue if no user logged on

Default value: 1

This value controls the behavior if the callers in the queue stay in queue if all agents have logged off. If a caller is in the queue and all users in the call queue destination are logged off the caller is removed from the queue and the logged off condition is executed.

(standard and professional version)


Call queue actives call on exit

Default value: 1

If this value is set to "0" the call stays on hold if the call is dropped from the queue. Sometimes it is necessary to add more than one queue in a chain. To avoid fading out music on hold on transferring the call from one queue to another set this value to zero.

(standard and professional version)


Welcome announcements

Default value: Call Queue - Welcome.wav

This sound file is played it the caller is added to the queue. The welcome announcement is not played if the call queue destination is free and the call is connected on the first connection attempt. It the call queue destination is free but the call is not connected the welcome announcement is played once for every caller. If a new caller is on position higher than two, the welcome announcement is played immediately.

(standard and professional version)

Multiple announcements can be separated them with a "|" between the different announcement files.

Example:
Announcement1.wav|Announcement2.wav|Announcement3.wav|Announcement4.wav

(professional version only)


Caller position

On welcome announcement it is possible to add the caller position to every announcement.

Example:
Announcement1.wav,1|Announcement2.wav,0

The call queue will play announcement1.wav and add the caller position after the announcement. Right after the caller position announcement2.wav is played but no caller positions is added.

(professional version only)


Call queue plays welcome before connecting

Default value: 0

This value controls the timing of the welcome announcement. If this value is set to 1 the welcome announcement is played before the first connection attempt. If the value is set to 0 the call queue will first try to reach a destination and will play the welcome announcement afterwards.

(standard and professional version)


Call user logged off override

Default value: 0

If this value is set to "1" the call queue assumes that all users are logged off. This parameter should be uses if own logged off conditions have to be checked before the call is placed in the queue.

Example:
Office hours are from Monday to Friday from 8 am to 4 pm. Add the standard ECR actions for the time checking and set a variable to "1" if the caller is calling outside the office hours. Use this variable as value for this call queue parameter.

(standard and professional version)


Call user logged off destination

Default value: 0

This value sets the destination a caller is connected to if no agent is logged on in the forwarding destination group or the call queue logged off override parameter is set to "1". If this value is not "0" the caller is connected to the configured number.

(standard and professional version)


Call user logged off destination timeout

Default value: 15

This value sets the duration a caller is connected to the logged off destination number before a connect timeout occurs.

(standard and professional version)


Call user logged off proceed with destination script

Default value: 0

This value affects the call transfer. Setting this value to "1" executes the call routing script of the SwyxWare/NetPhone user the call is transferred to.

(professional version only)


Call user logged off voicemail

Default value: 0

This value enabled the voicemail a caller is connected to if no agent is logged on in the forwarding destination group or the call queue logged off override parameter is set to "1".

Annotation:
If both "call queue logged off destination" and "call queue user logged off voicemail" are set, the call will be connected to voicemail if the connection attempt reaches a timeout or unreachable condition.

(standard and professional version)


Call user logged off voicemail file

Default value: 0

This value sets the voicemail file used For the logged off condition described above. If this value is Set To 0 the default voicemail of the script user is used otherwise the configured voicemail file is played.

(standard And professional version)


Call user logged off voicemail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the voicemail described above. The default value uses the address of the script user configured in SwyxWare/Netphone Administration.

(standard and professional version)


Call user logged off mail notification

Default value: 0

If this value is set to "1", the call queue sends a mail notification if all destinations are logged off.

(standard and professional version)


Call user logged off mail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the notification mail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

(standard and professional version)


Call user logged off mail subject

Default value: Call Queue: All destinations logged off

This value sets the Email subject of the notification mail. The following placeholders are possible:

%name% = Caller name
%number% = Caller number
%time% = Call start time
%starttime%" = Call start time
%callingnumber% = Caller number
%callednumber%" = Called number
%dialednumber%" = Dialed number
%callid%" = CallId
%calltype%" = Call type
%duration% = Call duration
%connectedname% = Connected name
%connectednumber% = Connected number

(standard and professional version)


Call user logged off mail body

Default value: Call Information|CallID: %callid%|CallerName: %name%|CallerNumber: %number%|Start: %time%|Duration: %duration%

This value sets the Email body of the notification mail. The following placeholders are possible:

%name% = Caller name
%number% = Caller number
%time% = Call start time
%starttime%" = Call start time
%callingnumber% = Caller number
%callednumber%" = Called number
%dialednumber%" = Dialed number
%callid%" = CallId
%calltype%" = Call type
%duration% = Call duration
%connectedname% = Connected name
%connectednumber% = Connected number

Annotation:
· Use "|" as new line separator

(professional version only)


Call user logged off escalation

Default value: 0

This value sets the behavior of the call queue to proceed with the escalation process if the following conditions match:
Call queue user logged off condition is true
Call queue user logged off destination is configured but could not be reached
Call queue user logged off voicemail is not configured

(standard and professional version)


Call user logged off error

Default value: 0

This value sets the behavior of the call queue to proceed with the error process if the following conditions match:
Call queue user logged off condition is true
Call queue user logged off destination is configured but could not be reached
Call queue user logged off voicemail is not configured

Annotation:
If both "Call queue user logged off escalation" and "Call queue user logged off error" are set only the first action is executed.

(standard and professional version)


Call user logged off stylesheet

Default value: ColorSetLoggedOff

This parameter sets the stylesheet used in web frontend for logged off condition. The calls are displayed in the active connections list.

(professional version only)


Call escalation timeout

Default value: 0

This value sets the maximum time a caller can stay in the call queue. After the escalation timeout the caller is forwarded to the escalation process described below. This prevents the caller from staying in the call queue for too long.

(professional version only)


Call escalation destination

Default value: 0

This value sets the destination a caller is connected to if the escalation timeout is reached. If this value is not "0" the caller is connected to the configured number.

(professional version only)


Call escalation destination timeout

Default value: 15

This value sets the duration a caller is connected to the escalation destination number before a connect timeout occurs.

(professional version only)


Call escalation proceed with destination script

Default value: 0

This value affects the call transfer. Setting this value to "1" executes the call routing script of the SwyxWare/NetPhone user the call is transferred to.

(professional version only)


Call escalation voicemail

Default value: 0

This value enabled the voicemail a caller is connected to if the escalation timeout occurs.

Annotation:
If both "call queue escalation destination" and "call queue escalation voicemail" is set, the call will be connected to voicemail if the connection attempt reaches a timeout or unreachable condition.

(professional version only)


Call escalation voicemail file

Default value: 0

This value sets the voicemail file used for the escalation condition described above. If this value is set to 0 the default voicemail of the script user is used otherwise the configured voicemail file is played.

(professional version only)


Call escalation voicemail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the voicemail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

(professional version only)


Call escalation error

Default value: 0

This value sets the behavior of the call queue to proceed with the error process if the following conditions match:
· Call queue escalation condition is true
· Call queue escalation destination is configured but could not be reached
· Call queue escalation voicemail is not configured

(professional version only)


Call escalation stylesheet

Default value: ColorSetEscalation

This parameter sets the stylesheet used in web frontend for escalation condition. The calls are displayed in the active connections list.

(professional version only)


Call announcement timeout

Default value: 0

This value sets the timeout for the call queue announcement. The call queue announcement is an announcement that is played after the welcome announcement to inform the caller to be patient.

(standard and professional version)


Call announcement repeat

Default value: 1

This value defines whether the call queue announcement is repeated or just played once.

(standard and professional version)


Announcement files

Default value: Call Queue - Announcement.wav

This value sets the call queue announcement files. These files are played if the call queue announcement timeout occurs.

(standard and professional version)

Multiple announcements can be separated them with a "|" between the different announcement files. After the first timeout the first announcement is played, after the second timeout the second announcement and so on...

Example:
Announcement1.wav|Announcement2.wav|Announcement3.wav|Announcement4.wav

(professional version only)


Caller position

On these announcements it is possible to add the caller position to every announcement.

Example:
Announcement1.wav,1|Announcement2.wav,0

The call queue will play announcement1.wav and add the caller position after the announcement. Right after the caller position announcement2.wav is played but no caller positions is added.

(professional version only)


Call selection timeout

Default value: 0

This value sets the timeout for the call queue selection. The call queue selection is a voice menu after the call queue announcement that gives the caller the possibility to select from different choices by sending dtmf tones with his telephone.


Call selection repeat

Default value: 1

This value defines whether the call queue selection is repeated or just played once.


Call selection before first connect

Default value: 0

This value defines whether the call queue selection menu is played before th first connection attempt. Otherwise the selection menu is played after the selection timeout. This option is useful for IVR-menus that should offer the possible options directly after the welcome announcement(s).


Call selection after first connect

Default value: 0

This value defines whether the call queue selection menu is played after the first connection attempt. Otherwise the selection menu is played after the selection timeout. This option is useful for IVR-menus that should offer the possible options directly after the first connection attempt.


Call selection file

Default value: Call Queue - Selection.wav

This value sets the call queue selection file. This file is played if the call queue selection timeout occurs.


Call selection dtmf timeout

Default value: 3

This value sets the time a caller can enter his choice in the IVR menu. Increasing this value gives the caller more time to make his decision.

Annotation:
The script is hold until the dtmf timeout occurs or the caller enters a dtmf digit. So do not increase this value to much. A maximum value of 10 should not be exceeded.


Call selection voicemail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the voicemail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.


Call selection callback mail notification

Default value: 0

If this value is set to "1", the call queue sends a mail notification if a callback has been requested.

(standard and professional version)


Call selection callback mail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the notification mail described above. The default value uses the address of the script user configured in SwyxWare/NetPhone Administration.

(standard and professional version)


Call selection callback mail subject

Default value: Call Queue: Caller requested callback

This value sets the Email body of the notification mail. The following placeholders are possible:

%name% = Caller name
%number% = Caller number
%time% = Call start time
%starttime%" = Call start time
%callingnumber% = Caller number
%callednumber%" = Called number
%dialednumber%" = Dialed number
%callid%" = CallId
%calltype%" = Call type
%duration% = Call duration

%callbacknumber% = Number of caller

Annotation:
· Use "|" as new line separator

(professional version only)


Call selection callback mail body

Default value: Call Information|CallID: %callid%|CallerName: %name%|CallerNumber: %callbacknumber%|Start: %time%|Duration: %duration%

This value sets the Email body of the notification mail. The following placeholders are possible:

%name% = Caller name
%number% = Caller number
%time% = Call start time
%starttime%" = Call start time
%callingnumber% = Caller number
%callednumber%" = Called number
%dialednumber%" = Dialed number
%callid%" = CallId
%calltype%" = Call type
%duration% = Call duration

%callbacknumber% = Number of caller

Annotation:
· Use "|" as new line separator

(professional version only)


Call selection key 0..9, *, #, timeout

These parameters offer the possibility to set the actions for the different IVR inputs within the selection menu.

Possible actions are:
· Nothing
· Voicemail
· Connect
· SimpleCallback
· AdvancedCallback

Nothing:
This action does nothing. It seems senseless at the first look. In conjunction with the selection key timeout parameter it can be used to force a caller to press a digit on his phone to stay in the queue. So the announcement says "Please press 1 to stay in the line" If the caller pressed nothing the selection key time puts him to the voicemail.

Voicemail:
Transfers the call to the selection voicemail

Connect:
Transfers the call to the corresponding destination and proceeds with the call routing of that destination

SimpleCallback:
The simple callback removes the call from the queue and puts him to the callback request list in the web front end. If the caller doesn't transmit a caller id the caller id is asked by a dtmf input sequence and used as callback number.

AdvancedCallback:
The advanced callback works like the simple callback but the caller stays virtually in the queue. It moves to the top position just as he would in the queue. If the caller would have been on position 1, the call is removed from the queue and put in the callback request list.

The corresponding destination parameter sets the destination the call is connected to if the call queue selection key entry is set to "Connect"


Call selection stylesheet

Default value: ColorSetSelection

This parameter sets the stylesheet used in web frontend for selection condition.

(professional version only)


Call queue voicemail

Default value: 0

This value enables the call queue voicemail. The call queue voicemail will be executed if one of the following conditions matches:
· Call queue sized exceeded
· Call queue call timeout occurred

(standard and professional version)


Call queue voicemail file

Default value: 0

This value sets the voicemail file used for call queue voicemail described above. If this value is set to 0 the default voicemail of the script user is used otherwise the configured voicemail file is played.

(standard and professional version)


Call queue voicemail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the voicemail described above. The default value uses the address of the script user configured in SwyxWare/NetPhon Administration.

(standard and professional version)


Call queue voicemail stylesheet

Default value: ColorSetVoicemail

This parameter sets the stylesheet used in web frontend for the call queue voicemail. The calls are displayed in the active connections list.

(professional version only)


Call disconnect mail notification

Default value: 0

If this value is set to 1, the call queue sends a mail notification if the caller hooks on without being connected to any destination.

(professional version only)


Call disconnect mail address

Default value: PBXUser.VoicemailEMailAddress

This value sets the Email address for the notification mail described above. The default value uses the address of the script user configured in SwyxWare/NetPhon Administration.

(professional version only)


Call disconnect mail subject

Default value: Call Queue: User has hook on during call queue

This value sets the Email subject of the notification mail. The following placeholders are possible:

%name% = Caller name
%number% = Caller number
%time% = Call start time
%starttime%" = Call start time
%callingnumber% = Caller number
%callednumber%" = Called number
%dialednumber%" = Dialed number
%callid%" = CallId
%calltype%" = Call type
%duration% = Call duration
%connectedname% = Connected name
%connectednumber% = Connected number

(professional version only)


Call disconnect mail body

Default value: Call Information | CallID: %callid%|CallerName: %name%|CallerNumber: %number%|Start: %time%|Duration: %duration%

This value sets the Email body of the notification mail. The following placeholders are possible:

%name% = Caller name
%number% = Caller number
%time% = Call start time
%starttime%" = Call start time
%callingnumber% = Caller number
%callednumber%" = Called number
%dialednumber%" = Dialed number
%callid%" = CallId
%calltype%" = Call type
%duration% = Call duration
%connectedname% = Connected name
%connectednumber% = Connected number

Annotation:
· Use "|" as new line separator

(professional version only)


Call disconnect threshold

Default value: 5

If this value defines a threshold for the mail notification. Default value is 5 seconds. So if a caller hooks on within the first 5 seconds no notification mail is sent.

(professional version only)


Call disconnect clearing timeout

Default value: 60

This value defines the time a disconnected caller is visible in web frontend. A disconnected call is displayed in the active calls list.

(standard and professional version)


Call aborted clearing timeout

Default value: 10

This value defines the time an aborted call is visible in web frontend. An aborted call is displayed in the active calls list.

(standard and professional version)


Call lost clearing timeout

Default value: 600

This value defines the time a lost caller is visible in web frontend. A lost call is displayed in the lost calls list. Setting this value to "0" the calls will never be removed from the lost calls list.

(standard and professional version)


Return values

The call queue block has several return values, depending on the conditions and actions executed within the call queue. These return values can be uses to add further actions in ECR-scripts. For standard CRM-script an evaluation of these return values is not possible.

Logged off checking
10 All possible destinations are logged off
11 Call connected to logged off destination
12 Call connected to logged off special voicemail
13 Call connected to call queue default voicemail
19 No valid destination found

Escalation processing
21 Call connected to escalation destination
22 Call connected to escalation special voicemail
23 Call connected to call queue default voicemail

Error processing
31 Call connected to error destination
32 Call connected to error special voicemail
33 Call connected to call queue default voicemail

Call Queue processing
41 Call connected to destination
42 Common error while processing the call in the queue. See trace for further details
43 Call lost
44 Queue size exceeded
45 Destination unreachable
46 Call timeout has been reached
47 Escalation timeout has been reached
48 Call aborted
49 Selection pressed

52 Call connected to queue special voicemail
53 Call connected to default voicemail

61 Call connected to selection destination
62 Call connected to selection special voicemail
63 Call connected to default voicemail
64 Caller requested a callback

90 Error creating queue COM object
91 Error creating queue
92 Error adding call to queue
97 Invalid license (invalid call property set)
98 Invalid license (maximum queue count exceeded, 1 for standard version)
99 Invalid license (license invalid, evaluation period expired)

(standard and professional version)


Call queue overview

This view displays the overview of all available queues. Selecting one queue jumps to the call queue view page.
http://server:81/Index.html

Fields:
ID = Call queue ID
Name = Call queue name
Queue size = actual call queue size and maximum call queue size separated by "/"

(standard and professional version)


Call queue view

This view displays all calls in the selected queue. The connected calls are displays below the caller waiting in the queue. At the bottom of the page all lost calls are displayed.
http://server:81/QueueCalls.html?QueueID=X
http://server:81/QueueCallsSmall.html?QueueID=X (used for SwyxIt! Webextension)

(standard and professional version)


Call queue all calls

This view displays an overview of all calls in all queues. The connected calls are displays below the caller waiting in the queue. At the bottom of the page all lost calls are displayed.
http://server:81/QueueAllCalls.html
http://server:81/QueueAllCallsSmall.html (used for SwyxIt! Webextension)

(standard and professional version)


Call pickup

To enable the call pickup functionality the pickup destination has to be included in the calling url.

Example:
Call pickup destination is 60.
The corresponding url has to be something like this: http://localhost:81/Index.html?Dummy=0&PickupDestination=60
Instead of the Index.html any other html-file can be used. Please ensure that the PickupDestination parameter starts with a "&"

In SwyxIt!/NetPhone Client Webextension parameters can be included in the calling url. So the url in the upper example can be:
http://localhost:81/Index.html?Dummy=0&PickupDestination=%OwnName%

This url is used in the skin files installed in the skins subfolder.


Call details

This view displays the call details.

(standard and professional version)


Global members view

This view displays all members of a group. The group parameters have to be added in html page
http://server:81/QueueMembers.html
http://server:81/QueueMembersSmall.html (used for SwyxIt! Webextension)

http://server:81/StatusMembers.html
http://server:81/StatusMembersSmall.html (used for SwyxIt! Webextension)

(professional version only)


Global calls view

This view displays all calls in SwyxWare, grouped by internal, outgoing and incoming calls.
http://server:81/GlobalAllCalls.html
http://server:81/GlobalAllCallsSmall.html (used for SwyxIt! Webextension)

Annotation:
SwyxWare/Netphone only resolves numbers on outgoing call against the inernal phonebooks. For number resolution against other systems (CRM, ERP) 3iMedia Metaservices for Swyxware/NetPhone has to be installed.

(professional version only)


HTML Templates

The front end can be customized on customers demand. All HTML files can contain tags that are parsed before displaying the web page.
These tags are described in the following chapters. The tags have to use the following syntax:

<%TagName%>
<%TagName:Parameter:Value%>
<%Set Value=Property%>

The html files containing the tags have to be in the webdir folder specified in the registry. Default location for that folder is the html subfolder in the installation directory.
The customized files should be placed in the custom subfolder. So the original html files are not overwritten. The webserver uses files in the custom folder first!


QueueList

Description:
Contains a list with all queues as HTML-table including the table headers.

Optional tags in HTML file:
Set QueueCallsURL: URL for queue calls link

Hiding queues from view:
Set QueueHide1=QueueID
Set QueueHide2=QueueID
Set QueueHide3=QueueID
...
Set QueueHideX=QueueID

Do not use Hide and Show on the same page

Show only queues in view:
Set QueueShow1=QueueID
Set QueueShow2=QueueID
Set QueueShow3=QueueID
...
Set QueueShowX=QueueID

Do not use Hide and Show on the same page

Hiding columns from view:
Set QueueListHiddenColumns1=1
Set QueueListHiddenColumns2=2
Set QueueListHiddenColumns3=3

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

(standard and professional version)


QueueList/Body

Description:
Contains a list with all queues as HTML-table without the table headers.

Optional tags in HTML file:
Set QueueCallsURL: URL for queue calls link

Hiding queues from view:
Set QueueHide1=QueueID
Set QueueHide2=QueueID
Set QueueHide3=QueueID
...
Set QueueHideX=QueueID

Do not use Hide and Show on the same page

Show only queues in view:
Set QueueShow1=QueueID
Set QueueShow2=QueueID
Set QueueShow3=QueueID
...
Set QueueShowX=QueueID

Do not use Hide and Show on the same page

Hiding columns from view:
Set QueueListHiddenColumns1=1
Set QueueListHiddenColumns2=2
Set QueueListHiddenColumns3=3

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

(standard and professional version)


QueueCallsList

Description:
Contains a list with all callers waiting in the selected queue as HTML-table including the table headers.

Mandatory parameters in URL:
QueueID: ID of the selected queue

Optional tags in HTML file:
Set QueueCallsURL: URL for action link
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueCallsListHiddenColumns1=1
Set QueueCallsListHiddenColumns2=2
Set QueueCallsListHiddenColumns3=3
Set QueueCallsListHiddenColumns4=4
Set QueueCallsListHiddenColumns5=5
Set QueueCallsListHiddenColumns6=6
Set QueueCallsListHiddenColumns7=7
Set QueueCallsListHiddenColumns8=8

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(standard and professional version)


QueueCallsList/Body

Description:
Contains a list with all callers waiting in the selected queue as HTML-table without the table headers.

Mandatory parameters in URL:
QueueID: ID of the selected queue

Optional tags in HTML file:
Set QueueCallsURL: URL for action link
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueCallsListHiddenColumns1=1
Set QueueCallsListHiddenColumns2=2
Set QueueCallsListHiddenColumns3=3
Set QueueCallsListHiddenColumns4=4
Set QueueCallsListHiddenColumns5=5
Set QueueCallsListHiddenColumns6=6
Set QueueCallsListHiddenColumns7=7
Set QueueCallsListHiddenColumns8=8

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(standard and professional version)


QueueActiveCallsList

Description:
Contains a list with all active calls in the selected queue as HTML-table including the table headers.

Mandatory parameters in URL:
QueueID: ID of the selected queue

Optional tags in HTML file:
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueActiveCallsListHiddenColumns1=1
Set QueueActiveCallsListHiddenColumns2=2
Set QueueActiveCallsListHiddenColumns3=3
Set QueueActiveCallsListHiddenColumns4=4
Set QueueActiveCallsListHiddenColumns5=5
Set QueueActiveCallsListHiddenColumns6=6
Set QueueActiveCallsListHiddenColumns7=7
Set QueueActiveCallsListHiddenColumns8=8

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(standard and professional version)


QueueActiveCallsList/Body

Description:
Contains a list with all active calls in the selected queue as HTML-table without the table headers.

Mandatory parameters in URL:
QueueID: ID of the selected queue

Optional tags in HTML file:
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueActiveCallsListHiddenColumns1=1
Set QueueActiveCallsListHiddenColumns2=2
Set QueueActiveCallsListHiddenColumns3=3
Set QueueActiveCallsListHiddenColumns4=4
Set QueueActiveCallsListHiddenColumns5=5
Set QueueActiveCallsListHiddenColumns6=6
Set QueueActiveCallsListHiddenColumns7=7
Set QueueActiveCallsListHiddenColumns8=8

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(standard and professional version)


QueueLostCallsList

Description:
Contains a list with all lost calls in the selected queue as HTML-table including the table headers.

Mandatory parameters in URL:
QueueID: ID of the selected queue

Optional tags in HTML file:
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueLostCallsListHiddenColumns1=1
Set QueueLostCallsListHiddenColumns2=2
Set QueueLostCallsListHiddenColumns3=3
Set QueueLostCallsListHiddenColumns4=4
Set QueueLostCallsListHiddenColumns5=5

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(professional version only)


QueueLostCallsList/Body

Description:
Contains a list with all lost calls in the selected queue as HTML-table without the table headers.

Mandatory parameters in URL:
QueueID: ID of the selected queue

Optional tags in HTML file:
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueLostCallsListHiddenColumns1=1
Set QueueLostCallsListHiddenColumns2=2
Set QueueLostCallsListHiddenColumns3=3
Set QueueLostCallsListHiddenColumns4=4
Set QueueLostCallsListHiddenColumns5=5

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(professional version only)


QueueAllCallsList

Description:
Contains a list with all callers waiting in all queue as HTML-table including the table headers.

Optional tags in HTML file:
Set QueueAllCallsURL: URL for action link
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueAllCallsListHiddenColumns1=1
Set QueueAllCallsListHiddenColumns2=2
Set QueueAllCallsListHiddenColumns3=3
Set QueueAllCallsListHiddenColumns4=4
Set QueueAllCallsListHiddenColumns5=5
Set QueueAllCallsListHiddenColumns6=6
Set QueueAllCallsListHiddenColumns7=7
Set QueueAllCallsListHiddenColumns8=8
Set QueueAllCallsListHiddenColumns9=9

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(standard and professional version)


QueueAllCallsList/Body

Description:
Contains a list with all callers waiting in all queue as HTML-table without the table headers.

Optional tags in HTML file:
Set QueueAllCallsURL: URL for action link
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueAllCallsListHiddenColumns1=1
Set QueueAllCallsListHiddenColumns2=2
Set QueueAllCallsListHiddenColumns3=3
Set QueueAllCallsListHiddenColumns4=4
Set QueueAllCallsListHiddenColumns5=5
Set QueueAllCallsListHiddenColumns6=6
Set QueueAllCallsListHiddenColumns7=7
Set QueueAllCallsListHiddenColumns8=8
Set QueueAllCallsListHiddenColumns9=9

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(standard and professional version)


QueueAllActiveCallsList

Description:
Contains a list of all active calls in all queues as HTML-table including the table headers.

Optional tags in HTML file:
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueAllActiveCallsListHiddenColumns1=1
Set QueueAllActiveCallsListHiddenColumns2=2
Set QueueAllActiveCallsListHiddenColumns3=3
Set QueueAllActiveCallsListHiddenColumns4=4
Set QueueAllActiveCallsListHiddenColumns5=5
Set QueueAllActiveCallsListHiddenColumns6=6
Set QueueAllActiveCallsListHiddenColumns7=7
Set QueueAllActiveCallsListHiddenColumns8=8
Set QueueAllActiveCallsListHiddenColumns8=9

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(standard and professional version)


QueueAllActiveCallsList/Body

Description:
Contains a list of all active calls in all queues as HTML-table without the table headers.

Optional tags in HTML file:
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueAllActiveCallsListHiddenColumns1=1
Set QueueAllActiveCallsListHiddenColumns2=2
Set QueueAllActiveCallsListHiddenColumns3=3
Set QueueAllActiveCallsListHiddenColumns4=4
Set QueueAllActiveCallsListHiddenColumns5=5
Set QueueAllActiveCallsListHiddenColumns6=6
Set QueueAllActiveCallsListHiddenColumns7=7
Set QueueAllActiveCallsListHiddenColumns8=8
Set QueueAllActiveCallsListHiddenColumns8=9

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(standard and professional version)


QueueAllLostCallsList

Description:
Contains a list of all lost calls in all queues as HTML-table including the table headers.

Optional tags in HTML file:
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueAllLostCallsListHiddenColumns1=1
Set QueueAllLostCallsListHiddenColumns2=2
Set QueueAllLostCallsListHiddenColumns3=3
Set QueueAllLostCallsListHiddenColumns4=4
Set QueueAllLostCallsListHiddenColumns5=5
Set QueueAllLostCallsListHiddenColumns6=6

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(professional version only)


QueueAllLostCallsList/Body

Description:
Contains a list of all lost calls in all queues as HTML-table without the table headers.

Optional tags in HTML file:
Set QueueCallDetailsURL: URL for call details link

Hiding columns from view:
Set QueueAllLostCallsListHiddenColumns1=1
Set QueueAllLostCallsListHiddenColumns2=2
Set QueueAllLostCallsListHiddenColumns3=3
Set QueueAllLostCallsListHiddenColumns4=4
Set QueueAllLostCallsListHiddenColumns5=5
Set QueueAllLostCallsListHiddenColumns6=6

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(professional version only)


QueueGroupMembersLoggedOnList

Description:
Contains a list of all logged on members of a group as HTML-table including the table headers.

Optional tags in HTML file:
Set MemberLogOffURL: URL for queue members logon action link
Set QueueGroupMembersMax: Maximum members that can be logged on
Set QueueGroupMembersLogging: Activate logging, log files are saved in the reports folder in the installation folder

User state column:
Set MemberNumberPrefix=+49xxxxxxxxxx Prefix for callto: link for internal numbers to dial number directly from HTML-page
Set MemberState=0,1 Adds the users state to the group member name in braces
Set MemberStateOnly=0,1 Adds the users state but suppresses the logged on/off text
Set MemberStateNoText=0,1 Adds the users state but suppresses the text leaving only the background color

Example 1 (used in QueueMembers.html):
Set MemberNumberPrefix=+4972178167
Set MemberState=1
Set MemberStateOnly=0
Set MemberStateNoText=0
Set QueueMembersListHiddenColumns2=2

Result:
Column 2 that normally contains the internal number with the prefix +4972178167 is hidden
Column 3 contains "Logged on (alerting)"
Column 4 contains the link for logging off from the group

Example 2 (used in QueueMembers_Small.html):
Set MemberNumberPrefix=+4972178167
Set MemberState=0
Set MemberStateOnly=0
Set MemberStateNoText=0
Set QueueMembersListHiddenColumns4=4

Result:
Column 2 that normally contains the internal number with the prefix +4972178167 is hidden
Column 3 contains "Logged on" without the state
Column 4 contains the link for logging off from the group

Example 3 (used in StatusMembers.html):
Set MemberNumberPrefix=+49xxxxxxxxxx
Set MemberState=1
Set MemberStateOnly=1
Set MemberStateNoText=1
Set QueueMembersListHiddenColumns4=4

Result:
Column 2 contains the internal number with the prefix +4972178167
Column 3 contains no text but has a colored background
Column 4 that normally contains the link for logging off from the group is hidden

Hiding columns from view:
Set QueueMembersListHiddenColumns1=1
Set QueueMembersListHiddenColumns2=2
Set QueueMembersListHiddenColumns3=3
Set QueueMembersListHiddenColumns4=4

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

(professional version only)


QueueGroupMembersLoggedOnList/Body

Description:
Contains a list of all logged on members of a group as HTML-table without the table headers.

Optional tags in HTML file:
Set MemberLogOffURL: URL for queue members logon action link
Set QueueGroupMembersMax: Maximum members that can be logged on
Set QueueGroupMembersLogging: Activate logging, log files are saved in the reports folder in the installation folder

User state column:
Set MemberNumberPrefix=+49xxxxxxxxxx Prefix for callto: link for internal numbers to dial number directly from HTML-page
Set MemberState=0,1 Adds the users state to the group member name in braces
Set MemberStateOnly=0,1 Adds the users state but suppresses the logged on/off text
Set MemberStateNoText=0,1 Adds the users state but suppresses the text leaving only the background color

Example 1 (used in QueueMembers.html):
Set MemberNumberPrefix=+4972178167
Set MemberState=1
Set MemberStateOnly=0
Set MemberStateNoText=0
Set QueueMembersListHiddenColumns2=2

Result:
Column 2 that normally contains the internal number with the prefix +4972178167 is hidden
Column 3 contains "Logged on (alerting)"
Column 4 contains the link for logging off from the group

Example 2 (used in QueueMembers_Small.html):
Set MemberNumberPrefix=+4972178167
Set MemberState=0
Set MemberStateOnly=0
Set MemberStateNoText=0
Set QueueMembersListHiddenColumns4=4

Result:
Column 2 that normally contains the internal number with the prefix +4972178167 is hidden
Column 3 contains "Logged on" without the state
Column 4 contains the link for logging off from the group

Example 3 (used in StatusMembers.html):
Set MemberNumberPrefix=+49xxxxxxxxxx
Set MemberState=1
Set MemberStateOnly=1
Set MemberStateNoText=1
Set QueueMembersListHiddenColumns4=4

Result:
Column 2 contains the internal number with the prefix +4972178167
Column 3 contains no text but has a colored background
Column 4 that normally contains the link for logging off from the group is hidden

Hiding columns from view:
Set QueueMembersListHiddenColumns1=1
Set QueueMembersListHiddenColumns2=2
Set QueueMembersListHiddenColumns3=3
Set QueueMembersListHiddenColumns4=4

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

(professional version only)


QueueGroupMembersLoggedOnCount

Description:
Returns the number of members in the corresponding logged on group.

Optional tags in HTML file:
none

(professional version only)


QueueGroupMembersLoggedOffList

Description:
Contains a list of all logged off members of a group as HTML-table including the table headers.

Optional tags in HTML file:
MemberLogOnURL: URL for queue members logon action link
QueueGroupMembersMin: Minimum members that have to be logged on
QueueGroupMembersLogging: Activate logging, log files are saved in the reports folder in the installation folder

Hiding columns from view:
Set QueueMembersListHiddenColumns1=1
Set QueueMembersListHiddenColumns2=2
Set QueueMembersListHiddenColumns3=3
Set QueueMembersListHiddenColumns4=4

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

(professional version only)


QueueGroupMembersLoggedOffList/Body:

Description:
Contains a list of all logged off members of a group as HTML-table without the table headers.

Optional tags in HTML file:
MemberLogOnURL: URL for queue members logon action link
QueueGroupMembersMin: Minimum members that have to be logged on
QueueGroupMembersLogging: Activate logging, log files are saved in the reports folder in the installation folder

Hiding columns from view:
Set QueueMembersListHiddenColumns1=1
Set QueueMembersListHiddenColumns2=2
Set QueueMembersListHiddenColumns3=3
Set QueueMembersListHiddenColumns4=4

To hide a column, remove the "!" in front of the tag in the corresponding HTML-file

(professional version only)


QueueGroupMembersLoggedOffCount

Description:
Returns the number of members in the corresponding logged off on group.

Optional tags in HTML file:
none

(professional version only)


Reload

Description:
Defines the refresh interval used in the html code. The refresh interval can be adjusted in the registry. See registry documentation for further details.

(standard and professional version)


Form

This tag is no longer supported. Use PickupDestination parameter in URL instead.


Parameters

Description:
Contains the complete parameter string collected from the browser url including the "?" This tag is used to pass parameters to other pages.

Example:
/Queue?QueueID=721&CallID=123&PickupDestination=123456&Action=Pickup

Parameter contains ?QueueID=721&CallID=123&PickupDestination=123456&Action=Pickup.

Additional parameters:
CallList, ActiveCallList, AllCallList and AllActiveCallList are using additional parameters like CallID, PickupDestination and Action to perform Pickup, Cancel, Abort, Up, Down and Top.

Examples:

Pickup:
/Queue?QueueID=721&CallID=123&PickupDestination=123456&Action=Pickup

Cancel:
/Queue?QueueID=721&CallID=123&Action=Cancel

Abort:
/Queue?QueueID=721&CallID=123&Action=Abort

(standard and professional version)


Date

Description:
Inserts the actual date

(standard and professional version)


Time

Description:
Inserts the actual time

(standard and professional version)


Custom tags

Description:
Custom tags can be used in the following way

Example 1:
/test.html?Testentry=2

<%Testentry%> is parsed as "2"

Example 2:
<%Key=Value%>

(standard and professional version)


GlobalAllOutgoingCallsList

Description:
Contains a list of all active outgoing calls as HTML-table including the table headers.

Hiding columns from view:
Set GlobalAllCallsListHiddenColumns1=1
Set GlobalAllCallsListHiddenColumns2=2
Set GlobalAllCallsListHiddenColumns3=3
Set GlobalAllCallsListHiddenColumns4=4
Set GlobalAllCallsListHiddenColumns5=5
Set GlobalAllCallsListHiddenColumns6=6
Set GlobalAllCallsListHiddenColumns7=7
Set GlobalAllCallsListHiddenColumns8=8
Set GlobalAllCallsListHiddenColumns9=9
Set GlobalAllCallsListHiddenColumns10=10

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(professional version only)


GlobalAllOutgoingCallsList/Body

Description:
Contains a list of all active outgoing calls as HTML-table without the table headers.

Hiding columns from view:
Set GlobalAllCallsListHiddenColumns1=1
Set GlobalAllCallsListHiddenColumns2=2
Set GlobalAllCallsListHiddenColumns3=3
Set GlobalAllCallsListHiddenColumns4=4
Set GlobalAllCallsListHiddenColumns5=5
Set GlobalAllCallsListHiddenColumns6=6
Set GlobalAllCallsListHiddenColumns7=7
Set GlobalAllCallsListHiddenColumns8=8
Set GlobalAllCallsListHiddenColumns9=9
Set GlobalAllCallsListHiddenColumns10=10

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(professional version only)


GlobalAllIncomingCallsList

Description:
Contains a list of all active incoming calls as HTML-table including the table headers.

Hiding columns from view:
Set GlobalAllCallsListHiddenColumns1=1
Set GlobalAllCallsListHiddenColumns2=2
Set GlobalAllCallsListHiddenColumns3=3
Set GlobalAllCallsListHiddenColumns4=4
Set GlobalAllCallsListHiddenColumns5=5
Set GlobalAllCallsListHiddenColumns6=6
Set GlobalAllCallsListHiddenColumns7=7
Set GlobalAllCallsListHiddenColumns8=8
Set GlobalAllCallsListHiddenColumns9=9
Set GlobalAllCallsListHiddenColumns10=10

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(professional version only)


GlobalAllIncomingCallsList/Body

Description:
Contains a list of all active incoming calls as HTML-table without the table headers.

Hiding columns from view:
Set GlobalAllCallsListHiddenColumns1=1
Set GlobalAllCallsListHiddenColumns2=2
Set GlobalAllCallsListHiddenColumns3=3
Set GlobalAllCallsListHiddenColumns4=4
Set GlobalAllCallsListHiddenColumns5=5
Set GlobalAllCallsListHiddenColumns6=6
Set GlobalAllCallsListHiddenColumns7=7
Set GlobalAllCallsListHiddenColumns8=8
Set GlobalAllCallsListHiddenColumns9=9
Set GlobalAllCallsListHiddenColumns10=10

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(professional version only)


GlobalAllInternalCallsList

Description:
Contains a list of all active internal calls as HTML-table including the table headers.

Hiding columns from view:
Set GlobalAllCallsListHiddenColumns1=1
Set GlobalAllCallsListHiddenColumns2=2
Set GlobalAllCallsListHiddenColumns3=3
Set GlobalAllCallsListHiddenColumns4=4
Set GlobalAllCallsListHiddenColumns5=5
Set GlobalAllCallsListHiddenColumns6=6
Set GlobalAllCallsListHiddenColumns7=7
Set GlobalAllCallsListHiddenColumns8=8
Set GlobalAllCallsListHiddenColumns9=9
Set GlobalAllCallsListHiddenColumns10=10

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(professional version only)


GlobalAllInternalCallsList/Body

Description:
Contains a list of all active internal calls as HTML-table without the table headers.

Hiding columns from view:
Set GlobalAllCallsListHiddenColumns1=1
Set GlobalAllCallsListHiddenColumns2=2
Set GlobalAllCallsListHiddenColumns3=3
Set GlobalAllCallsListHiddenColumns4=4
Set GlobalAllCallsListHiddenColumns5=5
Set GlobalAllCallsListHiddenColumns6=6
Set GlobalAllCallsListHiddenColumns7=7
Set GlobalAllCallsListHiddenColumns8=8
Set GlobalAllCallsListHiddenColumns9=9
Set GlobalAllCallsListHiddenColumns10=10

Show colored marker in front of line instead of setting background color
Set QueueListColorLayout=ColorLeftOnly

(professional version only)


GlobalAll...CallsList filtering

Description:
It is possible to filter the global calls list on users or groups. For filtering users and groups use the following syntax:

<%GlobalAllOutgoingCallsList:User:User1%>
<%GlobalAllOutgoingCallsList/Body:User:User1%>

Filters the user by name "User1", only "User1" will be displayed

<%GlobalAllOutgoingCallsList:NoUser:User1%>
<%GlobalAllOutgoingCallsList/Body:NoUser:User1%>

Filters the user by Name "User1", all users are displayed excepting "User1"

<%GlobalAllOutgoingCallsList:Group:Group1%>
<%GlobalAllOutgoingCallsList/Body:Group:Group1%>

Filters the group by name "Group1", only users from "Group1" will be displayed

<%GlobalAllOutgoingCallsList:NoGroup:Group1%>
<%GlobalAllOutgoingCallsList/Body:NoGroup:Group1%>

Filters the group by name "Group1", all users are displayed excepting users from "Group1"

(professional version only)


Log on/off from Phone or SwyxIt!/NetPhone Client

It is possible to log on and off from a group by using the Phone or SwyxIt!/NetPhone Client. There is a sample call routing "GroupLogonLogoff.rse" included in the scripts folder in the installation folder. This call routing can be imported in ECR editor. It is also possible to create own call routing scripts with the included ECR action blocks actionCallQueueAddMember and actionCallQueueRemoveMember.

CallQueueAddMember:

This block can be used to add a user to a group.

User name: Name of the user from SwyxWare/NetPhone that should be added to the group
Group name: Name of the group from SwyxWare/NetPhone the user should be added to
Max members: Maximum amount of possible members in that group
Logging: Enables or disables logging on a logon or logoff action. Log files are written in reports\logon groups subfolder in the installation folder
Accoustic notification: Enables or disables the acoustic notification for the logon process. This should be set to "0" if multiple blocks are chained

Annotations:
· A successful operation is confirmed with a positive confirmation sound (if not deactivated)
· A unsuccessful operation is confirmed with a negative confirmation sound (if not deactivated)
· If add operation exceeds the maximum amount of members the maximum number of members is announced an a negative confirmation sound is played (if not deactivated)
· If the user is already a member of this group a negative confirmation sound is played (if not deactivated)

CallQueueRemoveMember:

This block can be used to add a user to a group.

User name: Name of the user from SwyxWare/NetPhone that should be removed from the group
Group name: Name of the group from SwyxWare/NetPhone the user should be removed from
Min members: Minimum amount of possible members in that group
Logging: Enables or disables logging on a logon or logoff action. Log files are written in reports\logon groups subfolder in the installation folder
Accoustic notification: Enables or disables the acoustic notification for the logoff process. This should be set to "0" if multiple blocks are chained

Annotations:
· A successful operation is confirmed with a positive confirmation sound (if not deactivated)
· A unsuccessful operation is confirmed with a negative confirmation sound (if not deactivated)
· If remove operation exceeds the minimum amount of members the minimum number of members is announced an a negative confirmation sound is played (if not deactivated)
· If the user is not a member of this group a negative confirmation sound is played (if not deactivated)


ECR example

The included ECR example can be used in that way:

Import the GroupLogonLogoff.rse in GSE Editor into a new created ECR rule. Save this rule and activate it. This rule should be used on a dummy user in SwyxWare.

Group name: Name of group the calling user should be added to
Minimum members in group: Minimum amount of possible members in that group
Maximum members in group: Maximum amount of possible members in that group
Logging: Enables or disables logging on a logon or logoff action. Log files are written in reports subfolder in the installation folder

To log on a member to a group, just call the number of the call routing user and add a "1" to the dialed number. To log off the member again add a "0" to the dialed number

Example:
Dummy user has number 100. For logging on user with name "User1" to the group "Group1", set "Group1" as group name parameter in the ECR rule and call 1001 from the phone or SwyxIt! of "User1". To log off this user again, call 1000. This sample script always logs on and off the calling user. It is not possible to log on or off another user. To do so use the ECR action blocks used in this example script. With these action blocks it is also possible to add and remove users from groups by calling from an external phone.


Log on/off from website

It is also possible to add and remove users from a group in web front. The parameters used to set the group parameters are described in the HTML Templates chapter. In the web page the state is visible. The status column contains the logon state of the group (logged on / logged off) and the call state of this user in braces.

To call the members view call the QueueMembers page or any copy of this page with the customized parameters. A single page for each group has to be created.
http://server:81/QueueMembers.html
http://server:81/QueueMembersSmall.html (used for SwyxIt! Webextension)

(professional version only)


Logging to database

Per default the logon and logoff actions are logged to the Reports\Logon groups folder. The logging is performed by an ODBC text driver. This behaviour can be changed in the registry.

Logging to text file (default):
· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set LogonGroupsConnectionString to "Driver={Microsoft Text Driver (*.txt; *.csv)};DBQ=C:\Programme\3iMedia Call Queue Controller for SwyxWare\Reports\Logon groups;Extensions=txt"
· Set LogonGroupsType to "Text"

Logging to a database:
· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set LogonGroupsConnectionString to "Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Trusted_Connection=Yes;"
· Set LogonGroupsType to "SQL"
· Tested on Microsoft SQL Server 2000/2005

To create the table in a database use this SQL CREATE TABLE statement:
CREATE TABLE [dbo].[QueueLogonGroups] (
[ID] uniqueidentifier ROWGUIDCOL NULL DEFAULT (newid()),
[LogOnDate] [datetime] NULL ,
[LogOffDate] [datetime] NULL ,
[UserGroup] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[UserName] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL
) ON [PRIMARY]

Annotation:
Using the connection string for SQL Server the SwyxWare/NetPhone account is used connecting to the database. This account needs sufficient rights to that database. Otherwise the following connection string can be used instead:
Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Uid=Username;Pwd=Password;


Description

SwyxWare/NetPhone writes CDR-files with call detail records into a text file or a database table. These CDR-files contain all information on incoming and outgoing calls. It exist only one CDR-record for each call. So some fields in the CDR-entry are overwritten during the call. So there is no way to get all the information needed to create reports.

To address this issue the queue controller writes its own CDR-files. In these CDR-files a new CDR-entry is created if the state of the call changes. State changes can be "queued", "initialized", "alerting", "onhold", "timeout", "rejected", "lost", "disconnected", "aborted".

So if one of these states differ from the previous state a new CDR-entry is written. The result is a complete call history for each call. These CDR-entries are only written for incoming calls, processed by the queue controller. Outgoing calls and direct calls to internal destinations are not logged.

The CDR-files are located in the reports subfolder in the installation directory. On default all CDR entries are written in TXT-files with a maximum size of 5MB. The CDR-files are numbered CDR0.txt, CDR1.txt, ... CDRx.txt.

The corresponding schema.ini contains the field structure for the CDR-files an must not be deleted

(standard and professional version)


Fields

The following fields are used in the CDR-files. To be compatible with the Swyx-CDR-files not all of the fields are used but all fields are present.

CDRCallId CallID of the call
CDROriginationNumber Originating number in canonical format
CDROriginationName Originating name if resolved by SwyxWare
CDRCalledNumber Called number in canonical or internal format
CDRCalledName Called name, normally the name of the SwyxUser or ScriptUser
CDRDestinationNumber Number of destination or group the call is delivered to
CDRDestinationName Name of destination or group the call is delivered to
CDRStartDate Start date of call
CDRStartTime Start time of call
CDRScriptConnectDate Connect date of call (may differ from StartDate if call is delivered to a destination and times out before an announcement is played)
CDRScriptConnectTime Connect time of call
CDRDeliveredDate Delivery date of call (date for each delivery attempt)
CDRDeliveredTime Delivery time of call
CDRConnectDate Connect date of call
CDRConnectTime Connect time of call
CDREndDate End date of call
CDREndTime End time of call
CDRCurrency not used
CDRCosts not used
CDRState State of call ("queued", "initialized", "alerting", "onhold", "timeout", "rejected", "lost", "disconnected", "aborted")
CDRPublicAccessPrefix not used
CDRLCRProvider not used
CDRProjectNumber not used
CDRAOC not used
CDROriginationDevice not used
CDRDestinationDevice not used
CDRTransferredByNumber not used
CDRTransferredByName not used
CDRTransferredCallId1 not used
CDRTransferredCallId2 not used
CDRTransferredToCallId not used
CDRTransferDate not used
CDRTransferTime not used
CDRDisconnectReason not used
CDRConnectedNumber Connected number in canonical or internal format
CDRConnectedName Connected name if resolved by SwyxWare
CDRCustom0 Call forwarding destination
CDRCustom1 Call tag
CDRCustom2 Call duration in seconds
CDRCustom3 for future purposes
CDRCustom4 for future purposes
CDRCustom5 for future purposes
CDRCustom6 for future purposes
CDRCustom7 for future purposes
CDRCustom8 for future purposes
CDRCustom9 for future purposes
CDRCustom10 for future purposes
CDRCustom11 for future purposes
CDRCustom12 for future purposes
CDRCustom13 for future purposes
CDRCustom14 for future purposes
CDRCustom15 for future purposes
CDRCustom16 for future purposes
CDRCustom17 for future purposes
CDRCustom18 for future purposes
CDRCustom19 for future purposes
CDRCustom20 for future purposes
CDRTimeStamp timestamp of logging entry
CDRId unique identifier

(standard and professional version)


Logging to database

Per default the CDR entries are logged to the Reports\CDR folder. The logging is performed by an ODBC text driver. This behaviour can be changed in the registry.

Logging to text file (default):
· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set CDRConnectionString to "Driver={Microsoft Text Driver (*.txt; *.csv)};DBQ=C:\Programme\3iMedia Call Queue Controller for SwyxWare\Reports\Logon system;Extensions=txt"
· Set CDRType to "Text"

Logging to a database:
· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set CDRConnectionString to "Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Trusted_Connection=Yes;"
· Set CDRType to "SQL"
· Tested on Microsoft SQL Server 2000/2005

To create the table in a database use this SQL CREATE TABLE statement:
CREATE TABLE [dbo].[CDR] (
[CDRCallId] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDROriginationNumber] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDROriginationName] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCalledNumber] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCalledName] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRDestinationNumber] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRDestinationName] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRStartDate] [datetime] NULL ,
[CDRScriptConnectDate] [datetime] NULL ,
[CDRDeliveredDate] [datetime] NULL ,
[CDRConnectDate] [datetime] NULL ,
[CDREndDate] [datetime] NULL ,
[CDRCurrency] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCosts] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRState] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRPublicAccessPrefix] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRLCRProvider] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRProjectNumber] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRAOC] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDROriginationDevice] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRDestinationDevice] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRTransferredByNumber] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRTransferredByName] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRTransferredCallId1] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRTransferredCallId2] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRTransferredToCallId] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRTransferDate] [datetime] NULL ,
[CDRDisconnectReason] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRConnectedNumber] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRConnectedName] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom0] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom1] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom2] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom3] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom4] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom5] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom6] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom7] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom8] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom9] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom10] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom11] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom12] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom13] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom14] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom15] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom16] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom17] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom18] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom19] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRCustom20] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[CDRTimeStamp] [datetime] NULL ,
[CDRId] [bigint] IDENTITY (1, 1) NOT NULL
) ON [PRIMARY]

Annotation:
Using the connection string for SQL Server the SwyxWare/NetPhone account is used connecting to the database. This account needs sufficient rights to that database. Otherwise the following connection string can be used instead:
Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Uid=Username;Pwd=Password


Description

The queue controller is aware of the logon state of any user in SwyxWare. For these users a log file can be written containing all logon and logoff activities.

(professional version only)


Usage

The usage of this feature is very simple. For each group that should be monitored a MBR-File has to be created in the reports\logon system subfolder of the installation directory. The queue controller adds a second file to this MBR-file every 10 seconds. In that LOG-file the logon and logoff activities are logged.

Example:
An empty Everyone.mbr file has been placed in the logon system folder under the reports folder. A short time after the MBR-file is filled with the group members of the group "everyone". Further an Everyone.log file has been generated. If someone logs off from the everyone group in SwyxWare/NetPhone a log entry will be written to the log file.

The log file looks like this:
02.12.2008 20:52:46;User1;logged off;logged on
02.12.2008 20:53:38;User1;logged on;logged on
02.12.2008 21:13:41;User1;new;logged on
02.12.2008 21:15:56;User2;new;logged on
02.12.2008 21:22:10;User2;logged on;logged off

The log file contains the date and time, the username, the actual state of this user and the new state of the user.


Logging to database

Per default the logon and logoff actions are logged to the Reports\Logon groups folder. The logging is performed by an ODBC text driver. This behaviour can be changed in the registry.

Logging to text file (default):
· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set LogonStateConnectionString to "Driver={Microsoft Text Driver (*.txt; *.csv)};DBQ=C:\Programme\3iMedia Call Queue Controller for SwyxWare\Reports\Logon system;Extensions=txt"
· Set LogonStateType to "Text"

Logging to a database:
· Open registry editor regedit.exe
· Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare
· Set LogonStateConnectionString to "Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Trusted_Connection=Yes;"
· Set LogonStateType to "SQL"
· Tested on Microsoft SQL Server 2000/2005

To create the table in a database use this SQL CREATE TABLE statement:
CREATE TABLE [dbo].[QueueLogonState] (
[ID] uniqueidentifier ROWGUIDCOL NULL DEFAULT (newid()),
[UserGroup] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[UserName] [nvarchar] (255) COLLATE Latin1_General_CI_AS NULL ,
[LogOnDate] [datetime] NULL ,
[LogOffDate] [datetime] NULL ,
[AddedToGroup] [bit] NULL
) ON [PRIMARY]

Annotation:
Using the connection string for SQL Server the SwyxWare/NetPhone account is used connecting to the database. This account needs sufficient rights to that database. Otherwise the following connection string can be used instead:
Driver={SQL Server};Server=[ServerName];Database=[DatabaseName];Uid=Username;Pwd=Password


Registry Settings

Registry entry are located under HKLM\SOFTWARE\3iMedia\Call Queue Controller for SwyxWare

Name | Default | Type | Description
CallQueueReloadTimeout | 2 | REG_DWORD | Refresh timeout used for reloading the content of a html page
CDRConnectionString | Driver={Microsoft Text Driver (*.txt; *.csv)};DBQ=C:\Programme\3iMedia Call Queue Controller for SwyxWare\Reports\cdr;Extensions=txt | REG_SZ | ODBC connect string for connecting to database
CDRConnectionTimeout | 5 | REG_DWORD | Connection timeout for connection to database
CDRFileIndex | 0 | REG_DWORD | Current index of CDR text file (not used if logging to SQL database is used)
CDRFileMaxSize | 5242880 | REG_DWORD | Maximum file size for CDR text file (not used if logging to SQL database is used)
CDRType | Text | REG_SZ | Type of logging, text for TXT-files, SQL for database logging
InstallPath | %ProgramFiles%\3iMedia Call Queue Controller for SwyxWare | REG_SZ | Installation folder
IpPbxServer | localhost | REG_SZ | IP address of SwyxWare/NetPhone server, change only if Queue Controller is running on another server other then SwyxWare/NetPhone server
QueueControllerServer | localhost | REG_SZ | IP address of Queue Controller server, change only if Queue Controller is running on another server other then SwyxWare/NetPhone server
Port | 81 | REG_DWORD | Webserver port used for front end. If port 81 is already used by another application the port have to be changed
ServicePort | 59988 | REG_DWORD | Webservices port used for .Net service
Webdir |  | REG_SZ | Path to the html files located on the webserver


Licensing

The installation package contains a 30 day trial version. To activate this version please contact license@3imedia.de. To activate the license we need the volume id of the hard disc the product is installed.

To determine the volume id perform the following steps:

· Start - Run
· Type "cmd"
· In the command line type "dir"

The output should look similar to that:

The volume id is the number in the upper part of the screenshot. In that case it's A835-3D36

After sending us the volume id together with company name and adress we deliver a license file with further informations. This license file has to be saved in the applicaion installation folder.


Version history

Version 3.02:
· Webserver: Number resolution for outgoing calls against 3iMedia Metaservices
· Webserver: New tag <%Set QueueListColorLayout=ColorLeftOnly%> in html pages to display the background color only in front of the line
· Webserver: PickupDestination in URL can include the SwyxWare/NetPhone user name. So in SwyxIt! WebExtension %OwnName% can be used
· Webserver: New style sheets
· Webserver: Webserver included in QueueController, only one exe file
· General: Performance optimizations in Webserver and QueueController

Version 3.01:
· Webserver: New Http listener
· Genereal: Some minor fixes

Version 3.00:

· Frontend: Live reporting, integration with 3iMedia Reporting Services
· Frontend: New design
· Frontend: Hide actions in calls list
· Frontend: Faster html parsing
· Frontend: Delete button for lost call

· Queue: Simple, Advanced Callback
· Queue: New delivery scenarios, "Custom", "SequentialAdvX", "RotaryAdvX"...
· Queue: Logging to database for groups logon and system logon states
· Queue: Changes on CDR, no time fields any more, empty fields are left null
· Queue: Assembly redirection to support multiple SwyxWare/NetPhone platforms

· General: Better logging for support
· General: Possibility to separate Queue Controller from SwyxWare/NetPhone